RDR2 issue with Lenovo X1 Extreme Gen 2 + Razer Core X + AMD RX 5700 XT
 
Notifications
Clear all

RDR2 issue with Lenovo X1 Extreme Gen 2 + Razer Core X + AMD RX 5700 XT  

  RSS

Noak
 Noak
(@noak)
New Member
Joined: 2 months ago
 

my setup config:

laptop: Lenovo X1 Extreme Gen 2, i7-9750H, 16G RAM, Samung P981a 512GB NVMe and Samsung 860 EVO M.2

i/dGPU: UHD 630 and dGPU Nvidia GTX1650 Max-Q Design

eGPU: Razer Core X with Gigabyte Gaming OC AMD Radeon RX 5700XT

Windows: Win 10 Pro ver 1909, OS build 18363.836 put pci.sys using bas_timer temp fix from 1903 v1

AMD driver: 20.4.2 (tried 20.2.2 and 19.11.3)

Nvidia driver: 445.87

monitor - in-built laptop monitor

 

I have been running the eGPU without issues for games like Sekiro, GTA V, Witcher 3 on Steam and Borderlands 3 on Epic Games and in each case, I was able to verify by task manager that the current GPU (i.e. the eGPU was running). I did not have to disable the Nvidia dGPU on my laptop either, nor choose the app to run high performance via Graphics Settings in Windows.

My main problem is RDR2. I have no issue running the game if the eGPU is not connected, it uses the dGPU and things worked. However, when I connect the eGPU, the game refuses to launch. If I set Graphics Settings to power savings, it will run with iGPU and start up properly. When i switch Graphics Settings to high performance, the game will not launch.

Looking at the Rockstar Games > Launcher > launcher log,warning reported is "60seconds and still no game windows", followed by "Game exited with code 0xc0000005 (3221225477)". I have tried various solutions online but to no avail.

Things that I have already tried:

Graphics Settings - RDR2.exe to high performance

RDR2.exe -  disable full screen optimization (run this as administrator option couldn't work even if I change all related files on epic, R* and RDR2 executables)

AMD driver, roll back to 20.2.2, roll back to 19.11.3 and use switchable graphics

RDR2's settings.xml - tried running windowed borderless, DX12, Vulkan

disabling dGPU via device manager

tried eGPU outputting to my Acer X34P monitor, didn't work either

 

RDR2, Epic, R* launcher are all on latest build. RDR2 just refuses to recognize the eGPU or have problem running it yet while searching for solutions online, most point to the initial launch hiccups.

 

Any help would be appreciated. Thanks!

Lenovo X1 Extreme Gen 2, i7-9750H with GTX 1650 Max-Q + Razer Core X + Gigabyte AMD RX 5700 XT


ReplyQuote
LeeMadderBanyan
(@leemadderbanyan)
New Member
Joined: 7 days ago
 

@noak, Hi, I had the same problem. I somehow find a solution. Go to graphics setting add RDR2.exe set into power saving mod. It will run in intel graphics which is very slow. Then go to graphics setting in RDR2, set graphics working on 1 (or maybe 2 for yours since you have 3 graphics cards). Then with the game running, go back to windows setting switch from power saving to default. This way you can use 5700xt to run the game and you have to do this every time before you gaming. The only problem of this solution is resolution is fixed at 1080p, I have a 4k screen and I have to set system resolution to 1080 before running the game. If you have 1080 screen, everything should be fine. I hope this works for you. Nerd  

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote