BSOD when trying to output the video from eGPU to external monitor (Asus Zenbook...
 
Notifications
Clear all

BSOD when trying to output the video from eGPU to external monitor (Asus Zenbook UX325JA [10th,4C,8T] + 2060S @ 32Gbps-TB3 Razer Core X)  

  RSS

Nikita Ar4ikov
(@nikita_ar4ikov)
Active Member
Joined: 2 years ago
 

Hello there! 

I'm still getting problem with my eGPU and my new notebook.
Notebook setup: ASUS Zenbook UX325JA
eGPU enclosure: 2060 SUPER @ 32Gbps-TB3 Razer Core X 

 

The problem is: everytime when I trying to output the video and rendering from my 2060S in Core X, there is BSOD after 1-3 hours. But in some cases, there is no shown BSOD as well, just complete system failure. Earlier I'd got KERNEL_MODE_HEAP_CORRUPTION (0x0000013a), but the default solution like reinstall video drivers with DDU and win safety mode, reinstalling audio and wifi drivers, and reinstalling intel uhd graphics driver didn't work generally (but you can correct me in anytime). For today I don't know the certain BSOD error cause I can't see that). 

After all of that, I use output from my internal UHD graphics and rendering all tasks through eGPU. Low performance, High latencies.. Bad idea to do like that 🙁

Googling and search the same topic on this forum also did not lead to any result. So, if this problem is so rare, that the great possibility to fix it and add another solved problem to the forum collection Smile

This topic was modified 2 months ago
2020 13" ASUS ZenBook UX325JA [10th,4C,U] + RTX 2060 Super @ 32Gbps-TB3 (Razer Core X) + Win10 [build link]  

ReplyQuote
Boltoway
(@boltoway)
Estimable Member
Joined: 3 years ago
 

@nikita_ar4ikov

Here is a possible solution:

 

Open the Windows Registry Editor (regedit.msc) and navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers. 

Now create a new 'DWORD (32-Bit) Value'. It should look like this:

RegeEdit 1

Name it TdrDelay. After it has been created, right click on it and select Modify. Change the Base from Hexadecimal to Decimal, add a Value Data of 10 and select OK. 

Create another 'DWORD (32-Bit) Value'. Name it TdrDdiDelay. Change the Base from Hexadecimal to Decimal, add a Value Data of 20 and select OK. 

It should look like this:

RegeEdit 2

Restart your system.

(What this does is essentially allows Windows to give the GPU more time to respond or recover from an issue. It has fixed crashes for me on a couple of systems.)

 

Another thing you can do is change the NVIDIA Power Management Settings to Prefer Maximum Power. You can find this in the Manage 3D Settings tab of the Nvidia Control Panel.  

 

2021 14" Lenovo Yoga Slim 7i Pro (MX450) [11th,4C,H] + RTX 3060 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 21H1 [build link]  

ReplyQuote
Nikita Ar4ikov
(@nikita_ar4ikov)
Active Member
Joined: 2 years ago
 

@boltoway, Thank you sooo much, man Smile <3
I've also found out one more way to solve it. In coupe of your solution, it works pretty well. But I'm still waiting and testing it for a week
https://egpu.io/forums/pc-setup/video_tdr_failure-bsod-error-with-rtx-3070-and-razer-core-x/#post-94440

 

This post was modified 2 months ago
2020 13" ASUS ZenBook UX325JA [10th,4C,U] + RTX 2060 Super @ 32Gbps-TB3 (Razer Core X) + Win10 [build link]  

Boltoway liked
ReplyQuote