Setup & Software Discussions
EFI Boot partition doesn't launch windows after MacOS update
 

EFI Boot partition doesn't launch windows after MacOS update  

  RSS

(@drew_neely)
New Member
Joined: 4 months ago
 

I have a mantiz eGPU enclosure with an AMD RX 580. About a month ago I set this up with bootcamp by creating an EFI partition and putting a file called bootx64.efi in the EFI/Boot directory. I did all the necessary windows driver stuff and it worked for a month until yesterday I updated MacOS to Mojave 10.14.5 and now when I attempt to boot into the EFI partition it launches MacOS instead of Windows. The enclosure and GPU still work fine in MacOS. What might be wrong? I can't seem to find people having similar problems.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

Following every macOS update, the system sets macOS partition as default boot volume. You’d need to bless the Windows partition to be the default boot volume.

Best ultrabooks for eGPU use

eGPU enclosure buying guide


ReplyQuote
nu_ninja
(@nu_ninja)
Estimable Member
Joined: 1 year ago
 

I wrote a little quick action applescript that I run when this happens to me.

on run {input, parameters}
 set output to do shell script "csrutil status"
 if output contains "NVRAM Protections: disabled" then
  set output2 to true
 else
  set output2 to output does not contain "enabled"
 end if
 if output2 then
  do shell script "bless --setBoot --folder /Volumes/rEFInd/System/Library/CoreServices/ --file /Volumes/rEFInd/System/Library/CoreServices/refind_x64.efi" with administrator privileges
  display dialog "Bootloader set to rEFInd" buttons {"OK"} with title "rEFInd Set Boot"
 else
  display dialog "Error: SIP enabled" buttons {"OK", "Reboot"} with title "rEFInd Set Boot"
  if the button returned of the result is "Reboot" then
   do shell script "shutdown -r now" with administrator privileges
  end if
 end if
 return output2
end run

obviously change the folder and file path to yours.

Mid-2012 13" Macbook Pro (MacBookPro9,2) TB1 -> RX 460/560 (AKiTiO Node/Thunder2)
+ macOS 10.14+Win10
+ Linux Mint 19.1


itsage liked
ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 3 years ago
 

@nu_ninja Suggestion: maybe using a Launch Daemon would be a more automated approach 😉

This post was modified 4 months ago

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
2018 MacBook Pro 15" RP560X + Vega 64 (Mantiz Venus MZ-02)


itsage and nu_ninja liked
ReplyQuote