eGPU error 12 fail after update to Windows 10 1903 (OS Build 18362.329 or newer)
 

[Solved] eGPU error 12 fail after update to Windows 10 1903 (OS Build 18362.329 or newer)  

 of  13
  RSS

(@mofackin)
New Member
Joined: 2 months ago
 

As an addendum to my earlier post, I was never able to get my laptop to work on 1903.295, I had to go back to 1809 to actually get it to function before I decided to try this. Is there any sequence of events  that I can try? Will the pci.sys from 1809 version work here in this set up?

Razer Blade 2019 Early Advanced - 2060M - 16gb - 1TB HDD. Razer X Chroma with Radeon VII 16gb.


ReplyQuote
Creegan
(@creegan)
New Member
Joined: 4 weeks ago
 

@florin_samareanu

The pci.sys trick worked like a charm- thanks so much! Now that I'm able to enable the eGPU, I'm running into a different problem.

 

I disabled my discrete GPU, updated the eGPU drivers, and ran the SteamVR benchmark, but it ran horribly. It says the main problem is my CPU, which has never been an issue when I tested the benchmark before using the eGPU. Am I running into a bottleneck or some kind of issue?

 

Thanks again!

 

EDIT- Please let me know if this is considered a separate question/should be posted elsewhere. Thanks!

This post was modified 4 weeks ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
confidantduck
(@confidantduck)
Eminent Member
Joined: 3 years ago
 

@gregor_pigula

Just wanted some clarity on this, was there a particular reason you had to boot from an emergency drive to replace the file?

If you gave yourself ownership over the file and removed trusted installer access, wouldn't we be able to do it without booting from an emergency drive? Just asking to see if I am misunderstanding anything.

Current setup: Lenovo Yoga C740 + Razer Core V2 + 5700XT

Prev setup 3: Razer Blade Steath (early 2019) + Razer Core V2 + Vega 56

Prev setup 2: Late 2016 Razer Blade Stealth, Powercolour devil box + gtx 1060

Prev setup 1: 2016 13" MBP (no touchbar)
Powercolor Devil Box + GTX 1060/GTX 980(succeeded somewhat), RX480 Nitro+ 4GB(attempted but failed)


ReplyQuote
confidantduck
(@confidantduck)
Eminent Member
Joined: 3 years ago
 

@ahendarman

also clarifying here(with the assumption we do this AFTER the update), do we rename and/or replace the pci.sys files?

like, rename the old pci.sys file to "pci2.sys" and copy the intended pci.sys file in?

Or do we replace the existing pci.sys file with the intended file? 

Or both(which doesn't make much sense tbh?)

just wanna be clear on the exact steps to attempt this

Current setup: Lenovo Yoga C740 + Razer Core V2 + 5700XT

Prev setup 3: Razer Blade Steath (early 2019) + Razer Core V2 + Vega 56

Prev setup 2: Late 2016 Razer Blade Stealth, Powercolour devil box + gtx 1060

Prev setup 1: 2016 13" MBP (no touchbar)
Powercolor Devil Box + GTX 1060/GTX 980(succeeded somewhat), RX480 Nitro+ 4GB(attempted but failed)


ReplyQuote
(@gregor_pigula)
New Member
Joined: 1 month ago
 

@confidantduck

For me it was the fastest way to replace the file, no need for playing with permissions.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
glowi
(@glowi)
New Member
Joined: 6 months ago
 

@mofackin

According to my experience, 1909 refuse to boot with pci.sys from 1809. So far I am stuck with 1809 

HP Zbook Studio G5 x360 (Intel Core i7 8850 + Nvidia Quatro P1000) + eGPU Gigabyte Aorus Gaming Box GF 1070


ReplyQuote
ahendarman
(@ahendarman)
Active Member
Joined: 1 year ago
 

@confidantduck

I renamed the 1903/1909 pci.sys (using the method described above) and copied the older pci.sys

the 1903/1909 pci.sys is 427KB, the older pci.sys (prior to the update in 1903) is 425KB

 

Razer Stealth 13" (early 2019), Razer Core X Chroma, Sapphire Nitro+ RX 5700XT
Macbook Pro 13" (2018), Mantiz Venus, XFX RX 580


ReplyQuote
(@florin_samareanu)
Active Member
Joined: 2 months ago
 

Tested latest insider and, at least on a nuc, the pci.sys trick isn't needed anymore (plugged egpu,error 12, ran windows update, disabled fast boot, updated, no more code 12).

Also, for the laughs: https://www.3dmark.com/3dm/42463495 (nuc7i7 5700xt).

insider
This post was modified 3 weeks ago

16'' Macbook Pro - Razer Core X Chroma - PowerColor Red Devil 5700XT - LG 27UK850


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@florin_samareanu Thank you for the report and success with your NUC7i7. I tried the same Insider version as you (Version 2004 OS Build 19041.1) on the 2019 13″ MacBook Pro this morning. Unfortunately it wasn’t the same luck. Error 12 remains an issue on this machine. Worse yet I wiped my manual restore points of 295 so I will try the pci.sys swap next.

 

This post was modified 3 weeks ago

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
enderq
(@enderq)
Active Member
Joined: 1 year ago
 

@florin_samareanu

Maybe you can share the pci.sys of your insider version somewhere and we can experiment a bit without changing or reinstalling windows versions.

Maybe its the same can you find version and size of that pci.sys?

This post was modified 3 weeks ago

Macbook pro 15" 2017, Razer Core X, RTX2080 to Dp port connected 165hz 27 inch rog lcd. Stand alone Windows 10 pro Build 18362.19h1_release.190318-1202 on external ssd with bootcamp drivers (from Mojave, needs updating).


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago

ReplyQuote
shaym
(@shaym)
Active Member
Joined: 1 year ago
 

Hi.

I have a mac mini 2018 version with razer core x and vega 64 my problem is even when I try to install windows version 1809/1903 ( Bootcamp ) I still get a black screen when using my egpu only the internal intel GPU works to see windows can someone tell me what I'm doing wrong what is the correct way to install windows and use my egpu until a fix version of windows will be out...? 

Thanks,

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Trusted Member
Joined: 5 months ago
 

@shaym

Which Mac OS version are you running? 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.1 Catalina / LG 27" 4K display


ReplyQuote
shaym
(@shaym)
Active Member
Joined: 1 year ago
 

OS X catalina.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
enderq
(@enderq)
Active Member
Joined: 1 year ago
 

@shaym

Does it turn black after login, is there a mouse pointer? I had this long ago and recently with install latest 1903 1909  pushed windows and x key multiple times and got my screen back. It has to do  with multiple screen config I think. Multiple YouTube instructions on it.

 

Macbook pro 15" 2017, Razer Core X, RTX2080 to Dp port connected 165hz 27 inch rog lcd. Stand alone Windows 10 pro Build 18362.19h1_release.190318-1202 on external ssd with bootcamp drivers (from Mojave, needs updating).


ReplyQuote
shaym
(@shaym)
Active Member
Joined: 1 year ago
 

1. I don't see any mouse and pointers at all and no it's black from the start no windows boot screen at all.

2. I didn't try the windows and x combination but when I install windows from my mac it is when only the egpu I connected.

3. do you have a link to a youtube video so I can see..?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
slindshady
(@slindshady)
New Member
Joined: 3 weeks ago
 

@mac_editor

Yeah, thats why I tried it. Didn't do anything for me unfortunately. This is with Radeon 5700 XT and Core Chroma / Core X
2080 TI works out of the box. This is starting go give me way more hassle than I thought. Might just have to build a second desktop. 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@slindshady

That's unfortunate to hear. I think what might have happened in the Redditor's case is that they may have performed the pci.sys replacement before updating, and by doing so, denied the installer the permissions to replace it(?) - or something like it. Could only be validated by verifying the driver I suppose.

purge-wranglerpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro


ReplyQuote
Mini i5
(@mini-i5)
Trusted Member
Joined: 5 months ago
 

@shaym

10.15.1 works fine with 1809 on the 2018 Mini. (If anyone else is on 10.15.1 - stay there! 😉)

10.15.2 does not and complicates eGPU use in general (according to many others). 10.15.2 includes a much-unloved firmware update. It can’t be undone by restoring back to 10.15.1. Good times! 🤦‍♂️

10.15.3 should arrive this month.

This post was modified 3 weeks ago

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.1 Catalina / LG 27" 4K display


ReplyQuote
swithdrawn
(@swithdrawn)
Active Member
Joined: 2 years ago
 

I've had success using the posted PCI.sys on 1909 to solve error 12. I'm running 10.5.2 on my 2018 MacBook Pro 15" and Radeon VII. Didn't have to disable any h/w. Happily playing The Witcher 3! Thank you everyone. 

XFX Radeon VII, Sonnet Breakaway Box 550 (with upgraded PSU), mid-2018 MacBook Pro 15" (2.9Ghz 6-core i9, 32GB Ram)


ReplyQuote
enderq
(@enderq)
Active Member
Joined: 1 year ago
 

@shaym

Try unplugging all usb-c stuff from razer core x if any are plugged in for me anything plugged in is no booting at all but that is on a macbook pro 2017 15 inch.

My black screen issue was only after login so not relevant for you.

Macbook pro 15" 2017, Razer Core X, RTX2080 to Dp port connected 165hz 27 inch rog lcd. Stand alone Windows 10 pro Build 18362.19h1_release.190318-1202 on external ssd with bootcamp drivers (from Mojave, needs updating).


ReplyQuote
shaym
(@shaym)
Active Member
Joined: 1 year ago
 

I did try disconnected all from the USB-C still no go I'm on 10.15.2 and even the PCI.sys trick didn't work hope Microsoft and apple fix this thing soon. but it looks like not apple and not Microsoft really cares about fixing this it's taking far to long for them to fix this.

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
JMGmr2
(@jmgmr2)
Active Member
Joined: 4 months ago
 

Haven’t tried the sys file yet.  itsage where did you hear that AMD’s XConnect team was working on this?  They’ve been aware of this for months now.

 

I'm currently in a long back and forth with AMD support over this and I linked this thread.  I’m sure the issue could be resolved between AMD and MS in 5 min.  I don’t even get error 12.  I simply black screen when Windows updates. 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
atlr
 atlr
(@atlr)
Active Member
Joined: 10 months ago
 

Build 19541 did not solve Error 12 with Radeon 5700 and a Dell 7730 laptop.  

 

User of eGPUs at my job.


ReplyQuote
precision01
(@precision01)
Trusted Member
Joined: 3 years ago
 

Did anyone had any luck using Radeon RX 5700 XT with a Windows 10 version newer than 1903.295?

Razer Core X + AMD Radeon RX 5700 XT - Macbook Pro 15" Mid 2019 Radeon 560X


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@precision01 This issue affects the host computer rather than a particular graphics card. I believe all Macs with Apple T2 Chip have this issue in Boot Camp. The pci.sys file replacement from Win10 1903 V1 ISO is the only workaround if you need to run latest Windows version.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
precision01
(@precision01)
Trusted Member
Joined: 3 years ago
 
Posted by: @itsage

@precision01 This issue affects the host computer rather than a particular graphics card. I believe all Macs with Apple T2 Chip have this issue in Boot Camp. The pci.sys file replacement from Win10 1903 V1 ISO is the only workaround if you need to run latest Windows version.

Interesting, @itsage. Do we just have to replace pci.sys from any Windows 10 version with the one from Windows 10 1903.295? If it is not that simple, are there instructions for that workaround here on eGPU.io?

Razer Core X + AMD Radeon RX 5700 XT - Macbook Pro 15" Mid 2019 Radeon 560X


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 1 year ago
 

@itsage

I have the same issue with windows 1803 since the last and final update in December. 

As windows 1803 will not be updated again, what would you recommend? 

 

Best

 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
 @Os
(@os)
Active Member
Joined: 1 week ago
 

Build: Mac mini 2018 + Razer Core x +  Readon Rx 5700 (NOT XT) + Catalina 10.15.2 + Windows 10 1909   .535 

Tricks tried to fix Error 12: 

- pci.sys file swap 

- efi boot file (later figured it is irrelevant to mini)

- Downgrading windows 10 to .295 (didn’t work for me + People mentioned steam and Xbox don’t work on older windows versions) 

- Hot plug (card works but error 12 + later realized doesn’t work for AMD cards) + cold plug (Windows 10 doesn’t bolt beyond the logo) 

- Changing thunderbolt slot (tried all 4 of them with no success) 

- Disabling Pci Root and/or disabling iGPU. 
- reinstalling windows 1903 v1 (doesn’t boot beyond logo with eGPU connected) 

- Contacted AMD, Apple and Microsoft ( non wanted to take the blame especially AMD and Microsoft) 

Lets plz keep the topic for mac mino only because other fixes DONT work for mini. And EACH mac type and version is different. 

if someone tried something else, please share! 

Mac mini + Razer Core x + PowerColor RX 5700XT + Catalina 10.15.2


ReplyQuote
Test1
(@test1)
Active Member
Joined: 11 months ago
 

Have been on the .295 update since this first started to occur (and works almost perfectly). Just wanted to check the progress on the current state with AMD cards. Doesn't seem to have evolved to the extremes. But the pci.sys provided by @florin_samareanu sounded interesting. Seems that it still doesn't work for everyone though (which is heartbreaking). But I might give it a go if I have time this week on my MBP 15" touchbar 2016 + Vega56.

It seems that the Nvidia eGPU solutions still works best in bootcamp. I have a hard time believing that the teams at Nvidia is working/prioritizing to get specific eGPU solutions to work. It's more likely an effect of how their cards operate in general, being more efficient and not as highly resource dependent as AMD cards that their cards still works after recent MS updates. 

Is it confirmed what happened with the updates from .295 going forward? Why specifically that update works and not .329 . Right now it seems that most people (including me) by trial and error tries version to see what works, and stick with it without actually figuring out what caused it in the first place. We can try to *poke* MS and AMD for fixes (which we definitely should). But i think we might need more solutions like @florin_samareanu provided (even tho it was not a mac). 

Disclaimer: even though I am a computer science student (currently studying). I am by no means a hacker and programming isn't my favorite subject. I'm looking at .329 patchnotes from the 30th of August: https://support.microsoft.com/en-us/help/4512941/windows-10-update-kb4512941

Trying to see what changes could have caused it. Has anyone done more research within these patchnotes and come up with a theory previously? It's also likley that some changes were not included in this patchnote MS part.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 3 years ago
 

Downgrading didn't work for me. I hate being forced to use this piece of crap OS for gaming. How do you fix? I'm running Windows 1903.

This post was modified 1 week ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 1 year ago
 

Hi there I just made a clean instal of bootcamp windows 10 1909 on an ext ssd. I have now windows with various updates ready to download and install. I have not connected my gpu yet. 

Based on my A setup as seen below what are the recommended steps for a successful s installation?

 

thanks in advance 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
 @Os
(@os)
Active Member
Joined: 1 week ago
 

Did the new bootcamp update fix the error 12 on mac mini? I am kinda worried about installing it coz I don’t wanna complicate things more. 

Mac mini + Razer Core x + PowerColor RX 5700XT + Catalina 10.15.2


ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 1 year ago
 

My windows 1903 version 18362.295 was updated to 18362.592 yesterday.

This is what I did to enable egpu.

  1. Disable PCIE Root port#3 -9DBA
  2. Shut down windows
  3. Power cycles egpu (turn off at least 30 secs)
  4. Turn on egpu, connect TB3 cable to laptop, (Turn on laptop)
  5. Use Refind to enable internal graphics

Tested on MBP 13 2018 i5 Touchbar with external display both with Aorus Gaming Box RX580 and Mantiz Venus. 

MacOs Mojave 10.14.6

AMD ver 19.12.3

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT


atlr liked
ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 1 year ago
 

@badtz

Can you please point to guides for doing steps 1 and 5. 

Where is the the PCIE Root port#3 -9DBA ?

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 1 year ago
 

@tsakal

.295 is better for egpu. Less hassle. Just hot plug and it would connect. 

To disable pcie port #3, open your device manager (Command-X). Under system devices you should find Intel PCI Express Root Port #3. (This is your wireless adapter). 

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT


ReplyQuote
 of  13