eGPU error 12 fail after update to Windows 10 1903 or newer (OS Build 18362.329 ...
 
Notifications
Clear all

[Solved] eGPU error 12 fail after update to Windows 10 1903 or newer (OS Build 18362.329 or newer) inc downgrade pci.sys version solution  

 of  69
  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

@itsage rEFInd doesnt work in newer windows builds? Care to share more details? Thats my usual go to and has been working flawless... now I'm worried!

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@eightarmedpet Sorry I didn't make it more clear. That statement was in the context of the 2016 15" MacBook Pro. It needs DSDT override and automate-eGPU EFI method works but the older rEFInd method @shaun_kim was using doesn't work to resolve error 12.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago

ReplyQuote
Shaun Kim
(@shaun_kim)
Active Member
Joined: 9 months ago
 

@itsage

Bless you! I am now able to use my eGPU without code 12 following your guide! I didn't even need to a clean install of Windows is the best part of all this.

Here's what I did prior to following your guide:

1) Boot in OSX
2) Mount ESP volume
3) Delete refind folder

Also, when creating the FAT partition it would initially fail to format but did make the partition, so just reattempting to format said partition worked.

I don't know how useful this is but I thought it'd be something to note for those who want to make a work around without clean installing.

Once again, this build is a 2016 15" TbMBP RP460 + Razer Core X + Vega 64 with Windows 1909 18363.418 build.

Thank you again@itsage! You're a godsaver 😀

Late 2016 tbMBP 15" + Razer Core X + Vega64 + Windows 18.362.418 + Adrenalin 19.8.1 + goalque's automate-egpu


itsage liked
ReplyQuote
Nelson Ten
(@nelson_ten)
Active Member
Joined: 9 months ago
 

@itsage, what’s a good recommended os build for windows 10? On Microsoft’s website there’s one October 2018 and May 2019. Would it be better to get the October one and leave as is or update it somewhat a little then attempt to use the eGPU?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Knot3D
(@knot3d)
Active Member
Joined: 1 year ago
 

FFS.... Just overnight my RTX2070 stopped working again, although this time, I don't think .418 is the culprit - but I have no idea what is though.

 

Usually, when I'd hotplug it, there would be a double chime - then the egpu would turn on and I'd accept it via the TB3 software dock. 

Since today, the TB3 software accepts the egpu and it activates, but I can only hear a single chime and the egpu is nowhere to be seen in

device manager and nvidia control panel doesn't activate either.

Going back to .295 build did not resolve anything either - so atm I am quite disgusted and disappointed. There have been no Win10 updates

over the past few days so I think I can rule that out.

HP Spectre X360 13inch Diamand Cut 2019 i7 - 8565U with 8Gb RAM + Aorus Gaming Box RTX2070


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@nelson_ten The most eGPU friendly OS Build of Win10 so far is Win10 1903 V1 like @deduwka recommended. This particular ISO is no longer available on Microsoft download website. You'd have to search around for it. 

@shaun_kim I'm glad to hear it's working with automate-eGPU EFI. My 2016 15" MacBook Pro is currently running Win10 1909 OS Build 18363.418 and the RX Vega LC eGPU remains working with the same boot procedure.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
viciousmoth
(@viciousmoth)
Active Member
Joined: 9 months ago
 

Hello, I am new both to the forum and to using an eGPU. I'm doing as much research as possible before asking questions.

I have a Mac Mini 2018, and plan to purchase a Razer Core X with a Vega 64 (or a 5700 XT) to use with Windows. I am planning to use my internal drive for bootcamp, and use an external for storing large games. The bootcamp instructions have me go to a Windows site for the Windows 10 iso from either October 2018 or May 2019. Will either of those work to start? I have looked very carefully at the How To guide on this site a few times. I am trying to wrap my head around this thread of how the most recent updates have broken some compatibility, and how to prevent potential mistakes as I do this for the first time. Maybe I just need to wait this thread out to see what happens with solutions or new Windows updates? Any help would be appreciated. Thanks.

Mac Mini (2018) 3.2 Ghz 6-core i7, 32GB Ram, 500gb SSD
Enclosure: Razer Core X - GPU: Sapphire Radeon Nitro+ 5700 XT Monitor: BenQ EW3270U


ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 
Posted by: @itsage

@nelson_ten The most eGPU friendly OS Build of Win10 so far is Win10 1903 V1 like @deduwka recommended. This particular ISO is no longer available on Microsoft download website. You'd have to search around for it. 

@shaun_kim I'm glad to hear it's working with automate-eGPU EFI. My 2016 15" MacBook Pro is currently running Win10 1909 OS Build 18363.418 and the RX Vega LC eGPU remains working with the same boot procedure.

When I installed 1903 over 1803, I got build 418 but was able to uninstall that to get build 1 and then update to build 295 manually.

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
realistic
(@realistic)
Active Member
Joined: 2 years ago
 

This seems like an interesting issue. 

I had an RX480 with 15'' 2018 MBP running through all the 'problematic' updates, including .329, ?.359? and .418 as good as any 1903. I never had to do anything, in fact I have never seen the dreaded error 12 with my 15'' 2018 MBP + rx480, everything had been plug'n'play so far.

1903 was though way worse than 1809, because with 1809 I was easily able to achieve a situation where I had my dGPU RP555x running internal screen and eGPU rx480 running my external screen by making a autoninstaller of rx480 ( = uninstall it from device manager ) when shutting PC down. 1903 this dGPU+eGPU config seemed to be impossible, I always got black screen on internal screen when trying to use dGPU. With iGPU ( with iGPU fix ran from USB during boot) I got internal screen running, but I was not the most satisfied.

So 1903 was way worse than 1809 for my specific needs with RX480

Yesterday I decided to buy a RX5700 XT. Oh boy.

Found out immediately that DDU/any fix/any pci-e disablation ( disabled everything I could ) would not get my 5700XT out of error 12 with .418. Did not use too much time on it, cause this topic indicated that it might be impossible to get rid of error 12 on some AMD eGPUs.

Reinstallation of the Windows to 1809. DDU drivers, install https://www.bootcampdrivers.com/ drivers, couple of restarts, plug RX 5700XT in and - Ta-da - everything works again. dGPU driven internal screen, eGPU driven external screen. Soooo, it seems like I am staying out of 1903 game and wait until 1909 comes out, and is verified to be working at least with iGPU + eGPU config. 

I like that I can keep my dGPU online at all times, so I can game any time without my eGPU if I want to.

 

2018 15" MacBook Pro (RP555X) [8th,6C,H] + RX 480 @ 32Gbps-TB3 (Razer Core X) + Win10 [build link]  

ReplyQuote
 of  69