eGPU error 12 fail after update to Windows 10 1903 or newer (OS Build 18362.329 ...
 
Notifications
Clear all

[Solved] eGPU error 12 fail after update to Windows 10 1903 or newer (OS Build 18362.329 or newer) inc downgrade pci.sys version solution  

 of  79
  RSS

coupeman
(@coupeman)
Active Member
Joined: 11 months ago
 

Thanks, will start with that and report back. Appreciated

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
WickedPorter
(@wickedporter)
Active Member
Joined: 1 year ago
 

This has got to be fixed soon, right? This is not just an issue with Boot Camp/Macs ... my NUC has the exact same issue (Razer Core X, Radeon VII). I know a lot of us have contacted Microsoft/AMD ... has anyone heard anything back yet on potential fixes in the pipeline? Even latest insider builds still have the issue.

NUC8i7/MBP 16" + Razer Core X + Radeon VII


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@wickedporter AMD Xconnect team is aware of this issue. Last I heard from them in mid November, they are working with Microsoft to resolve it. There's no estimate on when they'll have a fix unfortunately.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2018 Mac Mini [8th,4C,B] + RX Vega 56 Nano @ 32Gbps-TB3 (Gigabyte Gaming Box) + macOS 11.0 & Win10 2004 [build link]  


ReplyQuote
coupeman
(@coupeman)
Active Member
Joined: 11 months ago
 

Ok, well after much swearing, its working, and running XPlane with everything on Max is actually enjoyable!

What i did was download an older version of W10, installed, DDU the install 5500 driver, installed the VII driver from bootcampdrivers.com and it sort of worked. For some reason bluetooth went south, so rebooted a few times, and 5500 driver reappeared. So, thought id try just right clicking on it and disabling it, rebooted again and hey presto VII working with no errors, both monitors working, LG 38 inch 3840x1600 res. Turned off Macbook screen and that seems to help, but its working, and flawlessly, no weirdness, no twitching!

Thanks for the pointers guys and happy eGPUing

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mofackin
(@mofackin)
New Member
Joined: 11 months ago
 

I'm running a 2019 early advanced Razer Blade 15" with a Razer Chroma and a Radeon VII installed. I know that the 1909 and everything broke the egpu support in windows, but I came here and read the instructions, installed 1903 fresh and still am getting the error 12 errors. Is it worth going all the way back to 1809 to give it a shot? 

I'm at my wits end lol. I just bought this card to replace my 2080 because i want to hot swap between my razer machine and my macbook and I was unable to get the RTX 2080 working on the macbook (cause of apple and nvidias issues) so I figured this would be an alright mix. I really just want to be able to swap between the two options.

Any ideas?

 

**Edit: My RTX 2080 worked on 1909+ in full, it worked flawlessly as far as I could tell. I'm just trying to get the best of both worlds with one card, and the apple/nvidia issue is less likely to get resolved than this issue (i hope)

Razer Blade 2019 Early Advanced - 2060M - 16gb - 1TB HDD. Razer X Chroma with Radeon VII 16gb.


ReplyQuote
Krishna V.
(@krishna_v_)
New Member
Joined: 12 months ago
 

Anyone manage to get their Mac mini working with an AMD card in bootcamp?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago

ReplyQuote
Mofackin
(@mofackin)
New Member
Joined: 11 months ago
 

I've gotten my Razer to work on 1809, had to go back over a year to get the functionality. I don't know why 1903 .295 didn't work, but until i went back to an even earlier build it refused to work, always with the error 12.

Razer Blade 2019 Early Advanced - 2060M - 16gb - 1TB HDD. Razer X Chroma with Radeon VII 16gb.


ReplyQuote
Evangelos Vasilaropoulos
(@evangelos_vasilaropoulos)
Eminent Member
Joined: 2 years ago
 

@coupeman

How you run on xplane everything on max ? I have Mac mini 2018 i5 with razer egpu 5700xt with ASUS 38 ultrawide monitor and is struggling on high settings. Res 3850x1600. 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
coupeman
(@coupeman)
Active Member
Joined: 11 months ago
 
Posted by: @evangelos_vasilaropoulos

@coupeman

How you run on xplane everything on max ? I have Mac mini 2018 i5 with razer egpu 5700xt with ASUS 38 ultrawide monitor and is struggling on high settings. Res 3850x1600

hi, I have a mbp 16, i9, 64gb ram and a Radeon VII, guess it just has the grunt

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  79