Setup & Software Discussions
Boot Camp eGPU error 12 fail after update to Windows 10 1903 (OS Build 18362.329...
 

[Solved] Boot Camp eGPU error 12 fail after update to Windows 10 1903 (OS Build 18362.329 or newer)  

 of  10
  RSS

AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 2 months ago
 

Bootcampdrivers.com will be releasing the November AMD drivers on Saturday. Might be a long shot, but there's always a chance it will help.

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
teltersat2
(@teltersat2)
Eminent Member
Joined: 4 months ago
 

Crossing my fingers for it!

Current build: 2017 15" MacBook Pro + Mantiz Venus MZ-02 + Silverstone SX700-LPT (750W Peak) + Sapphire Radeon RX Vega 64 (Reference model)
Replaced parts: Sapphire Radeon RX 580 Nitro+


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 2 months ago
 

@whodean

Can't say I have, but it doesn't look like anything in the change log indicates any improvement for eGPUs. Then again, nothing in the change logs for previous versions indicated anything that would change a working eGPU setup, so who knows?

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
Fred_erick
(@fred_erick)
Active Member
Joined: 1 year ago
 

I installed a fresh new Bootcamp and downloaded the latest Win 10 ISO. Of course its not working with my eGPU.

Which ISO can I download and install?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@maximilian_aussprung)
Active Member
Joined: 2 months ago
 

@fred_erick

Windows 10 October 2018. You can also install all updates (worked for me without problems). Just don't upgrade to 1903 or higher for now.

https://www.microsoft.com/en-us/software-download/windows10ISO

MacBook Pro 13' 2018 & Mac mini 2018, Razer Core X, RX 5700XT


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 2 months ago
 

New AMD drivers from bootcampdrivers.com are out. They haven't solved the code 12 problem under newer versions of Windows 10, but they have altered, or at least, reverted some things. The Large Memory device no longer uses an AMD driver file, reverting back to the original Windows one (with a driver date of 2006). As such, it's once again called a PCI Express Root Complex instead of Pci Bus. 

Unfortunately, even after disabling seven PCI-to-PCI Bridge devices and one of my D700s, error 12 persists. 

 

Update: It's working?! Error code 12 has vanished and the RX 580 is showing up in Radeon Settings. 

In Device Manager, I turned on Hidden Devices and removed a few duplicates that were in there. It also seemed to show up a bunch more PCI-to-PCI Bridge devices which I went and disabled. I now have 12 of those devices disabled (according to the Devices by connection view, none of them had anything connected to them, but all of them are on the same PCI bridge that the eGPU is on). About to load up a game to see what's what! @itsage, any chance you could replicate this on your Mac Pro?

This is Windows 10 1909 (18363.449).

This post was modified 1 month ago

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


itsage liked
ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@aj_scarcella Thank you for the report! I’m working on a couple computers atm (2015 iMac iGPU-only and MSI Prestige 15) but will try this soon. Besides latest OS Build 1909 (18363.449), what other components did you disable?

 

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
RavynArcadia
(@ravynarcadia)
Active Member
Joined: 1 month ago
 

Just an FYI about the November update:

If you have a Vega 20 in your MacBook Pro, it will stop the driver from working properly. I had to go back to the September update to fix it.

This post was modified 1 month ago

MacBook Pro 15" 2019 Vega 20 / Razer Core X / Radeon RX 5700 XT / Win 10 (1903 - 18362.295) The last version that works because Microsoft is stupid.


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

The Mac Pro has always been a more unique case vs. other systems so this update is interesting. Notably, I think Polaris GPUs did not face the Error 12 problem on other machines on newer Windows builds? https://egpu.io/forums/pc-setup/egpu-fail-after-update-to-windows-19-03/paged/5/#post-67087

Guess we need more tests to confirm: has the new driver fixed the Mac Pro issue only (Vega/Navi would still cause Error 12) or solved the issue entirely.

At least on my system, the Large Memory device is already a Pci Bus (2018 15” MBP, 18362.295).

This post was modified 1 month ago

purge-wranglerpurge-nvdaset-eGPU
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 2 months ago
 

@itsage

Here's what's disabled:

  • High Definition Audio Bus (PCI bus 2, device 0, function 1)
  • PCI-to-PCI Bridge (PCI Slot 2 (PCI bus 95, device 5, function 0))
  • PCI-to-PCI Bridge (PCI bus 17, device 8, function 0)
  • PCI-to-PCI Bridge (PCI bus 17, device 10, function 0)
  • PCI-to-PCI Bridge (PCI Slot 4 (PCI bus 92, device 5, function 0))
  • PCI-to-PCI Bridge (PCI Slot 4 (PCI bus 21, device 5, function 0))
  • PCI-to-PCI Bridge (PCI bus 21, device 0, function 0)
  • PCI-to-PCI Bridge (PCI Slot 5 (PCI bus 92, device 6, function 0))
  • PCI-to-PCI Bridge (PCI Slot 5 (PCI bus 21, device 6, function 0))
  • PCI-to-PCI Bridge (PCI bus 0, device 30, function 0)
  • PCI-to-PCI Bridge (PCI Slot 2 (PCI bus 95, device 4, function 0))
  • PCI-to-PCI Bridge (PCI Slot 3 (PCI bus 92, device 4, function 0))
  • PCI-to-PCI Bridge (PCI Slot 3 (PCI bus 21, device 4, function 0))

Some of these are under Hidden Devices. Also, under Windows Advanced Power Options, I disabled Link State Power Management under PCI Express. Don't know if this actually does anything, but that's the current state of my machine. 

@mac_editor: The Mac Pro is certainly an interesting little machine. Unfortunately, I don't have access to any Vega or Navi cards to do any further testing on my end.

Out of curiosity, with the Pci Bus on your system, who is the vendor for the driver?

This post was modified 1 month ago

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


itsage liked
ReplyQuote
reuel
(@reuel)
New Member
Joined: 5 months ago
 

I've downgraded to 18362.329 and installed the november bootcamp drivers. i'm now getting the error "display driver failed to start." in device manager, I see a code 43 next to both the vega 20 and 5700xt. i've read through this entire thread both before and after seeing the error.

my system is a MacBook Pro (15-inch, 2019) w/ the above amd card in a razer core x. it's connected to the upper right tb3 port on my laptop.

Posted by: @ravynarcadia

Just an FYI about the November update:

If you have a Vega 20 in your MacBook Pro, it will stop the driver from working properly. I had to go back to the September update to fix it.

this worked for me. how terrible.

This post was modified 1 month ago

MacBook Pro (15-inch, 2019)
2.3 GHz Intel Core i9
Radeon Pro Vega 20 4 GB
Razer Core X
AMD Radeon RX 5700 XT 50th Anniversary


ReplyQuote
RavynArcadia
(@ravynarcadia)
Active Member
Joined: 1 month ago
 

@reuel

It’s odd since, not knowing what ram you got, we have the same laptop.

MacBook Pro 15" 2019 Vega 20 / Razer Core X / Radeon RX 5700 XT / Win 10 (1903 - 18362.295) The last version that works because Microsoft is stupid.


ReplyQuote
reuel
(@reuel)
New Member
Joined: 5 months ago
 
Posted by: @ravynarcadia

@reuel

It’s odd since, not knowing what ram you got, we have the same laptop.

I meant that your fix worked for me. My setup wasn't previously working w/ the November drivers. There are other people who've noted this problem in the bootcampdrivers.com forums.

MacBook Pro (15-inch, 2019)
2.3 GHz Intel Core i9
Radeon Pro Vega 20 4 GB
Razer Core X
AMD Radeon RX 5700 XT 50th Anniversary


ReplyQuote
RavynArcadia
(@ravynarcadia)
Active Member
Joined: 1 month ago
 

@reuel

Ah. I misunderstood then. Glad rolling back worked. I hope it gets fixed soon. It would be nice having drivers made to run modern warfare. 

MacBook Pro 15" 2019 Vega 20 / Razer Core X / Radeon RX 5700 XT / Win 10 (1903 - 18362.295) The last version that works because Microsoft is stupid.


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@aj_scarcella

I'll look it up and let you know. Have a ton of college work lined up so haven't had a chance to mess around in Windows recently.

purge-wranglerpurge-nvdaset-eGPU
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


ReplyQuote
verypacific
(@verypacific)
Active Member
Joined: 11 months ago
 
Posted by: @ravynarcadia

Just an FYI about the November update:

If you have a Vega 20 in your MacBook Pro, it will stop the driver from working properly. I had to go back to the September update to fix it.

Mat just posted an update on bootcampdrivers.com saying he's planning to release a V2 of the Adrenalin November edition driver for the Vega 16 / Vega 20 chipsets on Tuesday.

Hopefully that one will work then and maybe we'll get some positive results concerning the error12 issue on newer versions of Windows 10 1903 or even 1909. 🤞

2018 MacBook Pro 15" | Razer Core X | GeForce RTX 2070 | Radeon RX 5700 XT | (macOS 10.15.1) | Windows 10 Pro 1909 | 1903 (AMD)


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@aj_scarcella

Here it is - it's AMD (18362.295 with November drivers). I was booted with eGPU connected/functional.

18362.295 Pci Bus

purge-wranglerpurge-nvdaset-eGPU
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 2 months ago
 

@mac_editor

That's very odd. The November drivers didn't reinstall that driver for me after I DDU'd everything - on the September drivers, I had that same AMD driver. I also thought it was odd that AMD were even supplying a driver for that in the first place. It also looks like it hasn't been updated since March anyway. Perhaps once the V2 Adrenalin drivers are out, you might get a different result.

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
(@branislav_benak)
Active Member
Joined: 11 months ago
 

Hi everyone,

During weekend I tried to install bootcamp on my new setup MacMini 2018 i3 + Sapphire Gearbox + Sapphire RX Vega56. The Windows ISO was downloaded automatically when I tried installing trial version of Parallels 15 under MacOS. Windows 10 1903 V1. After install, I ran all windows auto updates up to Build 18362.418. Than I tried to start eGPU. No success! Even the box was wrong identified (intel thunderbolt software didn't find it) and Vega56 driver was with error 12. I deleted the bootcamp and start it again. After second install, the first thing was to stop automatic updates. I plugged the eGPU in while I watch processes in device manager. Box was found and identified  with all peripherals (USB+Ether) and Vega was signed as MS Basic Adapter, as it should be.  Immediately I installed newest adrenalin from web. During installation I lost all bluetooth, wifi, ethernet and USB ports from MacMini. So I plugged Ethernet cable to the eGPU Ethernet port and after a while Windows was back online. But still I wasn't able to use any keyboard or mouse (tried cable / wireless) because all ports on MacMini were suspended. I was able to connect to Windows via RDP (remote desktop connection which I allowed right after windows startup). Via RDP from iPhone I was able to restart mini in proper way. No hard restart. After start up, all was working perfect with all devices enabled. I didn't have to disable any ports in device manager. Restarts between macOS 10.14.6 / Windows withou any problems (no boot screen). Unigine Superposition 1080p medium score 11207.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
errantPixel
(@errantpixel)
New Member
Joined: 1 year ago
 

Hi Folks,
I’ve had a MacBook Air 2018 (8GB model, 10.15.1) + Mantiz Venus + Radeon RX 580 setup working acceptably well for the past year. I do use it for occasional work at home, but the primary purpose for the eGPU purchase was gaming, and the only game I seem to be able to make time for is DOTA 2. 🙂 I’ve been fairly disappointed with the graphics performance of DOTA in macOS with this setup, especially on the internal display, as it is comparable if not worse to the performance I had with the same eGPU paired with my old and wheezing 2011 MacBook Pro. Certainly my own fault for having inflated expectations about what the bottom tier of the 2018 lineup’s silicon could deliver, graphics-wise. 😉

I’ve decided to go the Bootcamp route to try to squeeze out whatever Windows optimization gains there might be to be squeezed out, but I’ve so far not been able to get past the dreaded yellow-bang of code 12 death. I’ve disabled many devices in Device Manager, I can hot-plug no problem at the Windows logo, but no dice. I’ve downloaded the May 2019 ISO from https://www.microsoft.com/en-ca/software-download/windows10ISO, but by the time the Bootcamp installation is finished, the version showing is later than the magic release number 18362.295—perhaps it’s running updates during the Bootcamp process itself? Could this be an issue?

These forums are a wealth of information and I’ve really appreciated the help in getting previous builds running—in this case I feel like I’m drowning under all the information and am not sure where to go next! 😀

Anyone out there actually have this or a very comparable setup working?

Many thanks in advance

MacBook Air (2018, 8GB) + Mantiz Venus + Radeon RX 580
macOS Catalina 10.15.1 (operational) Windows 10 Bootcamp (not working, yet)


ReplyQuote
fire1ce
(@fire1ce)
New Member
Joined: 4 weeks ago
 

same problem here code 12. Win10_1903_V2 (download at 12.11.19). wondering when will this be fixed

This post was modified 4 weeks ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
verypacific
(@verypacific)
Active Member
Joined: 11 months ago
 

@fire1ce

@errantpixel

Did you try downloading the Win_10_1903_V1 iso file?

Then as mentioned in the very first post apply the KB to update manually to version .295 afterwards and disable automatic updates. This should help. 

This post was modified 4 weeks ago

2018 MacBook Pro 15" | Razer Core X | GeForce RTX 2070 | Radeon RX 5700 XT | (macOS 10.15.1) | Windows 10 Pro 1909 | 1903 (AMD)


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

My contact at AMD XConnect confirmed they are aware of this issue and actively working with Microsoft to get it resolved.

Best ultrabooks for eGPU use | eGPU enclosure buying guide


Mauro Diez, Ningauble77, Eightarmedpet and 2 people liked
ReplyQuote
Roedi78
(@roedi78)
Trusted Member
Joined: 2 years ago
 

@itsage

Sounds good, thanks for the info! 

MacBook Pro 15" Late-2016 w/TB 16GB with RP460 4GB
automate-eGPU EFI 1.0.5 USB w/DSDT override
 macOS Catalina 10.15.1 w/Win10 (1903) BootCamp
Sonnet Breakaway Box 650 TB3 /wAMD Sapphire Radeon VII 16GB
 Alphacool Eiswolf 240 GPX-Pro AiO Radeon VII M02 Water Cooling


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 
Posted by: @itsage

My contact at AMD XConnect confirmed they are aware of this issue and actively working with Microsoft to get it resolved.

Sweet!

purge-wranglerpurge-nvdaset-eGPU
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


ReplyQuote
Tailslide
(@tailslide)
New Member
Joined: 2 years ago
 

I'm in the same boat.. windows update kb4517389 gives me code 12 with DSDT modded Macbook Pro 2016 with touchbar, mantiz venus and Vega 64.   I got three days until microsoft forces the update on me guess I'm disabling windows update!

 

 

Mantiz Venus, MB Pro with Touchbar 2016, Vega 64


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 2 months ago
 

@itsage Awesome!

Quick question for you as well, now that you mention XConnect: when your Mac Pro had a working eGPU, did you ever get XConnect going? For a time, while my eGPU wasn't working in Windows, I did have the XConnect icon in my taskbar. It doesn't seem to be there anymore though, and I can't figure out if there's a way to get it back, or if it's even worth it.

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
RavynArcadia
(@ravynarcadia)
Active Member
Joined: 1 month ago
 

Either I'm not downloading the right driver package, or my install of windows may be borked. The nov update is still doing the same thing.

MacBook Pro 15" 2019 Vega 20 / Razer Core X / Radeon RX 5700 XT / Win 10 (1903 - 18362.295) The last version that works because Microsoft is stupid.


ReplyQuote
verypacific
(@verypacific)
Active Member
Joined: 11 months ago
 

@ravynarcadia

As far as I understood Mat did not yet update his initial release of the November edition for the Vega 20 to a V2.

He update his first post on the announcement thread saying he will look into providing an October edition driver instead as there are multiple issues with people failing to install even on other non Vega 20 Macs.

This post was modified 4 weeks ago

2018 MacBook Pro 15" | Razer Core X | GeForce RTX 2070 | Radeon RX 5700 XT | (macOS 10.15.1) | Windows 10 Pro 1909 | 1903 (AMD)


ReplyQuote
tidesgoesegpu
(@tidesgoesegpu)
Active Member
Joined: 8 months ago
 

Hey !

Solved here, latest version of Windows Insider 19018.1. Just woke up, booted the computer and it worked. Please ask if there's anything you want to see.

Update : not actually solved, can't get it to work again.

This post was modified 4 weeks ago

Razer Blade Stealth 2019 w/ MX150
Razer Core X + AMD Radeon VEGA 64


ReplyQuote
RavynArcadia
(@ravynarcadia)
Active Member
Joined: 1 month ago
 

@verypacific

Oh, I must have misread the post then. My bad.

MacBook Pro 15" 2019 Vega 20 / Razer Core X / Radeon RX 5700 XT / Win 10 (1903 - 18362.295) The last version that works because Microsoft is stupid.


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago

ReplyQuote
(@maximilian_aussprung)
Active Member
Joined: 2 months ago
 

@tidesgoesegpu

Great news!

What insider update ring are you using? Fast?

How is the performance? Better than 1809 and 1903?

And is it stable enough to play games and do windows stuff? ^^ 

MacBook Pro 13' 2018 & Mac mini 2018, Razer Core X, RX 5700XT


ReplyQuote
tidesgoesegpu
(@tidesgoesegpu)
Active Member
Joined: 8 months ago
 

I'm on the fastest ring. I don't benchmark performance much, I tried a little bit of Witcher 3 this morning and it worked pretty fine, I'd say the same as before but doesn't mean much without numbers. I also played Sekiro extensively this morning and didn't encounter any crash nor extraordinary framerates drops. Was playing it for the first time tho, can't compare.

Razer Blade Stealth 2019 w/ MX150
Razer Core X + AMD Radeon VEGA 64


ReplyQuote
verypacific
(@verypacific)
Active Member
Joined: 11 months ago
 

@tidesgoesegpu

May I ask you to post your Windows version and Build number just for reference? (Just type in "winver" into the search field in your taskbar)

Thanks 😊 

2018 MacBook Pro 15" | Razer Core X | GeForce RTX 2070 | Radeon RX 5700 XT | (macOS 10.15.1) | Windows 10 Pro 1909 | 1903 (AMD)


ReplyQuote
Roedi78
(@roedi78)
Trusted Member
Joined: 2 years ago
 

@tidesgoesegpu

Your signature says that you use a Razer Blade Stealth, so you don't have a Mac(Book)...? I thought the "eGPU error 12 fail after Windows update" error only happens on macOS systems /w BootCamp? Or am I misinformed?  

So what exactly was your problem you resolved by installing the newest Win 10 Insider Preview?

 

MacBook Pro 15" Late-2016 w/TB 16GB with RP460 4GB
automate-eGPU EFI 1.0.5 USB w/DSDT override
 macOS Catalina 10.15.1 w/Win10 (1903) BootCamp
Sonnet Breakaway Box 650 TB3 /wAMD Sapphire Radeon VII 16GB
 Alphacool Eiswolf 240 GPX-Pro AiO Radeon VII M02 Water Cooling


ReplyQuote
 of  10