eGPU still not recognized in Windows 10  

  RSS

rimcrazy
(@rimcrazy)
New Member
Joined: 1 month ago
Posts: 4
December 6, 2018 1:13 pm  

So I have my Akitio node up and it works.  I have a proper thunderbolt 3 cable connecting it to my P72 laptop.  The Akitio Node is on Port 1 on the chain of devices which as I understand it is required for an eGPU to be recognized.  The card in my Akitio Node is a NVidia Quadro P4000 and the GPU in my P72 laptop is a Quadro P4200 so the required driver should be identical.  All of that being said, everything "Looks" correct with the exception that the eGPU is simply not being recognized.  I've attached a screenshot of my configuration.  I've read through other configs on Windows machines and from what I've seen the GPU just appears.  Is there something I'm not seeing?  A BIOS change I need to make?

Lenovo P72 Laptop, 17" 4K display, P4200 Quadro GPU, 64Gb Non-ECC Dram, 2x2Tb Samsung 970 EVO m2 RAID 0, 4Tb Samsung 860 2.5" SSD


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
December 7, 2018 2:29 pm  

Check Thunderbolt Security settings in the BIOS. The Default Security Level should be User Authorization (SL1) which prompts you every time a new Thunderbolt device is detected. You can change to No Security (SL0) and see if the system can detect your AKiTiO Node.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote