Notifications
Clear all

eGPU Won't boot!  

  RSS

ricardorbc
(@ricardorbc)
Active Member
Joined: 8 months ago
 

UPDATE:
So turns out it's a faulty PSU that just went bezerk. Will keep this posted.
_________________________________

Hello,

So my Mantiz doesn't work at all!

A while back I spoke with you guys and with Mantiz themselves and both helped me order a MANTIZ MZ-03 SATURN PRO EGPU (V2) from Amazon, upon arrival I tested it with my laptop and runned fine, so I put it back in the box for a couple of months while I worked on building my desk setup.

Yesterday was the day I assembled it all, my desk, chair, monitors and the eGPU. Got a 1080ti and a 1TB HHD drive in the eGPU and connected 2 displays, an USB audio interface, ethernet cable, a keyboard and wireless mouse to the eGPU's external ports.
Connected it all with the Thunderbolt cable and voila, all working at first glance.

I started to setup my Windows power settings and such, restarted and it struggled after booting, displays started to lag/severe frame drop and audio struggling/crackling. So I shutted down the laptop and restarted manually, connected the cable again and lagging/frame drops went away but audio still crackled like crazy (didn't test any videogames still up to this point, just music on youtube using Google Chrome). I installed Thunderbolt NUC Software from Intel but it seems to crash or something and do nothing regarding my issues so I unistalled before I got software and drivers too involved.
I then disconnected everything and reconnected while everything was turned off. Now the eGPU won't even boot (not even a fan spin for a split second, nothing). I tried 2 different Thunderbolt 3 (active 40gbps) cables, including the original cable but no luck.
Windows shows a message when I connect the cable saying "Thunderbolt device functionality might be limited" now.
At this point I have disconnected everything from the external ports, including ethernet. Still eGPU seems to fail to start/boot and I get the same message from Windows. 

A weird behavior that I noticed was that, in one of the last couple times I was restarting the system, Windows Explorer opened, automatically, the root folder of the HDD I had in the eGPU for the first time.
So I read on a post around this forums that a SATA cable could be at fault here, it isn't. I have removed the disk altogether, no luck. Decided to remove the graphics card since I was at it. Still, not a heartbeat.
I can't find any LED showing me it's status, can anyone guide me through troubleshooting this? I have a feeling that the booting relay used to be louder, I can still kinda hear it when I connect the cable to the laptop but sounds weak. Maybe something burned? Shouldn't since I never got to test performances.
Just noticed that Device Manager detects TBX-750FA under Universal Serial Bus devices but if I plug, lets say a pendrive it doesn't show anywhere, still can't access anything from it.
 
I've emailed this issue to mantiz support already yesterday.
Best Regards and Stay Safe.
This topic was modified 3 months ago

Mantiz MZ-03 Saturn Pro EGPU (V2):
GTX 1080ti
1Tb HDD

Clevo PC50DD2 laptop:
i7-10875H
1x16GB DDR4 2933MHz
512GB M.2 PCIe NVMe
Intel Wi-Fi 6 AX200 (2.4Gbps) + BT 5.0


ReplyQuote