Error 43 on thunderbolt eGPU discussion
 
Notifications
Clear all

[Solved] Error 43 on thunderbolt eGPU discussion  

  RSS

Mo oi
(@mo_oi)
Active Member
Joined: 7 months ago
 

My iMac build got the sudden and random*d error43 in every 5-10 days. 

2017 iMac + RazerCoreChroma + RTX2060super + Windows 1909

The initial setup encountered no problem and it worked for several days without problem, but one day, eGPU fans has suddenly ran full loud and stopped working. The cause of error43 varied very much, I suppose. I found the same problems in here(no solution), and here(clean installing solved), here(no solution)

I wrote what I did and discuss my googled search results and hope help someone who shouldn’t know what to do. I’ve just found temporary fixes, but it has not continued over 10 days. I am now searching ways to make it stable.

  1. After crash, I turned off the switch on the eGPU with all cables plugged and restart everything result in error43 in device manager. I fixed it by reconnecting the internal power cables and replug GPU card*a . I cannot identify what procedure corrected the error43.
  2. Yesterday, I got the same crash and just unplug TB3 cable on the iMac side and reconnect it to another port, which is called “port dance”*b , fixes the situation for 24h without error43. After replugging the cable, I tried plugging the cable on the crashed port. After 30minutes of gaming, it crashes again and I return the cable to another port and it works now.

I attached some screenshots from this forum for your help (Thanks a lot for all)

 

[eGPU]

| Changing internal power cable(P3>P4 or reverse) or replugging the GPU card temporary worked

[Tb3 cable] I changed Tb3 cable, which didn’t work

[iMac]

| deleting drivers using DDU did not work

| disabling iGPU in device manager did not work

| Using windows auto installing driver(ver432.00) or latest driver did not work

 

Discussion and Question

I found similarity in “port dance” , replugging the internal power cables, and disabling-enabling eGPU in device manager. 

I cannot figured out precisely what caused error43 in my situation. In several days, it was working without any problems, so I didn’t think it was a hardware problem. I contacted Razer Support and he mentioned about some windows components*c may cause crash and it happened after windows 1809.

 

notes

a. I found one thread mentioning the same thing.

b. See this link (thanks @itsage) 

c. pci.sys??

d. the crash happend even in windows desktop screen or gaming not in heavy load.

 

citation from this site mentioning error43 fixes

ii) error 43 incorrect eGPU initialization due to PSU mistiming
So far, this has been working for me 100 of the time. The way that it constantly works for me is

 

2019 17" HP OMEN 17-cb0065TX (RTX2070) [9th,6C,H] + RTX 3080 @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 1909 [build link]  

ReplyQuote
Topic Tags
Mo oi
(@mo_oi)
Active Member
Joined: 7 months ago
 

I tried changing NVIDIA driver version using DDU, nothing changed. Applying Windows May update did not work. Once the crash happened, resulting in constant, random crashes in every several minutes.

I was tired and decided to return eGPU and GPU and let them check in manufacturers to rule out hardware errors.

If they find no hardware errors, I will buy a windows notebook for only gaming 🙁

I will keep updated if I find something.

2019 17" HP OMEN 17-cb0065TX (RTX2070) [9th,6C,H] + RTX 3080 @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 1909 [build link]  

ReplyQuote
Mo oi
(@mo_oi)
Active Member
Joined: 7 months ago
 

Updated

After installed Windows2004 and the newer Nvidia Drivers, errors have gone.

I have no errors for about 3 months.

I cannot precisely identify what solved errors, but some combination(Windows 2004 and NVIDIA driver) may correct errors.

 

2019 17" HP OMEN 17-cb0065TX (RTX2070) [9th,6C,H] + RTX 3080 @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 1909 [build link]  

ReplyQuote
Mo oi
(@mo_oi)
Active Member
Joined: 7 months ago
 

Finally, I got the answer.

 

RTX 2060super requires the 8 pin connector, and Razer core X chroma have the 6+2 pin connector.

I didn't  know how to connect the 6+2 pin connector. I finally noticed that the 2 pin connector was loosened, which may cause instability.

It's funny 2060super runs well even only with the 6 pin connector (:P)

 

2019 17" HP OMEN 17-cb0065TX (RTX2070) [9th,6C,H] + RTX 3080 @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 1909 [build link]  

itsage liked
ReplyQuote