Setup & Software Discussions
error Code 43 in Bootcamp / RX 5700 XT
 

error Code 43 in Bootcamp / RX 5700 XT  

  RSS

(@jendrik_reis)
Active Member
Joined: 1 month ago
 

hey Guys,

 

i finally solved the code 12 error on my 13in Macbook pro 2019 in Bootcamp.

But now i get the error code 43.. what can i do ?

Macbook Pro 2019 13Inch 2,4GHZ / WIN 10 1809 / MacOS 10.15.1
Razer Core X Chroma
Asus ROG Strix Rx 5700 XT


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

@jendrik_reis a bit more info would be good... what Mac? What have you done to get past error 12? 

Error 43 is often power/hardware or driver.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@eightarmedpet I’ve encountered error 43 lately with different AMD eGPUs in Boot Camp too. In some instances the eGPU would be working at first then all of a sudden Windows would yellow-bang the eGPU claiming the drivers have issues. It’s hard to determine whether it’s Windows or Radeon drivers are acting up.

 

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago

ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@eightarmedpet Error 43 happened on an RX 580 for me a couple of times. I did try switching to macOS right after to observe whether it’s possibly a hardware issue. Interestingly enough the Thunderbolt connection was not detected in macOS. I had to disconnect and reconnect a few times for it be detected and the eGPU started working again. This was a VisionTek mini eGFX + RX 580. There were mouse and keyboard as well as Ethernet connected. None worked so it wasn’t the RX 580 hardware issue. Maybe it’s from the Thunderbolt 3 controller on either the enclosure or laptop? Thunderbolt 3 cable was the standard issued .5m one.

 

This post was modified 4 weeks ago

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
(@jendrik_reis)
Active Member
Joined: 1 month ago
 

@eightarmedpet

Macbook Pro 2019 13Inch 2,4GHZ / WIN 10 1809 / MacOS 10.15.1
Razer Core X Chroma
Asus ROG Strix Rx 5700 XT

Ive installed WIN 1809 via Booctamp. then installed automate eGPU EFI and booted into WIN 10.

then code 43 appears

Macbook Pro 2019 13Inch 2,4GHZ / WIN 10 1809 / MacOS 10.15.1
Razer Core X Chroma
Asus ROG Strix Rx 5700 XT


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

@jendrik_reis and which drivers have you installed? You may need to use DDU to clean up any old/corrupt AMD drivers and instal some nice clean fresh ones.

@itsage that only makes it a bigger mystery... is this something you've found recently or has it happened over the last few years? I'm kinda nervous about switching anything out in my system now as (tempts fate) everything has settled back down and is relatively stable.

This post was modified 4 weeks ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
(@jendrik_reis)
Active Member
Joined: 1 month ago
 

@eightarmedpet

ive installed bootcampdrivers, still error 43, then uninstalled the drivers with DDU, and then installed the AMD Drivers from the homepage. nothing changed.

repeated this steps but with no effect

Macbook Pro 2019 13Inch 2,4GHZ / WIN 10 1809 / MacOS 10.15.1
Razer Core X Chroma
Asus ROG Strix Rx 5700 XT


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@eightarmedpet This error 43/Thunderbolt connection issue is something I only experienced in the last couple of weeks. I’m testing this 2017 13″ MacBook Pro with a different eGPU [ASUS XG Station Pro + RX 5700] now to see whether it’s the laptop’s Thunderbolt 3 controller/port causing the detection issue.

@jendrik_reis If the card works in macOS then it’s not a hardware issue. RX 5700/XT drivers are not very good for external graphics use atm so it’s hard to determine the right fix in Windows.

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
(@jendrik_reis)
Active Member
Joined: 1 month ago
 

@itsage

in MacOS the rx 5700 xt gets detected correctly and runs flawless.

 

dont know if waiting for the error to get fixed ( new drivers, win update etc. ) or buying a other AMD Card ( Vega 64.. )

Macbook Pro 2019 13Inch 2,4GHZ / WIN 10 1809 / MacOS 10.15.1
Razer Core X Chroma
Asus ROG Strix Rx 5700 XT


ReplyQuote
graukatze
(@graukatze)
Active Member
Joined: 3 years ago
 
Posted by: @itsage

@eightarmedpet Error 43 happened on an RX 580 for me a couple of times. I did try switching to macOS right after to observe whether it's possibly a hardware issue. Interestingly enough the Thunderbolt connection was not detected in macOS. I had to disconnect and reconnect a few times for it be detected and the eGPU started working again. This was a VisionTek mini eGFX + RX 580. There were mouse and keyboard as well as Ethernet connected. None worked so it wasn't the RX 580 hardware issue. Maybe it's from the Thunderbolt 3 controller on either the enclosure or laptop? Thunderbolt 3 cable was the standard issued .5m one.

 

Same for me - after I upgraded to macOS Catalina I went back to try out Bootcamp + 5700XT w/Akitio Node and same troubles as described (sudden disconnect of eGPU with Windows 10 (Windows 10 1903 OS Build 18362.295 + bootcampdrivers AMD November or July V2), then trouble to even find eGPU in Catalina. Reboots, logons, waiting... at one point the eGPU is discovered again in Catalina and also in Bootcamp until the next disconnect.

Macbook Pro 2018 w/ Radeon Pro 560X
Akitio Node and RX5700 XT with Windows 10 1903 and macOS 10.14.6


ReplyQuote