Notifications
Clear all

External monitor not detected  

  RSS

MaddogITB
(@maddogitb)
New Member
Joined: 2 months ago
 

Hello! I recently got my Razer Core X Chroma and connected it to my Dell XPS 15 (9570) and to an external display via HDMI. When I turn my laptop on, everything seems to work and my external display is connected. I can mess with the Nvidia control panel where it shows my 3070. But after at most a few minutes, the display will go black and say “No Signal Detected.”

With my laptop display still on, I can control the Core X via Synapse but don’t see the 3070 listed when I check the Nvidia GPU Activity or Nvidia Control Panel. My laptop also isn’t detecting the external display anymore.

I can “fix” this by shutting my laptop down and turning it back on or unplugging and replugging the thunderbolt cable from my laptop, where the display eventually goes black again.

Any help would be appreciated, thank you!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
MaddogITB
(@maddogitb)
New Member
Joined: 2 months ago
 

A little update, I updated my Intel Graphics Drivers as per Razer Support. I also took the GPU out of the Razer Core and put it back in, double-checking to make sure everything is securely plugged in. So far I've had no problems with it losing connection.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

Boltoway liked
ReplyQuote