[GUIDE] DSDT override eGPU error 12 fix
 
Notifications
Clear all

[GUIDE] DSDT override eGPU error 12 fix  

 of  25
  RSS

Sace
 Sace
(@sace)
Eminent Member
Joined: 2 years ago
 
Posted by: @nando4
Posted by: bryanangg

 

Hi, I'm new here and I followed the steps and could successfully run the Akitio Node on my MacBook pro 13" early 2015 and could run games with no problems. But I found that after I had restarted my laptop, I received errors like IRQL_NOT_LESS_OR_EQUAL when starting up and had no luck getting it back to work ever since. Any ideas?

   

If there is a mismatch between the DSDT override and your current system bootup state then this could occur. So.. reset NVRAM, disable the DSDT override and re-create it.

Here's where it is useful to have the Clover method working as don't need to wrestle with recovering Windows back into a working state.

I've been messing around with this for a few days after the 1903 update killed my eGPU setup and for some reason I can't get it to work without the override now.

My trouble is that it seems that the allocation get's completely screwed when I connect my external HDD. Before I connected it the setup worked fine (Running 1803 and with a DSDT override active). When I connected my HDD it stopped working and I can't get it going again. The computer just freezes in the windows boot where it usually would activate the eGPU. 

Could this be because the override file is not matching my system anymore? What changes can generate that mismatch (Hardware, windows versions etc.)? The file was generated on a clean system before connecting anything.

MacBook Pro 13” nTB (2016) - Razer Core X - MSI Radeon RX 580 Armor 8GB
Mac OS X 10.14.1 + Windows 10 1803 (Bootcamp)

 
2016 13" MacBook Pro [6th,2C,U] + RX 580 @ 32Gbps-TB3 (Razer Core X) + macOS 10.14.1 & Win10 [build link]  


ReplyQuote
Papagoja
(@papagoja)
New Member
Joined: 7 months ago
 

Cannot simply get my setup to boot using the microsoft method and test signing mode. 

Right after the BIOS splash screen it will hang and reboot until I enter recovery - any idea what the issue might be? 

Lenovo Thinkpad X230 Tablet with EXP GDC 8.5c & Dell DA-2 coupled with GTX 1060 6GB over Expresscard.


ReplyQuote
DMI
 DMI
(@dmi)
New Member
Joined: 5 months ago
 

Hi there!

I am completely new and I have run into an issue with my GDC Beast Expresscard GPU.
I am running a gtx 970 on an HP ProBook 6550b and I always run into the error code 12.

Since then, I stumbled on this awesome guide here on this forum and followed the steps to do the dsdt override.

In the last step to creating the dsdt file I get the following error:
dsdt-modified.dsl 2103: 0x00000000, // Length
Error 6043 - ^ Invalid combination of Length and Min/Max fixed flags

The lines around the error are the following:

DWordMemory (ResourceProducer, PosDecode, MinFixed, MaxFixed, Cacheable, ReadWrite,
0x00000000, // Granularity
0x00000000, // Range Minimum
0xFEDFFFFF, // Range Maximum
0x00000000, // Translation Offset
0x00000000, // Length
,, _Y0F, AddressRangeMemory, TypeStatic)

I can not figure out how to get rid of this error and it is the only error I still have to fix!

I hope someone can help me out I would be immensely grateful for that!

HP ProBook 6550b,Intel(R) Core(TM) i5 CPU,ATI Mobility Radeon HD 4500 Series dGPU, GDC Beast Expresscard v8 with Asus Strix Geforce GTX 970 OC


ReplyQuote
Homo Bimpson
(@homo_bimpson)
New Member
Joined: 4 months ago
 

I'm getting errors in my dsdt-modified.dsl and I've tried everything, just more errors no matter what I do

This post was modified 4 months ago

2011 14" Dell Latitude E6420 I5-2450m 8GB HD3000 + NVS 4200m Xubuntu 18.04.4 LTS/Windows 10
EGPU: GTX 980 - 4GB VRAM + PCE164PN03 + Corsair CX750M


ReplyQuote
Daemon53
(@daemon53)
New Member
Joined: 5 months ago
 

I have read a lot of articles on this site about code 12. I tried to do dsdt process. Did anyone want to help me? @nando4

System Features :

Hp Pavilion G6 2212 et

İntel Grapchish 4000

Amd Hd 7600M

MSI RX 570 ARMOR 8GB OC

PLASE HELP ME. Pray  

DAEMON53


ReplyQuote
alexhore
(@alexhore)
New Member
Joined: 3 months ago
 

For anyone wanting to get this going on a Lenovo Thinkpad L540 or similar this does work just took a few attempts.

  • Thinkpad L540 latest bios
  • i7-4712MQ
  • 16GB Ram
  • GTX 970 Strix
  • Generic cheap PCIe USB3 mount via expresscard (cable spliced and directly soldered at both ends very short) Fresh UEFI windows 64bit install fully updated
  • Microsoft method
  • Inserted HEX using "For other Systems"

My first attempt resulted in a large memmory entry but it didnt work. Then I realised it had "motherboard resource" next to it which was strange. The image shows PCI bus. Then I realised I had added the large memmory hex block to the wrong area

There are top options of searching for the insert location, the "For Lenovo Systems" one was wrong for me and the hex table below was tiny, the guide mentions it being large. I found a buff entry under PCI0 and that was huge and worked a treat.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Arturo Javier Alejandro Morán Rouzaud
(@arturo_javier_alejandro_moran_rouzaud)
New Member
Joined: 2 months ago
 

Hey there!

I'm pretty new to anything Apple related, so please excuse me if I happen to miss something 😅

 

I'm trying to set up a MacBook Pro from 2011 (A1278) for a friend of mine with BootCamp and Catalina, so far everything on the OS X side seems to be working, but I'm stuck between a rock and a hard place regarding Windows 10 in the device.

I found this forum through a post on StackExchange describing how using a patched DSDT would expose the sound components to Windows, and so far I have been able to follow this guide to a T and managed to produce the modifications correctly.

 

The only thing that is leaving me stumped is the boot process, as it seems that booting through the EFI Boot option leads to an "USB File System not found" error unless I have a USB unit plugged to the machine, in which case I can get as far as the Windows or OS X selection until choosing one causes a system freeze and I have to hard reset.

 

Is there any way to enable the DSDT override without test signing and using the internal SSD only? I am currently using a GPT-only UEFI installation of Windows 10 Pro 1909 and macOS Catalina 10.15 on an APFS case-insensitive encrypted volume.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Timmy Shotgun
(@timmy_shotgun)
New Member
Joined: 1 month ago
 

I checked the setup and software with gtx 640 - everything works.
I decided to put a more powerful card-R9 270x and got an error with the code 12.
I followed the instructions to code 12 and created a dsdt file with a bunch of errors (73 errors), ruled them with Notepad ++ to 0 (I realized that this was a bad idea) and when I rebooted, I got a BIOS error when loading Windows.
I understand that to make the correct dsdt. aml file, you need to install Mac OS and edit the guide: Guide from tonymacx86?
Are there any alternative methods to avoid installing Mac OS?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mr.Meeseeks
(@mr-meeseeks)
New Member
Joined: 1 month ago
 

Hello community!

I've been a guest member for a few days while deciding what to buy and for the past few days to set up my build. This is an amazingly helpful community, thank you!

I've been following mainly @Ritero's and @itsage's guides to set things up, but when I reached the final Steps, I got Error 12. While trying to figure out what went wrong, I realized I was using the wrong DSDT override (I need RP450 and was using RP455). I didn't dare build one myself for the bricking issue I've seen around. Then I stumbled across @NANDO4's repository but found that the links were broken:

https://egpu.io/public-repository-egpu-dsdt-overrides/

Clicking on the image takes me to:

https://www.mediafire.com/folder/9xrm0bg8jj0z5/DSDT_override_resources

Which I see empty. Any chance I am doing something wrong and they are not really empty?

My Build 15" 2016 Touchbar MBP 2.6Ghz - 16GB + Razer Core x Chroma + Saphire 5700 XT Nitro+

 

Thanks!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

@mr-meeseekshttps://www.mediafire.com/folder/9xrm0bg8jj0z5/DSDT_override_resources works fine. Maybe try a private browser sessions or a different browser?

image

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
 of  25