[GUIDE] Generic Windows 10 Solutions for eGPU BSOD, Crashing, System Freezing an...
 
Notifications
Clear all

[Sticky] [GUIDE] Generic Windows 10 Solutions for eGPU BSOD, Crashing, System Freezing and Stuttering - (Link State Power Management, TdrDelay & TdrDdiDelay, NVIDIA Power Management Settings)  

  RSS

Boltoway
(@boltoway)
Estimable Member
Joined: 3 years ago
 

If you have a Windows 10 eGPU System and are suffering from blue screens, crashing or system freezes, there are a couple of universal solutions you can try. These solutions have helped me on multiple occasions, across a variety of systems. Unlike BIOS options that are device-specific, these are generic solutions that can be applied to any Windows system.

 


SOLUTION ONE: (Disable iGPU / dGPU).

If you are suffering from graphical stuttering, you might have to disable your integrated GPU (iGPU) or descrete GPU (dGPU). 

To do this, press the Windows Key + X and select Device Manager.

In Device Manager navigate to Display Adaptors and expand this section.

Right click on your iGPU or dGPU (Intel Iris Xe, Intel HD 4000, Nvidia MX450, etc) and select Disable.

Device manager Disable iGPU

To re-enable your iGPU or dGPU, follow the same process and select enable.

(Depending on your system, you might not need to leave the iGPU disabled. You might be able to disable and then enable the device immediately and still fix the stuttering).

 


 

SOLUTION TWO: (Tdr & TdrDdiDelay).

This solution essentially allows Windows to give the GPU more time to respond or recover from an issue. It has fixed crashes for me on a couple of systems.

Open the Windows Registry Editor (regedit.msc) and navigate to:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers

Now create a new DWORD (32-Bit) Value and name it TdrDelay. It should look like this:

RegeEdit 1

After it has been created, right click on it and select Modify. Change the Base from Hexadecimal to Decimal, add a Value Data of 10 and select OK. 

Using the same process, create another DWORD (32-Bit) Value. Name it TdrDdiDelay. Change the Base from Hexadecimal to Decimal, add a Value Data of 20 and select OK. 

It should look like this:

RegeEdit 2

Close the Registry Editor and restart your system. 

 


 

SOLUTION THREE: (Link State Power Management).

Link State Power Management is a Windows System Policy that mandates power saving for PCIe devices. This can usually be accessed in the Advanced Settings of the Windows Power Options:

Link State Power Management Crop

If this is setting is available to you, you want to turn all power saving options off. If this option is not available to you, use this process to add it:

Open the Windows Registry Editor (regedit.msc) and navigate to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\501a4d13-42af-4429-9fd1-a8218c268e20\ee12f906-d277-404b-b6da-e5fa1a576df5

Create a new DWORD (32-Bit) Value and name it Attributes. After it has been created right click on it and select Modify, and change the Value Data to 2 and select OK. It should look like this:

Link State Power Management Registry Edit CROP

The Link State Power Management option should now be available in your Advanced Power Settings.

 


 

SOLUTION FOUR: (NVIDIA Power Management Settings).

If you are using an NVIDIA graphics card, you can change the Power Management Mode through the NVIDIA Control Panel.

Right click on your desktop and select NVIDIA Control Panel.

Navigate to the Manage 3D Settings page listed on the left.

Under the Global Settings tab, scroll down to Power Management Mode and select Prefer Maximum Performance.

Apply these settings and exit the NVIDIA Control Panel.

nvidia control panel power management mode

 


 

This topic was modified 3 days ago
2021 14" Lenovo Yoga Slim 7i Pro (MX450) [11th,4C,H] + RTX 3060 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 21H1 [build link]  

mr.ribeiro, BlackJack84, wildfear and 2 people liked
ReplyQuote
sonagi
(@sonagi)
Active Member
Joined: 2 months ago
 

thank you somuch for this tips and tricks.

i had similar problem.

whenever i shutdown my laptop and egpu for a long time if i start it again the nvidia drivers is not loading. i have to go to device manager and uninstall and restart all over again. what could be the problem? also sometimes i get bsod video_scheduler error and restart.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Boltoway
(@boltoway)
Estimable Member
Joined: 3 years ago
 

@sonagi, What model EGPU and Laptop do you have? How is your system connected to the EGPU?

 

2021 14" Lenovo Yoga Slim 7i Pro (MX450) [11th,4C,H] + RTX 3060 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 21H1 [build link]  

ReplyQuote
sonagi
(@sonagi)
Active Member
Joined: 2 months ago
 

@boltoway, i am using exp gdc 8.5c

Asus k43sv Gt 540m paired with gtx 750 ti o.c version via mPCIe (wifi) slot:

This post was modified 1 month ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

Boltoway liked
ReplyQuote
wildfear
(@wildfear)
Trusted Member
Joined: 9 months ago
 

Nice guide !

 

Another way to get rid of the stuttering with nvidia dGPU / eGPU couple is to put a dummy hdmi/display port on one of the dGPU output.

This output have to be directly connected to the dGPU.

This way, dGPU stays awake and optimus don't mess with eGPU.

You can make that screen a duplicate of one of your screen setup.

exemple of dummy HMDI :

dummy

And my setup for duplicate screen :

- 4 external main screen - eGPU

- 2-3 external secondary screen - eGPU / dGPU dummy duplicate

- 1 internal screen - iGPU / dGPU optimus

dummy.conf
2021 16" Lenovo Legion 5i Pro Gen 6 (RTX3060) [11th,8C,H] + RTX 3080 @ 32Gbps-TB4 (Razer Core X Chroma) + Win10 21H1 [build link]  

Boltoway liked
ReplyQuote
Boltoway
(@boltoway)
Estimable Member
Joined: 3 years ago
 

@sonagi, Sorry, but nearly all my eGPU troubleshooting has been with Thunderbolt 3 Systems. If I was you, I would start by disabling 'fast-startup' in Windows and also disable all device power-saving options in both Device Manager and Windows 10 Advanced Power Options.

You should also look throughout your BIOS for any device security and or power-saving settings that can be adjusted, and see if anyone has had any success modifying them in an eGPU setup.

Sorry I cannot be of more assistance.  

 

2021 14" Lenovo Yoga Slim 7i Pro (MX450) [11th,4C,H] + RTX 3060 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 21H1 [build link]  

ReplyQuote
BlackJack84
(@blackjack84)
Eminent Member
Joined: 5 years ago
 

Can confirm that (Link State Power Management = Off) + (Nvidia Power Management Mode = Prefer Maximum Performance) got rid of the occasional freezes (about once every 100 running hours) I was having on a Mantiz Venus + GTX1070 + Tongfang PH4TRX1.

Conversely, same issue but no luck with the same setup on my previous host, a Razer Stealth 12.5" 7500U on which I had tried pretty much anything mentioned above, and more (including swapping PSU/enclosure/GPU, updating BIOS, using a UPS, DCH Vs. non-DCH drivers, disabling fast startup, enabling Ultimate Perf power plan, etc. etc. you name it).
So I guess with some hardware it might just be unavoidable.

2021 14" Tongfang PH4TRX1 [11th,4C,H] + GTX1070 @ 32Gbps-TB3 (Mantiz Venus)


Boltoway liked
ReplyQuote