[Help] Dell XPS 13 9360 - Multiple crashes and freezing when connecting eGPU
 
Notifications
Clear all

[Help] Dell XPS 13 9360 - Multiple crashes and freezing when connecting eGPU  

  RSS

Jean Bruls
(@jean_bruls)
New Member
Joined: 4 months ago
 

Good morning everyone, I've got an issue regarding my eGPU I hope some of you can help me with.

Setup:

Dell XPS 13 9360 + Razer Core X Chroma + MSI GeForce GTX 960

Symptoms:

  1. Power on laptop > connect eGPU > First frame is rendered on the external monitor, then the system freezes. Unplugging doesn't change anything.
  2. Connect eGPU > Power on laptop > Loading screen on external monitor for 2-3 seconds, then black screen. System doesn't shut down.

Fix:

For 1, I have found no fix.

For 2:

Hold power button for 10 seconds while still connected > system shuts down > press power button > system starts again, this time no issues.

Once I have done 2. the system works without issues, my graphics card is registered, my laptop is charged and I have wired internet and access to the external usb's. I am overall happy with my eGPU, but it has proven to not be the plug-and-play experience as advertised. But it should be, at least it should be easier than it currently is.

Any tips to try out?

Dell XPS 13 9360
Razer Core X Chroma
MSI GeForce GTX 960 GAMING 2G


ReplyQuote
Topic Tags
Dustin Stoddart
(@dustin_stoddart)
Active Member
Joined: 2 years ago
 

@jean_bruls, This sounds brutal. I'm having a similar problem where plugging in an eGPU causes an instant freeze. Curious if you ever found a solution for problem 1?

 

2020 Razer Blade Stealth (1165G7 + GTX 1650Ti Max-Q) + Aorus Gaming Box 1080


ReplyQuote
Jean Bruls
(@jean_bruls)
New Member
Joined: 4 months ago
 

@dustin_stoddart, unfortunately no. I am still facing the same problems.

 

Dell XPS 13 9360
Razer Core X Chroma
MSI GeForce GTX 960 GAMING 2G


ReplyQuote