[HELP] Gigabyte RX 580 Gaming Box various issues
 
Notifications

[HELP] Gigabyte RX 580 Gaming Box various issues  

  RSS

Merode
(@merode)
New Member
Joined: 1 year ago
 

Hello everyone

I hope I don't stretch forum rules too much. I couldn't find better board to post what I have on my mind. I'm hoping to find people who might have had similar issues and resolved them or those who have similar setup and can try to reproduce my issues. I have reached various manufacturer's supports and will update this thread as I learn more.

I have just recently acquired Gigabyte RX 580 Gaming Box which I plug into Intel Skull Canyon (NUC6I7KYK). These are steps I have already performed:

  • I'm connecting NUC to eGPU with 2m active TB3 cable rated for 40Gb/s (from Cable Matters),
  • I have updated Gaming Box to newest, H2D firmware (v. F1.0_H2D),
  • Gaming Box is running BIOS v. F1
  • I have installed newest TB driver (v. 17.2.71.2),
  • I have updated TB3 controller to newest firmware (v. 27),
  • NUC is running almost the newest BIOS (v. 0058, there's already v. 0059 available which I will try today),
  • I have reinstalled (unsintalled with DDU) newest AMD drivers (v. 18.12.2),
  • I'm running Windows 10 x64 1809, completly updated
  • This system has integrated Intel Iris Pro 580, which I have updated to newest driver (v. 25.20.100.6444) but it is not used. The display connected to it is disabled in screen settings of Windows.
  • The only display that is enabled is connected directly to eGPU via DP cable.
  • I have installed newest VulkanRT (v. 1.1.92.1) and all Vulkan demos (cube.exe) and my mini games work.
  • To resolve issues I have tried disabling in device manager and completly uninstalling integrated graphics to no avail.

Issues:

  1. I cannot control RGB through Aorus Engine app (v. 1.49). When I open this app it shows only fan control. If you take a look at this screenshot (which is not mine) in the bottom-right corner I have only monitor icon, other icons are not visible at all. I can confirm that Aorus engine detects my GPU correctly because in the dropdown menu (top-left corner) I see my GPU name and P/N. This issue in itself doesn't bother me as much (I just wanted to disable RGB completly) but I think it might be indicative of greater issues.
  2. Aorus Engine mentioned above should be able to update BIOS on eGPU, however its update function doesn't detect newer version. I can confirm there's one because I can download it from Gigabyte's website (I'm running F1, there's F2 available online).
  3. However when I click 'Update' in Aorus Engine as mentioned in point 2, it starts downloading 'RGB Fusion' software on its own accord. This software should be able to control RGB on GPU. It however doesn't detect any RGB-enabled device.
  4. There's also tool named [email protected] which Gigabyte offers to reflash VBIOS manually on GPU. However it seems to work only with Gigabyte motherboards and is of no help with my NUC setup. Not to mention pages of warnings in all manuals about how risky flashing VBIOS is.

All of points 1 to 4 are really steps I took and discoveries I made to resolve the following issue: Doom is the only game on my setup misbeheaving (and it's my favorite game). I have tried running two versions of it:

  • full version (fully updated),
  • demo (which was not updated since 2016).

In case of OpenGL mode I get the same results in demo and full game: about 30 FPS whichever graphics preset I choose. I enabled statistics which show GPU timings are completly off: Doom thinks GPU times are astronomically high and I guess it assumes GPU utilization is at 100%, however it is not. Here's the screenshot which shows GPU timings in milliseconds (this very wide red row). I have reinstalled game, messed with config files - nothing helps.

In case of Vulkan, there are two outcomes. In case of demo I get instant game crash and callstack points to vkResetFences() in vulkan-1.dll. It might be due to the age of demo and dynamic development of Vulkan implementations. In case of full version, game starts and I get to initial loading screen. Even at this stage statistics are displayed and I notice that running Vulkan my GPU timings are correct and game would work flawlessly. However when it reaches 99% I get BSOD pointing to atikmdag.sys with error SYSTEM_THREAD_EXCEPTION_NOT_HANDLED.

All other games and programs are working correctly. My benchmarks look fine and comparable to my friend's RX 580 running directly off PCI-E slot. I know it's a slim chance but if anyone is running even remotely similar setup, has access to Doom (demo is free) and/or had similar issues:

  1. Can you please try reproduce my issues? Both in OpenGL and Vulkan.
  2. If you had them and resolved them, how?

I have reached out to AMD, Intel, Gigabyte and Bethesda support. I'll update this thread as I learn more so if somebody has similar issue, there'll be answer at hand.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
dream3
(@dream3)
Estimable Member
Joined: 3 years ago
 

Hey how were you able to check AND update the bios and firmware of your 580 box?

The gigabyte software i installed doesnt even detect the gpu. Actually just the aorus engine in the dropdown menu but as soon as I select it, crashes.

MacOS: 15" Retina Macbook Pro 2015 Iris Pro only
Windows 10: Tornado F5 laptop with discrete GTX 1060
eGPU: GIGABYTE RX 580


ReplyQuote
(@e-v-min)
Active Member
Joined: 1 month ago
 

I have exactly same issue. Doom is only game in my collection that runs that poor. I have around 30 fps with 5700 XT both OpenGL and Vulkan (sometimes Vulkan crashes when main menu is loaded), no matter low or high graphics settings.

Did you resolved this issue?

2019 MacBook Pro 16-inch, 5300M 4GB
Sonnet eGFX Breakaway Box 550
Sapphire Radeon RX 5700 XT Nitro+


ReplyQuote