Notifications
Clear all

Help! Laptop not recognizing eGPU  

  RSS

Asai
 Asai
(@asai)
New Member
Joined: 3 months ago
 

My configuration now:

After I forced my laptop to reboot, the eGPU is not recognized by the laptop and the external graphics card is not working.

Device Manager doesn't recognize it either but I used to see it at port 5.

image

I don't know what to do now. Cry

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@asai, Disconnect the Mantiz Venus from power source and Thunderbolt 3 for a while then reconnect. Did you see a Thunderbolt device prompt the first time you connect the eGPU? How did you install the drivers?

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RTX 3080 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 // my 3rd RTX 3080 build [build link]  


ReplyQuote
Asai
 Asai
(@asai)
New Member
Joined: 3 months ago
 

@itsage, Thanks. After doing these operations, nothing happened. I've been using it normally for almost a year before the forced reboot of the laptop failed today. I have not done anything to the driver, it has always been in the state it was bought.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
timginter
(@timginter)
Eminent Member
Joined: 2 years ago
 

In Device Manager, click "View -> Show hidden devices" - check if the GPU is listed there. It may show errors if there are any. You can also right-click it, "Uninstall device" and select to remove drivers. Then reinstall the drivers.

If that fails, there shouldn't be many parts to troubleshoot: GPU, enclosure, enclosure's port, power cable, usb cable, thunderbolt port and the laptop itself.

Are there any lights on the enclosure indicating that it powers on?

There's 1 thunderbolt port on your laptop if I'm not mistaken, so tough to test that.

Do you have someone who can check your GPU in their PC?

Hope all will be OK in the end

Clevo N141ZU + Win10 + M.2 ADT R3G + Zotac RTX 2070 8GB Mini
Clevo N141ZU + Win10 + M.2 ADT R3G + Asus GTX 1060 6GB STRIX OC
Lenovo x230 + Win8.1 + EC PE4C V3.0 + Asus GTX 1060 6GB STRIX OC
Lenovo x230 + Win8.1 + EC PE4C V3.0 + Asus GTX 950 2GB STRIX OC
https://egpu.io/forums/psu-cables/dell-da-2-to-any-output-adapter

 
2018 14" Clevo N141ZU [8th,4C,U] + GTX 1060 @ 32Gbps-M2 (ADT-Link R43SG) + Win10 // 5cm NVME extender used to create pluggable NVME port [build link]  


ReplyQuote
Asai
 Asai
(@asai)
New Member
Joined: 3 months ago
 

@timginter, Thanks, Don't see anything including the graphics card in device manager. The enclosure can only charge my laptop at the moment, I used another MacBook and it doesn't recognize it. I think the motherboard is broken because I forced it to shut down.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

timginter liked
ReplyQuote
aaron manee
(@aaron_manee)
New Member
Joined: 3 months ago
 

@asai, Have you install bootcamp drivers???  [ go to bootcampdrivers.com ] free download. Good luck. Cool  

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote