[Help Needed] Gpu keep disconnecting after launching into game
 
Notifications
Clear all

[Help Needed] Gpu keep disconnecting after launching into game  

  RSS

Junwei Koh
(@junwei_koh)
New Member
Joined: 2 months ago
 

I had recently completed my egpu enclosure setup. I am using a mostly second hand setup less the laptop and trying to play on the laptop's display. There is the problem where once a game load past the menu and into the actual game, it will crash and and a nvidia popup will indicate that my gpu has disconnected. Disconnecting and connecting back the thunderbolt 3 cable will reconnect the gpu. Tried games like Control and GTA5 to no avail. 

Any help rendered will be much appreciated.

Setup: Acer spin 3 SP313. Razer Core X Chroma, Palit GTX 970 Jetstream

Driver: 471.41

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@junwei_koh, My first guess is the GTX 970 is not stable. Have you tried a different benchmark such as CUDA-Z to put a load on the card?

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Junwei Koh
(@junwei_koh)
New Member
Joined: 2 months ago
 

@itsage Just tried 3dmark instead and saw for the first time the gpu spin its fan full force, it is able to run 1 full test. Afterward run Control for 5 minutes and it work. Then restart the laptop to see if i can replicate this result but now launching 3dmark will also crash the program. Used heaven benchmark and it also crash. 

Now i want to pinpoint what is the problem: It is the gpu , the enclosure which might be the psu , or the laptop ( the thunderbolt 4 area is really hot after a while).

I just got this 970 less than 24 hrs ago so i might have a case against this seller that sold me this gpu

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@junwei_koh, Check to make sure the PSU in the Razer Core X Chroma is the stock unit which should be 700W as seen below. If it is, the most likely culprit is the GTX 970.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Junwei Koh
(@junwei_koh)
New Member
Joined: 2 months ago
 

@itsage The enclosure came with the original Psu so yeah my gpu is most likely a lemon. You gain some and you lose some in the used market

Btw thanks man for ur help, i saw that you have a founder tag under ur name, thx for creating this channel for us to get help. 🙂 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@junwei_koh, You're welcome. It's rough in this current market to buy GPU. Hopefully you'll find good card soon.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote