Help with 3080 + Mantiz Saturn pro
 
Notifications
Clear all

Help with 3080 + Mantiz Saturn pro  

 of  2
  RSS

Robeet
(@robeet)
Active Member
Joined: 1 month ago
 

Xps 17 

Core I7-10875h

Rtx 2060 max-q

32gb ram

Windows 10 2004

Egpu 

Mantiz saturn pro with rtx 3080

 

 

When I plug in my gpu my computer finds it fine and I can install the drivers and use it with external monitors but when I try to run time spy it stutters alot which from another forum post could be the pch overheating and im going to deal with that once the materials get in but it only gets part way through graphics test 1 then the programs shuts off and I get a score of 0 and it says a error has occurred. Does anyone have any fixes for this or does this just sound like the pch over heating? 

2020 17" Dell XPS 17 9700 (RTX2060) [10th,8C,H] + RTX 3080 @ 32Gbps-TB3 (Mantiz Saturn Pro) + Win10 [build link]  

ReplyQuote
Arizor
(@arizor)
Trusted Member
Joined: 8 months ago
 

Yep that's the drivers pushing overclocking way too aggressively.

Change to the "Studio" drivers, and also grab MSI Afterburner and underclock the card by around 50mhz-100mhz, seems to ensure stability until they fix the drivers.

2019 16-inch MacBook Pro Retina (2.3ghz Intel i9) // Radeon 5500M (8GB).
MacOS Catalina // Bootcamp Win10 2004 (Build 19041).
Razer Core X // Vega 64 // 2m Active Thunderbolt cable.


ReplyQuote
lwf
 lwf
(@lwf)
Eminent Member
Joined: 4 months ago
 

@arizor, it does seem like a driver problem that impacts eGPUs. Is the 3080 just frying TB3 controllers? Have we seen any Ice Lake setups with the 3080 yet?

 

2020 15" Lenovo Slim 7 [10th,4C,G] + RX 580 @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 [build link]  

ReplyQuote
Arizor
(@arizor)
Trusted Member
Joined: 8 months ago
 

@lwf, it seems like it’s impacting many AIB 3080s, see the various reports on wccftech, videocardz, NVIDIA forums etc.

now I’ve underclocked and am on the studio drivers it’s running very smooth, just with the usual TB3 performance hit.

 

edit: Time Spy EXTREME benchmark is 6667, very close to desktop performance.

 

2019 16-inch MacBook Pro Retina (2.3ghz Intel i9) // Radeon 5500M (8GB).
MacOS Catalina // Bootcamp Win10 2004 (Build 19041).
Razer Core X // Vega 64 // 2m Active Thunderbolt cable.


ReplyQuote
yo2u
 yo2u
(@yo2u)
Active Member
Joined: 4 weeks ago
 

@robeet,

I also have the XPS17 with Mantiz Pro + 3080 and its underperforming. See here and here.

I tried the studio drivers and underclocking and it's made no difference (3dmark still stutters). I even went down 500 mhz on clock and afterburner showed it never hit above 1500 mhz. Let me know if it ends up helping you

 

This post was modified 4 weeks ago

Dell XPS 17 9700 i7-10750H 32GB Win10
Mantiz Saturn Pro II + RTX 3080 FE
Aorus 1070 Gaming Box

 
2020 17" Dell XPS 17 9700 (GTX1650Ti) [10th,6C,H] + RTX 3080 @ 32Gbps-TB3 (Mantiz Saturn Pro) + Win10 [build link]  


ReplyQuote
Arizor
(@arizor)
Trusted Member
Joined: 8 months ago
 

@yo2u , that sucks, sorry to hear. I've got an RTX3080 MSI Ventus in my Razer Core X hooked up to my MBP 2019 16" and I'm hitting 15k on Time Spy and everything is running smooth *after* moving to studio drivers and down clocking to a max of 1900mhz core clock and under volting.

 

2019 16-inch MacBook Pro Retina (2.3ghz Intel i9) // Radeon 5500M (8GB).
MacOS Catalina // Bootcamp Win10 2004 (Build 19041).
Razer Core X // Vega 64 // 2m Active Thunderbolt cable.


ReplyQuote
Robeet
(@robeet)
Active Member
Joined: 1 month ago
 

@yo2u, did some more testing and the new drivers plus a 100mhz underclock got the test to finish but still getting stuttering at all points. I tested the temp of the pch with a thermal camera just to see if that was a possibility and it was maxing out at around 50° so it doesn't seem to be overheating. Not to sure what to try next but I'll keep testing to see if I can find anything 

 

2020 17" Dell XPS 17 9700 (RTX2060) [10th,8C,H] + RTX 3080 @ 32Gbps-TB3 (Mantiz Saturn Pro) + Win10 [build link]  

ReplyQuote
Arizor
(@arizor)
Trusted Member
Joined: 8 months ago
 

@robeet, have you undervolted also via MSI Afterburner (need beta 2 latest version)? That's what really clinched it for me.

 

2019 16-inch MacBook Pro Retina (2.3ghz Intel i9) // Radeon 5500M (8GB).
MacOS Catalina // Bootcamp Win10 2004 (Build 19041).
Razer Core X // Vega 64 // 2m Active Thunderbolt cable.


ReplyQuote
Robeet
(@robeet)
Active Member
Joined: 1 month ago
 

@arizor, what did you set your core voltage % at?

 

2020 17" Dell XPS 17 9700 (RTX2060) [10th,8C,H] + RTX 3080 @ 32Gbps-TB3 (Mantiz Saturn Pro) + Win10 [build link]  

ReplyQuote
Arizor
(@arizor)
Trusted Member
Joined: 8 months ago
 

@robeet, I’m away from the computer but follow this from Reddit user nitorita :

Seems like the 3080 simply can't handle over 2000 MHz before it gets unstable. The Studio Ready driver cure doesn't really sound like one; it's probably clocked lower by default since it's intended for stability for the workstation users.

This may be all the more reason to simply undervolt the card and call it a day. Better to just save wattage and increase stability than to deal with those minor ~5% performance boosts.

Edit: Simple 1-2-3 Undervolting Instructions for Stability

To undervolt, open up MSI Afterburner and click the triple bar next to the Core Clock at the left. Note down roughly what voltage the curve starts to turn into a flat line, and then enter -100 into the Core Clock in the main window and press Enter (this will decrease your idle GPU usage as well, which is good for saving power in the long run).

The entire curve should now shift down. Select the dot that aligns with the voltage where the curve turned flat, press Shift + Enter, and then enter a frequency value under 2000 (up to you really; the lower the better for stability) and press Enter. It should pop up a spike where you did this. Click Apply in the main window. The curve should now rise to the value you entered and then turn perfectly flat.

Test to see if your game is stable. If not, reset and repeat, but with an even lower frequency value this time. Once it is finally stable, reset and repeat the above steps, but this time, select the voltage that is 25 mV less than the one you had before. Apply the same stable frequency value and test. If it works, from here, rinse and repeat until you eventually bug out, and then go back to the last stable voltage setting. Save it as a profile.

Voila. You've undervolted your card and saved up to ~100W in the process (some videos showed that ~900 mV is where the sweet spot is, but you should still go through the process gradually because not all cards are the same).

 

 

2019 16-inch MacBook Pro Retina (2.3ghz Intel i9) // Radeon 5500M (8GB).
MacOS Catalina // Bootcamp Win10 2004 (Build 19041).
Razer Core X // Vega 64 // 2m Active Thunderbolt cable.


ReplyQuote
 of  2