[GUIDE] keeping iGPU activated when booting into Windows using apple_set_os.efi
 
Notifications
Clear all

[GUIDE] keeping iGPU activated when booting into Windows using apple_set_os.efi  

 of  30
  RSS

waverapture
(@waverapture)
Active Member
Joined: 4 years ago
 

@goalque

Hey, so I'm running windows via EFI-Boot on an external HDD via USB 3.0.

Instead of using ANOTHER usb-drive, can I make it run at the same time as when I'm starting windows via EFI-Boot? So should I manually copy the apple_set_os.efi to the EFI partition on my eHDD, so it's all in one place and starts at the same time?

thanks,

wave

EDIT: I clearly didn't explain myself right, in afterthought. You are explaining this for someone who installed Windows via Bootcamp. My question simply is: How does it work with Windows being installed EFI-Bootable on an external HDD. I wonder if I can combine your boot-script with the one which is starting windows. And if not, how can I make this work otherwise? Can I in someway customize the bootx64.efi to run your script while starting up?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
s3aaan
(@s3aaan)
Active Member
Joined: 4 years ago
 
Posted by: JacobSyndeo

 

Oddly enough, I haven't personally encountered this issue. Running late 2016 13" MBP with Touch Bar.
In fact, Windows seems to prefer using the Intel Iris 550 by default, and I need to use GeForce Experience or another Nvidia tool to whitelist apps for using my GTX 1060.

Is that normal? Is this issue supposed to affect everyone trying to run eGPUs on Macs, or does it only affect some of them?

   

Can you please share what steps/guide did you follow? how did you manage to make eGPU work? I have the same setup as yours. 

Macbook Pro 2016 w Touchbar, Akitio Node, ASUS GTX 1060

 

Thank you

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ddqp liked
ReplyQuote
ddqp
 ddqp
(@ddqp)
Eminent Member
Joined: 4 years ago
 

I tried my macbook 2016 late + node + gtx 1050 ti

win10 is in UEFI mode

with the new apple_set_os.efi.zip, I can boot into win10 then with a driver crash(boot with node powered and connected to macbook), the gpu-swith wont help.

I tried more than 10 times, there are about 2 times without drive crash in win10.

If hot plug node during win10 booting (see spinning), it can work perfertly

Late Macbook Pro 2016 13' touch bar + AKITIO node + GTX 1050TI 4G Windows


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 4 years ago
 

UPDATE: This method is confirmed to work with Akitio Node + Late 2016 13" MBP (non-touch) + following cards on Windows 10 Boot Camp 10.0.10586:

- R9 Nano (AMD XConnect works)
- RX 480 (AMD XConnect works)
- GTX 980 (Optimus works)
- GTX 1060 (Optimus works)

Connect the enclosure to the second TB3 port of the MBP and the USB-C-to-USB adapter to the first (port closest to the ESC key). If you see error code 12 with Nvidia, disable the parent PCI Express Downstream Switch Port in Device Manager, and then enable. No restart required.

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 1809 [build link]  


ReplyQuote
ddqp
 ddqp
(@ddqp)
Eminent Member
Joined: 4 years ago
 

@goalque

new compiled file is confirmed to work with Akitio Node + Late 2016 13" MBP (with-touch) + Windows 10 Boot Camp 10.0.10586 + GTX 1050TI (Optimus works)

Late Macbook Pro 2016 13' touch bar + AKITIO node + GTX 1050TI 4G Windows


nando4 and goalque liked
ReplyQuote
Jadida
(@jadida)
New Member
Joined: 4 years ago
 

Ok so I am new to all of this computer magic you guys are doing. I got a 2016 MBP 15in with rad 450 dgpu and am trying to setup EVGA GTX 1080 FTW Hybrid using Akitio Node over thunderbolt 3. I have tried booting into windows and disabling the PCI bridge stuff and the "iSight" camera option and all that. However none of that stuff shows up for me "same situation as one of the guys posts on the DSDT override forum. However after reading his post (being I was in the same situation as him) I saw nando4's comment on his post to try this method so here I am already confused by your directions.  So right at step one you have two links? which one am i supposed to download? Im running os Sierra 10.12.3 (i think that matters right?). Do I download "Download apple_set_os.efi https://github.com/0xbb/apple_set_os.efi " or click the one below it "apple_set_os.efi.zip."  Ok now lets say i click the right one. Now I'm on the next step. I plug in an 8gp flash drive using a usb to usb-c adapter on my mac (which was 4 ports btw, 2 right, 2 left). I reformat the drive the exact way as listed in the post. So all good for that step right? OK then next step. You say "create a folder structure" which im assuming means create folders within folders right? So I create a fold in "finder" does that mean i can create it anywhere? how about on my desktop? Anyways so i create the first folder named "EFI" then i open that one and create another one named "Boot" then I open that one and drag one of the two files i was supposed to download from step 1 and drag it into the folder and rename it "Bootx64.efi" k all set. Then u say open startup disk and basically start into windows using the USB stick. what does that mean?  If i click the windows partition and click restart then the mac will restart into windows on its own so what does the USB stick have to do with anything. Also there is nothing on the USB stick because we erased/formatted it so what does the USB stick have to do with anything? K but lets say we restart, the computer starts to turn on, i hold down option and then im supposed to see a new disk named "EFI Boot".... So where did that come from. The USB stick is empty and all we did on the computer was make 3 folders. How is that going to make a new boot disk? OK but anyways lets say i get to that point. So i click that and then it is supposed to boot into windows?? and then after that when i restart my computer, say to go back to mac, do i have to boot that way every time i want to go back to windows? It would be great if someone could clear up this process from someone who has NEVER done any hacks or work arounds or code/terminal stuff, etc on computers before. I think a video (on YouTube) would benefit a lot more people than whats provided on these forums. There very hard to follow as an average guy trying to play some games at better FPS :] Sorry for the long post and all the questions. I would be sad if i had to return the gpu and Node because i couldn't figure out how to get it to work.

BTW I am running windows 10 on boot camp

If want to ask me more about my situation you can email me at [email protected] too

Again, Thanks in advance! Hope this was helpful to show how these tutorials could be explained better? Or maybe I'm just dumb when it comes to this stuff...

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
matthieuv
(@matthieuv)
Active Member
Joined: 4 years ago
 

Thank you very much for this custom file, my Mac updated automatically to 10.12.4 last night and it was the only working solution to make it work again 😮

previous setup : 2013 15" retina Macbook Pro + TB2 Akitio Thunder 2 EVGA GTX 1060 DIY (Mac OS 10.13 and Windows 10)
current setup : 2018 15" retina Macbook Pro + TB3 Aorus Gaming Box 1080 (Mac OS 10.13 and Windows 10)

 
2013 15" MacBook Pro (GT750M) [4th,4C,H] + GTX 1060 @ 16Gbps-TB2 (AKiTiO Thunder2) + Win10 [build link]  


nando4 liked
ReplyQuote
Eason85
(@eason85)
Eminent Member
Joined: 4 years ago
 

Hi All, Eason here 🙂

 

I haven't used Macs for about 20 years. Due to recent issues with PC hardware and support, I'm thinking of picking up the next Kaby Lake Macbook Pro 15 and using it mostly as a windows machine.

Anyway, I'm intrigued by this sticky, because it makes me think maybe there's a way to keep the iGPU enabled running Windows on the 15" MBP with the RX4xx series GPUs? That's my only real concern about buying the 15" mbp; that it will always run the radeon and suck my battery dry (plus overheat even more).

 

1. Would it be possible to use this method to use the iGPU in Windows on a 15" macbook with dedicated GPU so it won't draw power?

2. Would I still be able to connect the MBP 15 to an eGPU?

Thanks for any answers 🙂 I'm very out of my element with MacOS X and bootcamp.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 4 years ago
 

@Eason85:

We can't predict the future. At present, the new efi keeps the iGPU enabled with the Mid 2015 15" (M370X) MBP (you also need gpu-switch):

https://egpu.io/forums/thunderbolt-enclosures/alert-akitio-node-half-h2d-bandwidth-issue/paged/2/#post-6172

It's always possible to disable dGPU in device manager.

Please note that there seems to be an AMD related performance issue that I am investigating:

https://egpu.io/forums/thunderbolt-enclosures/alert-akitio-node-half-h2d-bandwidth-issue/paged/4/#post-6561

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 1809 [build link]  


Eason85 and itsage liked
ReplyQuote
Eason85
(@eason85)
Eminent Member
Joined: 4 years ago
 

Thank you for the reply. So the new 2016 MBP should not be different in that regard than the 2015?

My concern was that disabling the dGPU in the device manager wouldn't stop it from drawing power and killing battery life.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  30