Is there a newer version of Windows over 1903 that is safe for eGPUs?
 
Notifications
Clear all

Is there a newer version of Windows over 1903 that is safe for eGPUs?  

  RSS

jazzdogg
(@jazzdogg)
Active Member
Joined: 5 months ago
 

Howdy eGPU fam. Is there a newer version of Windows that is safe for eGPUs? 

I am running a 2019 13" MBP connected to a Razer Core X with a 5700 XT, running Windows 10 Pro version 1903, build 18362.30. Although the internal iGPU doesn't work and it's occasionally unstable with some full screen games, it's otherwise great.

I recently purchased an Oculus Quest and really been enjoying the Oculus Link and wireless PC VR streaming, however I've encountered an issue with muted audio with some Oculus applications and games. Turns out there's a direct issue with Windows 10 v1903. Just my luck, huh? 

I've been hunting around the forums and I've noted some folk are saying a newer insider build works, although I haven't been on the bleeding edge of Windows updates for many years and I wasn't sure how to safely get there, nor was I sure how safe it was.

Does anyone know of a newer version / build of Windows that is safe with eGPUs? I don't mind formatting and a bit of trial and error to get there. (edited to remove the weird smiley face at the end, thats a heckin' creepy emote)

This topic was modified 1 month ago

2019 13” MacBook Pro (8th,4C,U) + Radeon RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.2 & Win10

 
2019 13" MacBook Pro [8th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.2 & Win10 [build link]  


ReplyQuote
Christian Prinoth
(@christian_prinoth)
Active Member
Joined: 2 months ago
 

In my setup the Oculus works perfectly with 1903...

2018 Mac Mini [8th,6C,B] + RX 580 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 1903 [build link]  

ReplyQuote
ghislain4
(@ghislain4)
Active Member
Joined: 3 years ago
 

@jazzdogg, My set-up: Razer Blade Stealth 13" 2019 + eGPU (Akitio Node + NVidia GTX 1080ti). I have installed the last MAJ of windows 10 (2004) and it works flawlessly with my Oculus rift S....Now, I don't know what would happen with BootcamP..

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
jazzdogg
(@jazzdogg)
Active Member
Joined: 5 months ago
 

@christian_prinoth @ghislain4 thanks for the reply guys. How strange. There's a forum link (read: https://forums.oculusvr.com/community/discussion/73901/no-sound-on-oculus-home-touch-basics-and-first-contact) which states the exact issue I'm having and apparently there's a support article from Oculus floating around somewhere suggesting updating to a newer build of Windows. Strangely it also affects wireless VR streaming via Virtual Desktop with the exact same results (OS audio and StreamVR works perfectly, but random Oculus apps including Star Wars Vader Immortal are mute) so it suggests an issue with the applications and their APIs rather than the headset software itself.

What a bummer. I've tried troubleshooting a fair bit and didn't get anywhere. 

 

2019 13” MacBook Pro (8th,4C,U) + Radeon RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.2 & Win10

 
2019 13" MacBook Pro [8th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.2 & Win10 [build link]  


ReplyQuote