Macbook Pro 15" 2014 (Iris Pro) + Aorus Box Gtx 1070  

 

ricc
 ricc
(@ricc)
Active Member
Joined:1 month  ago
Posts: 5
March 19, 2018 11:52 pm  

Hello everyone, I was seriously thinking about getting an Aorus Box and pair it to my Macbook Pro through a Thunderbolt 3 to 2 adapter.

I searched the forum and didn't see guides for this exact setup. So I'd like to get some advices.

Moreover, I noticed that latest MacOS seems to drop "support" for TB2. In case, would the eGPU still work with bootcamp? 

Thank you.


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined:1 year  ago
Posts: 1644
March 20, 2018 12:18 am  

@ricc,  To answer your query, macOS dropping TB2 eGPU support has not had any affect so far on Windows support for it.  

You have a less common Iris Pro 15" MBP, which we have only three build examples for:

https://egpu.io/build-guides/?table_filter =""15-inch Macbook Pro" -TB2 none "

From this we see that within Windows, a native TB2 enclosure works with a Nvidia card or a TB3 enclosure works with an AMD card. We do not know if a TB3 enclosure works with a Nvidia card, as you intend to purchase.

If your system's firmware is like the M370X 15" MBP then it allows eGPU detection in Windows and works OK with a TB3 enclosure & Nvidia card.  If it's firmware is like the GT750M MBP, then it will fail to detect a Nvidia eGPU (though AMD is OK) unless used in a TB2 enclosure.

See @mac_editor's research here  on the GT750M 15" MBP compatibility with Nvidia/AMD cards in a TB3 enclosure

Maybe play it safe with a generous return policy so can revert to a native TB2 enclosure if experience such hiccups? Certainly your investigation will help us understand TB3 enclosure + Nvidia eGPU compatibility with your system.

 

Edited: 1 month  ago

eGPU Port Bandwidth Reference TableeGPU Setup 1.35


ricc liked
ReplyQuote
ricc
 ricc
(@ricc)
Active Member
Joined:1 month  ago
Posts: 5
March 20, 2018 12:34 am  

Thanks for your answer. Sadly, the best offer I found is from a store that may cause some pain in returning the product in case the box would be working (that is, it's just my laptop failing to recognise it). 
This guy  (it's a 13" 2015 MBP, okay) got the whole thing to work. I though it was the nvidia GPU to cause problems.


ReplyQuote
bootz
(@bootz)
Eminent Member
Joined:1 year  ago
Posts: 21
March 20, 2018 5:31 pm  

@ricc The answer is yes, that configuration works still, but if you look at my forum entries you'll see I'm having trouble using the eGPU with my internal iMac display (Late 2015, Iris Pro 6200, no dGPU). But if you intend on using it with an external display, it is pretty simple to set up.

Edited: 1 month  ago

ReplyQuote
ricc
 ricc
(@ricc)
Active Member
Joined:1 month  ago
Posts: 5
March 21, 2018 9:13 am  

Mmmh, I could use it with an external monitor.. But since it's all so unstable right now, I think I'll wait a little longer and build a PC. It's such a pity because the GPU was the only thing I needed, if paired with my MPB.


ReplyQuote
meznaric
(@meznaric)
New Member
Joined:1 month  ago
Posts: 2
March 21, 2018 11:42 pm  

To hijack the thread because I can't send the messages yet and give some extra hopefully helpful info:

I have MBP Mid 2014 with only Iris Pro iGPU and I am trying to use Akitio Node TB3 -> TB2 with AMD R9 390
High Sierra (10.13.3) results: eGPU is detected even if hotplugged, but it won't work (if I remember correctly enclousre detected AMD HD8xxx  or something like that in Device Manager)
Windows 10 results: Detected, but currently stuck with Code 12, I tried pretty much everything I found on the forums except for dsdt override - I had some issues overriding it.

To my question:

Does nando's script work with GPT, I couldn't go into MBR route due to my quirky setup with Windows on external SSD? https://egpu.io/egpu-setup-13x/

Edited: 1 month  ago

ReplyQuote
bootz
(@bootz)
Eminent Member
Joined:1 year  ago
Posts: 21
March 22, 2018 9:00 pm  

@meznaric,

Do you get the Code 12 errors on both Thunderbolt 2 ports? On my iMac 4k 2015, if I use the TB2 port closest to the USB ports, I do not get the Code 12 error. If I use the other port, the error appears.

If the error occurs on both ports, open Device Manager and take a look at the status of unplugging and replugging. Also, try disabling the iGPU in Device Manager and re-enabling it later if you manage to get the drivers installed.

If you take a look at the build guide, there was someone who managed to get the iMac 4k 2015 working with AMD X Connect. While it isn't a MBP, it does share similar traits (iGPU Iris Pro only, AMD eGPU). Good luck.


ReplyQuote
meznaric
(@meznaric)
New Member
Joined:1 month  ago
Posts: 2
March 25, 2018 1:15 pm  

@bootz Thanks for the tips. I managed to get drivers installed. It doesn't matter which port I plug it into.

I will try to install AMD X Connect and maybe it makes a difference. I will also try to disable/enable internal gpu, but I assumed if I disable it I am without screen and I will be unable to reenable it. Will report what happens.

Edit: There is nothing different with trying to install AMD X Connect, seems it is just normal driver. I tried different port just to be sure, it didn't work.

Edited: 1 month  ago

ReplyQuote
jumpingsalad
(@jumpingsalad)
Active Member
Joined:12 months  ago
Posts: 12
March 30, 2018 3:08 am  
Posted by: meznaric

To hijack the thread because I can't send the messages yet and give some extra hopefully helpful info:

I have MBP Mid 2014 with only Iris Pro iGPU and I am trying to use Akitio Node TB3 -> TB2 with AMD R9 390
High Sierra (10.13.3) results: eGPU is detected even if hotplugged, but it won't work (if I remember correctly enclousre detected AMD HD8xxx  or something like that in Device Manager)
Windows 10 results: Detected, but currently stuck with Code 12, I tried pretty much everything I found on the forums except for dsdt override - I had some issues overriding it.

To my question:

Does nando's script work with GPT, I couldn't go into MBR route due to my quirky setup with Windows on external SSD? https://egpu.io/egpu-setup-13x/

have you tried logging out and logging back in on your macOS? my external display(connected to the egpu) was detected when I logged in and out. btw, I use aorus gaming box so YMMV


ReplyQuote
  
Working

Please Login or Register