MBP 2016 + Razer Core X Adding External SSD  

  RSS

OOP
 OOP
(@oop)
New Member
Joined: 3 weeks ago
Posts: 2
January 31, 2019 1:13 am  

Hey guys,

So I managed to install Windows Bootcamp on my MBP 2016 15" and have it hooked up to a Razer Core X running a Vega 56. I used the guide on this site and have it running well. During installation I disabled the PCIe lanes 1901 and 1905 and have my Razer Core X hooked up the top right side USB-C port. On the left side USB C port I have a USB hub connected for my mouse and keyboard.

I only assigned 300GB space for my bootcamp partition. I have a Samsung T3 SSD which I was previously using as a Windows boot drive and want to use it for storing games. Unfortunately, with the Razer Core X hooked up, I can't seem to use any of the ports to attach the SSD. Using the lower USB-C port on the right side crashes the system. The hub doesn't seem to load the SSD either. I understand that the issues might be due to disabling the PCIe lanes.

How is everyone else accessing external drives when using this config? Since I followed the guide here, I didn't actually encounter error 12. Wondering if any of the PCIe lanes can re-enabled?

Macbook Pro 2016 15" 2.9GHz 16GB > Razer Core X > Vega 56


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3554
January 31, 2019 1:23 am  

Once you boot in Windows with a functional eGPU, you can re-enable Root Controller 1905 to make use of the left-sided USB-C/Thunderbolt 3 ports. Which version of Windows are you running?

Best ultrabooks for eGPU use

eGPU enclosure buying guide

94 external GPU build guides


ReplyQuote
OOP
 OOP
(@oop)
New Member
Joined: 3 weeks ago
Posts: 2
January 31, 2019 6:17 am  

Windows 10 Pro and I think it has all the updates installed. 

Awesome, I’ll try and re-enable it and update. 

I also get occasional screen-flickering when no game or processor intensive app is running. Would this be linked to the PCIe buss? None of the power management fixes or undervolting the graphics card seems to help. 

Thanks for your help 🙂

EDIT: Re-enabling 1905 requires me to restart which seems to defeat the purpose. Is there any other way?

This post was modified 3 weeks ago

Macbook Pro 2016 15" 2.9GHz 16GB > Razer Core X > Vega 56


ReplyQuote
geojan
(@geojan)
New Member
Joined: 1 month ago
Posts: 1
February 11, 2019 12:57 am  

which install guide did you follow?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote