Notifications
Clear all

MSI GS40 Akitio Node MSI 1080 gtx  

 of  2
  RSS

nealqu
(@nealqu)
Active Member
Joined: 3 years ago
 

i just hooked up everything. Updated the thunderbolt to software 16.3. For some reason my pc could not detect the node. Whenever I connect the node it says try improving usb connection. Any ideas?

2016 14" MSI GS40 6QE (GTX970M) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
nealqu
(@nealqu)
Active Member
Joined: 3 years ago
 

Updating the bios fixed the issue Smile

2016 14" MSI GS40 6QE (GTX970M) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

Good work sorting it as a BIOS issue. Would you like to submit an implementation guide to give MSI notebooks more exposure as a user-verified eGPU candidate system?

Involved would be listing your notebook & eGPU hardware specs, steps needed to get it going, ideally a CUDA-Z bandwidth output to ensure you are getting full TB3 performance and some pics to bring it all to life.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
nealqu
(@nealqu)
Active Member
Joined: 3 years ago
 

Thanks for the reply. I would be happy to.

2016 14" MSI GS40 6QE (GTX970M) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

Thank you. There is also now a Interface Performance Reference. For 32Gbps-TB3 be aiming for CUDA-Z host-to-device near on 2254MiB/s to confirm everything is working OK.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
nealqu
(@nealqu)
Active Member
Joined: 3 years ago
 

I just found out that my host to device bandwidth is too slow. Already updated the node though.

2016 14" MSI GS40 6QE (GTX970M) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 
Posted by: nealqu

What did you use for testing? I  used CUDA-Z on mine.

Yes, CUDA-Z is being used. No other GPU intensive activities are to be done in the background. You want CUDA-Z to have exclusive access to the eGPU to measure peak link bandwidth.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
nealqu
(@nealqu)
Active Member
Joined: 3 years ago
 

I got the 40GB TB cable as well as an updated Akitio Node but I am getting very low numbers on device to host bandwidth. I wonder what else is up?

2016 14" MSI GS40 6QE (GTX970M) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

Check your TB3 controller's hosting port using hwinfo64 like at https://egpu.io/forums/pc-setup/xps-15-9550-not-able-to-reach-40gbps-over-tb3/ . Your CUDA-Z numbers are about what a 8Gbps x2 2.0 link or at best, a 10Gbps-TB1 link would give.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 [build link]  


ReplyQuote
nealqu
(@nealqu)
Active Member
Joined: 3 years ago
 

I actually have the Intel DSL6340 (Alpine Ridge 2C)listed when I checked on HWINFO. Further research suggest the following.

Intel® Thunderbolt 3 Controllers

The Intel Thunderbolt 3 controllers that power all this capability, codenamed Alpine Ridge, are formally called DSL6540 for the dual-port version, and DSL6340 for the single-port version. These powerful controllers provide 40Gbps Thunderbolt, USB 3.1 (10Gbps), and DisplayPort 1.2 all behind a single USB-C port.

2016 14" MSI GS40 6QE (GTX970M) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
 of  2