Share:

Please Help: X1Extreme + Razer Core X - dGPU Error 43  

  RSS

Neobond
(@neobond)
New Member
Joined: 3 months ago
Posts: 4
May 11, 2019 3:27 pm  

Hello,

I am trying to get my eGPU setup and I keep getting error 43 on my dGPU.

Lenovo X1 Extreme
8850H
4k Screen
1050TI MaxQ

Razer Core X
980TI (working in the desktop I removed it from)

I can get the laptop to recognize and use the 980TI in the Core X but in device manager the 1050TI has error code 43 and isn’t used when in laptop mode.

I have tried using DDU in safe mode, installing drivers with and without eGPU plugged in and both ways result in an error 43 on my dGPU.

How can I have both GPUs working with a hot swap plug and play solution?

Thanks!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


Quote
theitsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
Posts: 3939
May 11, 2019 5:28 pm  

It's a common issue with Nvidia dGPU + Nvidia eGPU. Use DDU to disable Windows auto-install of device drivers and remove all Nvidia graphics drivers. Make sure you have both the dGPU and eGPU show up in Device Manager as "Microsoft Basic Display Adapters" before you install the latest Nvidia drivers.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

94 external GPU build guides


ReplyQuote
Neobond
(@neobond)
New Member
Joined: 3 months ago
Posts: 4
May 11, 2019 9:35 pm  

@itsage

As you described above in this thread and many others I have read that is the procedure that I followed.

What ended up working was reinstalling the drivers with the eGPU connected after the steps described above, unplugging the eGPU, reinstalling the drivers to get dGPU working, plugging in eGPU and reinstalling drivers.

Figures crosses this works again when I upgrade the 980TI to something more useful.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


theitsage liked
ReplyQuote