Previously working eGPU setup stopped working in Win10 even without any obvious ...
Clear all

Previously working eGPU setup stopped working in Win10 even without any obvious Windows updates  


Active Member
Joined: 2 years ago

tl;dr: reinstalling Windows 10 in Bootcamp was the only way I found to fix a previously working setup that 'randomly' (maybe not; see possible breaking changes below) stopped working. Suspect a change to Mac boot security or a Mac OS update may have been cause.

Since I was able to fix the problem, this is more intended to be informative and to ask others if they've had a similar issue. For reference, I'm running a 2018 Mac Mini core i7 with a Razer Core X and a Sapphire Pulse Radeon Vega 56. Windows is version 1809. My setup has worked pretty well for >2 months. Ultimately the best boot process for me since I'm using Win10 for gaming has been to boot into OS X (10.14.6), set my cooling fan speed manually, power up the eGPU and plug the monitor directly into the Vega, then use system preferences>startup disk to boot directly into Bootcamp partition. When I boot back to Mac OS I use Bootcamp Assistant in Windows.

I was out of town for 4 days and powered down/unplugged system because we sometimes have power outages here. When I got back, the eGPU no longer worked in Windows. It would boot with a flash of the Windows loading screen, then to a black screen, then to a gray screen with a visible mouse cursor. From here I could click and enter my PIN without seeing the login screen. Windows would load, but oddly certain items weren't visible on screen and and open windows or applications were completely invisible. If I booted into Windows normally using iGPU and hot-plugged the eGPU, the eGPU would be detected with error 12. Oddly and perhaps most importantly, another driverless 'Base System Device' was shown in device manager flagged with an error. I've read that this might have something to do with the T2 security chip in 2018 Macs, but in this case it also seemed to coincide with the eGPU not working properly.

After trying a number of things (reinstalling video drivers, rebooting a bunch of times with different hardware configurations, hotplugging eGPU, automateEFI boot, etc) I finally just reinstalled Windows and was able to get it working again. I was unable to find or use any restore points of the three or four that I'd created previously in Windows. Perhaps Windows automatically deletes these at intervals? A couple of variables that may or may not have affected my setup are:

- Recently changing Mac OS X boot security settings back to disallowing external device booting and also to only used signed OS.

- Recently updating to the latest 10.14.6 version (haven't migrated to Catalina yet, but there was a relatively large security update recently for 10.14.6).

- Some small Windows update that didn't show a change in versioning?

Apologies for long post, but hopefully this helps anyone with a similar problem. It seems that sometimes a stable setup can just stop working even without an obvious Windows update/version change. I suspect something to do with Mac OS X security update is the culprit in this case but can't confirm.

2018 Mac Mini/i7/16GB
Razer Core X/Sapphire Pulse Radeon Vega RX 56
Old 1080p Dell monitor

2018 Mac Mini [8th,6C,B] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.14.6 & Win10 [build link]  

itsage liked
Spencer Cheng
New Member
Joined: 1 year ago

i have the exact same issue on my mbp 2019 razer core x with a rx 580. Any suggestions?

Macbookpro2019+ razer core x + Rx580