Setup & Software Discussions
Problem - 13" MacBook Pro error 12
 

Problem - 13" MacBook Pro error 12  

  RSS

Agov261
(@agov261)
New Member
Joined: 11 months ago
 

I have a Macbook Pro 13" non touch bar running Windows 10 build 1709 with a GTX 1060 6 GB, using a Sonnet Breakaway Box and I am primarily using the eGPU for my internal display. Using apple_set_os.efi I have absolutely no problems using the GPU. However I am experiencing performance degradation where Host to device is 16xx MiB/s which was identified here: https://egpu.io/forums/mac-setup/mbp-tb3-port-underperformance-16xxmibs-instead-of-22xxmibs-under-macos-or-windowsapple_set_os-efi/ . I have tried hot plugging with no success and either an "error 12" pops up, or a "device has no installed drivers" error shows up in the device manager. Anyone has advice to solve this problem so I can get the full 22xx MiB/s with my eGPU? Thank you for your time.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Maven
(@maven)
Trusted Member
Joined: 3 years ago
 
Posted by: Agov261

I have a Macbook Pro 13" non touch bar running Windows 10 build 1709 with a GTX 1060 6 GB, using a Sonnet Breakaway Box and I am primarily using the eGPU for my internal display. Using apple_set_os.efi I have absolutely no problems using the GPU. However I am experiencing performance degradation where Host to device is 16xx MiB/s which was identified here: https://egpu.io/forums/mac-setup/mbp-tb3-port-underperformance-16xxmibs-instead-of-22xxmibs-under-macos-or-windowsapple_set_os-efi/ . I have tried hot plugging with no success and either an "error 12" pops up, or a "device has no installed drivers" error shows up in the device manager. Anyone has advice to solve this problem so I can get the full 22xx MiB/s with my eGPU? Thank you for your time.

 

I don't think you need to use any of those scripts.

Just plug in the eGPU cable as soon as the Windows scroll wheel starts to spin at boot.

This will give you both internal and external acceleration.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Agov261
(@agov261)
New Member
Joined: 11 months ago
 

Hi. I have tried that as well, but once Windows boots up and I check the device manager, it gives me code 12.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago

ReplyQuote
Agov261
(@agov261)
New Member
Joined: 11 months ago
 
Posted by: Eightarmedpet

Use the left ports. The right ports have less bandwidth on the 2017 models.

I am using the left ports. I have the 2017 13 inch non-touchbar MacBook Pro. It does not have ports on the right.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote