Setup & Software Discussions
Problem with eGPU crashing MacBook pro bootcamp windows
 

Problem with eGPU crashing MacBook pro bootcamp windows  

  RSS

Defoler
(@defoler)
Eminent Member
Joined: 7 months ago
 

I have a 2017 macbook pro with touch bar with a main monitor of LG 5K.
And I want to add razer core x + rtx 2080 and connect them to LG 3440x1440 display.
I am running bootcamp windows on external SSD.
I connect the LG 5K to the mac and through it I get all my peripherals as well as the external SSD.
Once windows loads up, and I connect the eGPU, it takes a couple of minutes for it to recognise the eGPU, and it does. The device manager even identify the eGPU and shows nvidia rtx 2080. But after a few more seconds, the system hangs, and a windows crash error shows up (applespidevice.sys, IRQL error, and thread error, not limited to just one error). I tried either side, it does the same thing.

I'm just trying to figure out what is going on and what I'm doing wrong. I see people here talk about plug and play. Doesn't plug nor play 🙁

I don't want to lose the option to connect the LG to the MacBook pro alongside the eGPU.

This topic was modified 6 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Defoler
(@defoler)
Eminent Member
Joined: 7 months ago
 

Wanted to add that ditching the plan to use USB as an external OS, kinda "fixed" the problem, as large memory showed up when I used a 100GB of bootcamp created partition on the MacBook pro instead.
I still had many USB issues, with devices keeps getting disconnected, etc. With a bootcamp system (not external), at least all ports work, up to a certain performance point, so I used them. Kinda strange that the mac has no issues, but under windows there are a lot of restrictions.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@james_takeuchi)
New Member
Joined: 3 months ago
 
Posted by: Defoler

I have a 2017 macbook pro with touch bar with a main monitor of LG 5K.
And I want to add razer core x + rtx 2080 and connect them to LG 3440x1440 display.
I am running bootcamp windows on external SSD.
I connect the LG 5K to the mac and through it I get all my peripherals as well as the external SSD.
Once windows loads up, and I connect the eGPU, it takes a couple of minutes for it to recognise the eGPU, and it does. The device manager even identify the eGPU and shows nvidia rtx 2080. But after a few more seconds, the system hangs, and a windows crash error shows up (applespidevice.sys, IRQL error, and thread error, not limited to just one error). I tried either side, it does the same thing.

I'm just trying to figure out what is going on and what I'm doing wrong. I see people here talk about plug and play. Doesn't plug nor play 🙁

I don't want to lose the option to connect the LG to the MacBook pro alongside the eGPU.

MacBook pro egpu systems are never plug an play with thunderbolt 3. you should boot holding the option key from the ssd, plug in the egpu, wait for the egpu to power up and light up, then select windows from the boot menu. If you get the insufficient resources error, disable the igpu or dgpu

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@james_takeuchi)
New Member
Joined: 3 months ago
 

My egpu boots but crashes shortly after placing any load on it. if gpu usage goes over I think 5% then it disconnects from my MacBook. I tried replacing the cable but this fix only worked for 1 day and then it crashed and acted like the manufacturer cable. Is anyone else experiencing something like this? I have a 2018 MBP 15" and the gigabyte aorus gaming box rx 580.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote