Random freezing in Windows 10 Pro with Intel NUCi7BEH + Razer Core X + GTX 2060 ...
 
Notifications
Clear all

Random freezing in Windows 10 Pro with Intel NUCi7BEH + Razer Core X + GTX 2060 SUPER  

 of  5
  RSS

Erasmuz
(@erasmuz)
New Member
Joined: 6 months ago
 

I joined this forum just to say THANK YOU to the OP & others in this thread, I was having the exact same problem and this fixed it for me.

I recently purchased a Razer Core X Chroma and an RTX 2070 Super which I have connected to my HP EliteBook 850 G6.

My system would just randomly freeze as described in this thread, everything would stay on the screen but it was unresponsive. It was very frustrating! I did a fresh install of Windows 10 with nothing else except HP's drivers, Windows updates & the latest nVidia drivers but the issue persisted. With a fresh install of Windows 10 I could easily see there were no errors whatsoever in the Event Viewer happening before the freeze.

The freezing was also very random in that it wouldn't occur while I played a game for 1-2hrs, but would happen a lot more frequently just doing day-to-day tasks like switching Firefox tabs, maximizing a window, replying to an email or even deleting a file from the Desktop.

When it froze it did not matter what I did the only way to fix it was to hold down the power button until the system shut off. As a side note I can't boot with the eGPU plugged in, but I really don't mind unplugging it while it starts.

Thanks to this thread I made these two changes:

  • Control Panel --> Power Options --> Change Plan Settings --> Change Advanced Power Settings --> PCI Express --> Link State Power Management --> Plugged In --> OFF
  • NVIDIA Control Panel --> Manage 3D settings --> Global Settings (tab) --> Power management mode --> Prefer maximum performance

I'm not sure which of these two changes worked but I no longer have the very random freezing occurring which is just marvelous.

Again, thank you to the OP & everyone in this thread.

Razer Core X Chroma + RTX 2070 Super


ReplyQuote
Najjar
(@najjar)
New Member
Joined: 4 months ago
 

Been having the freeze issue for months, Long story short, it got resolved only after setting LSPM to off, one more thing to add is csenabled registry entry won't be available after WIN 10 2004 update. However, following this post helped me sorting it out:

https://appuals.com/how-to-restore-missing-power-plan-options-on-windows-10/#:~:text=You%20can%20restore%20the%20missing,%E2%80%9CRun%20as%20administrator%E2%80%9D%20option.

 

Build:

Dell XPS 13 7390, Razer Core X chroma, Asus RTX 2070S

 

Thanks

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

Mini i5 liked
ReplyQuote
Taylor John Arsenault
(@taylor_john_arsenault)
New Member
Joined: 2 months ago
 

@najjar, Hi,

 

Thanks for your post. I am still having this issue and really struggling to find how to enable the LSPM options in power management. Could you clarify which part of the article was helpful for you? Or could someone else help walk me through how to enable LSPM in power management since the CsEnabled regedit no longer works?

 

For reference I am using a dell XPS 13 7390 + Razer Core X + Zotac GTX 1660 mini

 

Thanks,

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Erasmuz
(@erasmuz)
New Member
Joined: 6 months ago
 

Hello again! I've been meaning to post this update, I hope it helps someone.

I updated my laptop from the HP mentioned previously to a Lenovo X1 Carbon Yoga Gen 4 and had exactly the same issues, so this was good to prove (to me at least) that this is a common fault across brands. I applied the fixes in my post above and it worked perfectly.

A little while ago I decided to install a fresh copy of Windows 10 for no reason other than I do it about once a year. I do this by downloading the Windows 10 ISO installation USB directly from Microsoft, wiping all partitions and installing from scratch. Once done I run all the Windows updates, then I run all the drivers & BIOS updates delivered through Lenovo's Vantage utility. Finally I install the latest nVidia drivers downloaded from their site - that's all I do OS & driver wise.

The issue returned (as expected) so I went to set the above mentioned two settings but this time my Link State Power Management option was gone! As others have mentioned above, Windows have hidden this setting in the newer version of Windows 10. I tried using the laptop having only changed the nVidia setting but it continued to crash. So I followed these instructions to re-show the option and set it to Link State Power Management --> Plugged In --> OFF

Registry Change: https://www.eightforums.com/threads/power-options-add-or-remove-link-state-power-management.50769/

I believe there are other ways to get this option to show so if this doesn't work for you just Google how to do it and follow your preferred method. After that it worked perfectly!

However I then started to wonder, was the nVidia setting necessary? Well, I can answer that question too! Just recently it started to crash again so I went back in to check these two settings. The Link State Power Management setting was still correct but after a recent nVidia driver update the Power management mode had been changed back to it's default state (which I think is "Optimal Power"). I set this back to Prefer maximum performance and since then it's been great once again.

So this post doesn't really add anything to my previous post, but it confirmed for me at least that the changes I mention in my previous post are 100% required at all times. It's a shame there's not a fix for this, like a setting in Windows & the nVidia driver that could detect an eGPU and set these options accordingly.

Razer Core X Chroma + RTX 2070 Super


ReplyQuote
Najjar
(@najjar)
New Member
Joined: 4 months ago
 

@taylor_john_arsenault, Hi,

 

I did Solution1 Solution2, and solution4 ... "Solution 2" is the actually sufficient, solution 1 would add the missing profiles ...

The Idea is to disable Power management on PCI express as TB3 connects to PCIe , and to do this you need to enable this flag in Regedit

image

and it would show in power profile management

image

 the challenge is that you have to go through regedit as mentioned in the link shared, and set value to 2, I suggest you search for the word PCI in regedit and change it as in the snapshot.

 

 

this video can be helpful to understand the how to disable power saving on PCIe (With CSenabled available in windows).

 

Overall this should be addressed through Razer Central Installation, but it doesn't create power profile anymore ...

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  5