Reduced GPU performance with Throttlestop Disable Lock Turbo Power Limits
 
Notifications
Clear all

Reduced GPU performance with Throttlestop Disable Lock Turbo Power Limits  

  RSS

iopean
(@iopean)
New Member
Joined: 1 month ago
 

Hey all!

Pretty new here but got myself set up with a Dell XPS 13 9300 and a 2070Super via a Razer Core X.

All working pretty well actually but I'm seeing a bit of a strange kind of behaviour that I wouldn't expect...

It is most evident in a benchmark for Rise of the Tomb Raider - but also happens with various 3DMark benches too; as I increase the performance of the CPU by either undervolting or disabling the tubo power limits, the performance of the GPU decreases.  Anyone have any idea of the dynamic that is causing this behaviour?

Cheers

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Boltoway
(@boltoway)
Eminent Member
Joined: 2 years ago
 

The first thing I would do is run Intel XTU as a monitoring software while you benchmark with and without the modified CPU operating parameters. Do a couple of runs with different settings, and take note of whether XTU records an increase in power limit throttling or thermal throttling with your adjusted settings.   

Dell XPS 13 9380 (i7-8565U, 16GB RAM, 1TB Samung 970 Evo Plus) + Razer Core X + AMD RX VEGA 64 Limited Edition + Acer Nitro 27" VG271UP

 
2019 13" Dell XPS 13 9380 [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Razer Core X) + Win10 [build link]  


ReplyQuote
iopean
(@iopean)
New Member
Joined: 1 month ago
 

Hey, thanks for the suggestion. Unfortunately I can’t install XTU as it seems Ice Lake CPUs are not on the supported list so it flatly refuses to install.

I've monitored Throttlestop though and as you’d expect with a reduced vcore and no power limit the CPU throttles less ( temp only while maintaining much higher clocks)and is performing faster as per score results. Though, GPU is then scoring less.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote