Share:

RTX2080Ti cannot be used for OpenCL in Windows Bootcamp with 15-inch MPB2018 and dGPU?  

  RSS

OliverB
(@oliverb)
Noble Member
Joined: 7 months ago
Posts: 1200
December 2, 2018 1:19 am  

I just made a eGPU Build with a RTX2080Ti and installed it in Windows. Everything is running fine, but it is not possible to use it as OpenCL device.

-AIDA64 GPGPU Benchmark doesn't list ist.
-Luxmark doesn't list it.
-Geekbench doesn't list it.

It's corectly listed as Cuda-Z. They say the nVidia driver includes the OpenCL driver. I have just freshly installed Bootcamp with the newest nVidia driver, but not OpenCL for the RTX2080Ti.
Can anyone tell what's wrong?

Screenshot from AIDA64 says Cuda, but no OpenCL.

noOpenCL

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680


Quote
Topic Tags
OliverB
(@oliverb)
Noble Member
Joined: 7 months ago
Posts: 1200
December 2, 2018 8:32 am  

In case someone wants to help me: With the same eGPU (enclosure and gpu) and Mac and Windows Version, I get everything correct at the 13-inch MBP 2015:

AID64 GPGPU RTX TB2

As I extra reinstalled Windows 10 on the 15-inch MPB 2018, it must have to do with the fact that the dGPU Radeon Pro 560 is interfering. Anyone else must have these problems, no?
@itsage or @mac_editor, any idea?

PS: Deactivating Radeon560X driver or/and using GTX1080Ti didn't solve the problem. The nVidia cards just won't be detected as OpenCL devices.

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680


ReplyQuote