Setup & Software Discussions
RX 580, MBP 2014, Windows 10 1809, error 12
 

RX 580, MBP 2014, Windows 10 1809, error 12  

  RSS

Espionage724
(@espionage724)
Active Member
Joined: 3 months ago
 

I don't know if I was missing anything, but the few times I've tried to get this eGPU working, Windows refused to load the driver (error 12; insufficient resources or something along those lines).

 

  • Specs in signature up-to-date
  • Windows 10 LTSC 1809 (installed directly in UEFI mode; not through Bootcamp)
  • Using AMD's latest driver (newer than 19.8.2; directly from AMD's website)
  • Latest MBP firmware (157.0.0.0.0/Catalina; I believe a firmware date of 2019/07/24)
  • I tried both rEFInd (with macOS spoof) and apple_set_os.efi (both allowed the iGPU to stay on, the eGPU to be detected, but didn't solve error 12)
  • automate-eGPU EFI didn't work (froze as soon as I selected Windows)
  • eGPU works fine on macOS 10.14 and 10.15, along with Linux (hardware seems ok)
This topic was modified 3 weeks ago

MacBook Pro (Retina, 13-inch, Mid 2014)
AKiTiO Thunder2
XFX Radeon RX 580
macOS Catalina 10.15
Fedora Workstation 31 Beta


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 1 month ago
 

Have you tried automate-eGPU EFI?

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
Espionage724
(@espionage724)
Active Member
Joined: 3 months ago
 
Posted by: @aj_scarcella

Have you tried automate-eGPU EFI?

Yep; it didn't do anything (it freezes right after selecting Windows)

MacBook Pro (Retina, 13-inch, Mid 2014)
AKiTiO Thunder2
XFX Radeon RX 580
macOS Catalina 10.15
Fedora Workstation 31 Beta


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 1 month ago
 

Is Windows installed using Bootcamp?

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
Espionage724
(@espionage724)
Active Member
Joined: 3 months ago
 
Posted by: @aj_scarcella

Is Windows installed using Bootcamp?

No; I installed it directly (wiped SSD, booted Windows install USB directly from EFI).

MacBook Pro (Retina, 13-inch, Mid 2014)
AKiTiO Thunder2
XFX Radeon RX 580
macOS Catalina 10.15
Fedora Workstation 31 Beta


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 1 month ago
 

I believe that automate-eGPU EFI looks at the Mac’s install drive’s EFI partition to boot Windows. You’ll need to copy the Microsoft folder out of the Windows install drive’s EFI partition into the Mac install drive’s EFI partition. 

There are instructions in the forums to do this (I can’t search right now) but the general process is this in Terminal:

1. Mount an empty EFI drive

2. Assign the hidden Windows EFI partition to the empty EFI drive  

3. In Finder, open the EFI drive and copy the Microsoft folder

 

4. Eject the EFI drive

5. Remount an empty EFI drive

6. Assign the hidden Mac EFI partition to the drive

7. Paste the Microsoft folder in the EFI drive (goes in the same containing folder that has the Boot folder)

8. Try loading Windows from automate again. 

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote