Second Monitor Not Going Beyond 40FPS
 
Notifications
Clear all

Second Monitor Not Going Beyond 40FPS  

  RSS

Henry Sahdala
(@henry_sahdala)
Active Member
Joined: 11 months ago
 

Hello everyone, I hope you're all doing well in these difficult times. I have an issue and would really appreciate your input. 

 

I recently installed my eGPU with a graphics card. It is connected to an external monitor via DisplayPort. When I play games, currently tried Halo Master Chief Collection, Overwatch, Wolfenstein II, and The Witcher III, my external monitor does not beyond 40FPS independently of the graphic settings I use. For some reason, in certain moments the FPS goes beyond 40 but no higher than 60. What could it be? Below you'll find the details of my setup.

 

Setup:

-Razer Blade Stealth (2019) - Intel i7-1065G7 @ 1.30GHz, 16GB RAM, GTX 1650 Max-Q, 1080p 60Hz Screen 

-Razer Core X Chroma with an RTX 3070 MSi Gaming X Trio, connected to Laptop via ThunderBolt 3 Cable, not the one included in the Core because it is too short, so I'm using this one by Cable Matters, https://www.amazon.com/gp/product/B01H5QF2TK/

-PX7 Prime, 1440p, 165Hz, connected to the GPU using a DisplayPort cable, https://www.amazon.com/Pixio-FreeSync-Certified-Warranty-Compatible/dp/B07WGXXV55

 

I would really appreciate any solutions you suggest, hope to hear from all of you soon!

 

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@henry_sahdala, Did you try turning off G-Sync and make sure the refresh rates in Nvidia Control Panel are at 165 Hz? 

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Henry Sahdala
(@henry_sahdala)
Active Member
Joined: 11 months ago
 

@itsage, Hi! Thank you for your reply!

 

I just tried what you mentioned and still no change. Could it have something to do with me using the cable by Cable Matters instead of the one that comes with the Razer Core?

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@henry_sahdala, The Cable Matters TB3 cable is good (40 Gbps). You can try disable the GTX 1650 Max-Q dGPU in Device Manager and set Windows to show the external PX7 Prime monitor only.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Henry Sahdala
(@henry_sahdala)
Active Member
Joined: 11 months ago
 

@itsage, You say that I should disable my laptop's screen while playing?

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Henry Sahdala
(@henry_sahdala)
Active Member
Joined: 11 months ago
 

Hey, just sorted it, apparently, it had something to do with the Whisper Mode on GeForce Experience. I could not see it with the eGPU connected, but I unplugged everything, then turned off whisper mode, restarted the computer and everything worked! Thank you!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote