Serious eGPU issues after update from Windows 10 Build 1803 to 1903. I can't ins...
 
Notifications
Clear all

Serious eGPU issues after update from Windows 10 Build 1803 to 1903. I can't install Build 1803 anymore.  

 of  2
  RSS

OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 

Dear community,
I am actually fighting with a eGPU setup (13-inch 2015 MBP, RX 570) that has been working flawlessly with Windows 10 Build 1803. After updating to Build 1903 hardly anything works anymore:

1) Hot-plugging eGPU doesn't work at all. The device doesn't even appear in Device Manager
2) It's not possible to boot with eGPU and another TB2 device plugged in. I must unplug the other TB2 device during boot in order to avoid Error 12 and get the eGPU running, 
3) Sleep and Hibernation cause havoc in the system. The eGPU will just disappear, other devices don't work anymore. This feature worked flawlessly with 1803
4) Performance is worse then it has been with 1803.

It's reproducible that those problems come with Build 1903 and go with 1803, because some weeks ago I could revert to 1803 and everything worked again. Especially 2), 3) and 4) never have been a problem with Build 1803. 

And the worst now:
5) I cannot install 1803 anymore with Bootcamp. Bootcamp Assistant won't allow the iso, saying "Need 64-bit Windows 10 or later ISO file" even though it's the same ISO file I have been using before. It will only accept and install a Build 1903 ISO.

So now I really need your help. I cannot go back to 1803 (why?) and the eGPU is hardly working. There are two separate topics, the eGPU issues and that I cannot install Build 1803 anymore.

Can anyone give me some hints about this? Experts like @itsage, @mac_editor, @goalque, @joevt or @eightarmedpet?

This is a link to my build.

This topic was modified 10 months ago

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@oliverb

Are you still on Mojave or Catalina?

Typically 1903 is the easiest with eGPU except for the recent updates: https://egpu.io/forums/pc-setup/egpu-fail-after-update-to-windows-19-03/

Consider downloading Windows 10 1809 (October 2018) Update instead and trying: https://www.microsoft.com/en-us/software-download/windows10ISO

Alternatively, manually install Windows 1803. You might be able to use Etcher to create a bootable disk.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

I agree with @Mac_editor to try Win10 1809 ISO through Boot Camp Assistant first. If that doesn't work still, you can do a manual installation through a Win10 1803 USB drive.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 

@mac_editor, @itsage
Thank you for your replies. The MacOSX is Mojave 10.14.6.

It have tried an 1809 ISO as well, without success. I still don't get why it's not possible? It was possible before, this is sure, but why not anymore? Because generally they don't allow anymore those builds or it's because on the particular laptop there was a 1903 already installed?

@mac_editor
You are saying that 1903 is very easy to setup, does this rule apply for sleep/hibernation, too? Because this is the issue that bothers most. Sleep/Hibernation with 1803 had no problems, with 1903 it's impossible. There should be others who have the same problems and perhaps there is a solution?

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@oliverb

Indeed. IMO eGPU support has improved. Latest improvements on 2018 MBPs include AMD eGPU hot-plug and no need to uninstall eGPU to keep internal display active. Windows build 1903 (18362.295) has been the most optimal. Can switch to clamshell mode in Windows too (need to log in again).

Maybe you need to change some settings related to sleep which you did on 1803 but not on 1903? For example, I disable hibernation in Windows (it works fine - but is horrible).

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 

@mac_editor,
I think the eGPU support may have improved for newer computers, especially for TB3. Unfortunately this is not correct for my wife's Early 2015 13-inch, which has TB2 ports. Settings are identical and Sleep alone doesn't work.  I guess the improvements were made for newer models/TB3. 

Other topic, for information: On my 15-inch 2018 Build 1903 did not worsen the situation, but neither improved it really. Hotplugging an AMD eGPU works only the very first time, when drivers are getting installed. Every try later => Error 12, too.

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

@oliverb sort to hear you are having troubles! I have experienced plenty of odd behaviour when trying to instal W10 on various machines. I wonder if there is something left over in your EFI folder that is causing an issue (total guess based on no real knowledge.

Your instal problem is probably macOS related so I'd be inclined to reinstall macOS so everything is nice and clean, and prob check for stray partitions in recovery mode.

Then maybe download another ISO if that one is failing still?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 

@eightarmedpet
No, it's not thaaat bad, only some strange things happen.;)
I have tried several ISOs and all failed but the 1903 one. I have cleaned the system, deleted the partitions and completely reinstalled MacOSX: Still no other ISO than the 1903 will be accepted. That is very strange.. hmm?!

But, as it is, my wife loves the new Windows 10 Build 1903 so we will probably stick to it and try so solve the eGPU related issues. The most annoying one is the Sleep/Hibernation: How could a system change this much from a update? 

Do you know any tips and tricks to get sleep or hibernation working. One of them would be great. Did it always work for you? I have/had problems before with nVidia cards in Bootcamp, but not with the RX570 and the 2015 model.

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@oliverb

Could you elaborate on what happens when sleep/hibernation does not work?

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@oliverb Sleep with an eGPU connected doesn't work for me. Waking up from sleep would show a black internal display. I believe it might work when the Intel iGPU is activated and attached to the internal display.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
 of  2