Severe performance issues since 1903 with Blade 15 + CoreX (1080Ti)
 
Notifications
Clear all

Severe performance issues since 1903 with Blade 15 + CoreX (1080Ti)  

  RSS

Plattenschieler
(@plattenschieler)
New Member
Joined: 1 year ago
 

Hi, 

I recenlty started playing BF V again with massiv performance issues. My CPU usage is allways at 100% on all cores while my GPU is sitting arround freaking 8-11%. 
I changed all settings back and forth, reinstalled Nvidia Drivers and whatnot. I dont know waht to do now. 

Regardless of the settings in BF V I get arround 60-70 FPS. On Ultra and on Low. Heaven ist significantly lower in score. WTF is happening with 1903 and eGPU 😕 

Anyone with the same issues? 

Edit:
8750H
16GB
external Monitor with 144Hz and 1440p

This topic was modified 1 year ago

Razer Blade 15 (2018) with Core X and 1080 Ti

 
2018 15" Razer Blade 15 (GTX1070) [8th,6C,H] + GTX 1080 Ti @ 32Gbps-TB3 (Razer Core X) + Win10 [build link]  


ReplyQuote
Plattenschieler
(@plattenschieler)
New Member
Joined: 1 year ago
 

Since no one had something to comment I want give a Solution to this: 

1. 1903 sucks.
2. Re-Installing Windows and drivers did not solve the problem.
3. The problem consists even with undervolt, different TB3 Cable and different GPU inside the CoreX (1080Ti).
4. The reasen is simple: The 25 Watt CPU limitation of the Razer Blade 15 (2018 Advanced)! 
5. The solution not so much: Since the Blade 15 2018 does not have and get the "Creater" Mode, you have to use the "Gaming" mode within the Razer Synapse Software. 
The moment you switch to "Gaming" mode, the System will lift the 25 Watt limitation and everything just works fine. CPU is arround 30-40 Watt usage and GPU is running at 100%. 
FPS in Battlefield 5 arround 70 on 1440p and ultra. Very nice!

I did not use the "Gaming" in the past because a stupid issue: When switching to "Gaming" mode, the system would overclock the GPU in the CoreX which lead to crashes and black screens in the past.

Razer Blade 15 (2018) with Core X and 1080 Ti

 
2018 15" Razer Blade 15 (GTX1070) [8th,6C,H] + GTX 1080 Ti @ 32Gbps-TB3 (Razer Core X) + Win10 [build link]  


ReplyQuote
jerry Kansai
(@joi_kansai)
Estimable Member
Joined: 3 years ago
 
Posted by: Plattenschieler

Since no one had something to comment I want give a Solution to this: 

1. 1903 sucks.
2. Re-Installing Windows and drivers did not solve the problem.
3. The problem consists even with undervolt, different TB3 Cable and different GPU inside the CoreX (1080Ti).
4. The reasen is simple: The 25 Watt CPU limitation of the Razer Blade 15 (2018 Advanced)! 
5. The solution not so much: Since the Blade 15 2018 does not have and get the "Creater" Mode, you have to use the "Gaming" mode within the Razer Synapse Software. 
The moment you switch to "Gaming" mode, the System will lift the 25 Watt limitation and everything just works fine. CPU is arround 30-40 Watt usage and GPU is running at 100%. 
FPS in Battlefield 5 arround 70 on 1440p and ultra. Very nice!

I did not use the "Gaming" in the past because a stupid issue: When switching to "Gaming" mode, the system would overclock the GPU in the CoreX which lead to crashes and black screens in the past.

Thanks for sharing. You can still rolling back right? Undervolting cpu is for boosting better performance by making cpu cooler, there’s nothing to do with that cpu usage, 1903 somehow  bottleneck your cpu.
I use always gaming mode when gaming with core setting, yes it’s running on normal cpu tdp unlike on balanced mode which is power limited on 25 watt, so mostly I run on max frequency I think I never see it under 3,9ghz and no cpu power limit throttling sometimes maybe gpu, but it doesn’t ruins gaming experience like cpu one, since gpu usage on high 99% which means effective.
You don’t need creator mode, if you’ve afterburner go there and reset gpu overclocking value when you’re on gaming mode, Creator mode on early 2019 Blade 15 runs cpu on higher tdp with no Gpu OC, and weirdly gaming mode on that model applying no gpu OC, means they’re both same. I heard in mid 2019 model they erased it, seems on this new model only balanced and costum which you can apparently set your self.
Only my curiousness, 2018 Blade OC Core +100/ memory +300, what is your card? Because with the cheapest Zotac Mini I was fine with +125 almost a year, no crashing whatsoever from previous laptop before Blade 15.

Razer Blade 15 2018, i7 8750H 16gb ddr4 2666mhz 1tb 970Evo
Razer Blade Stealth 12,5 2016 i7 7500U 8gb ddr3 1866mhz 500gb 970Evo
MacBook Pro 13 mid 2012 i5 3210M 12gb ddr3 1600mhz 500GB HDD
Razer Core V2 rtx 2070 Black 2040mhz Boost clock
Previous setting: rtx 2080ti Asus Turbo, rtx 2080 xc gaming, rtx 2080 Fe, Zotac Mini 1080ti, Evga 1080 FTW2 gaming.
Dual Monitor Predator XB241YU 165Hz 1440p, LG l24UD58 60Hz 4K
Portable Monitor Magedok 1440p HDR 60Hz usbA/C monitor

 
2016 12" Razer Blade Stealth [7th,2C,U] + RTX 2080 Ti @ 32Gbps-TB3 (Razer Core V2) + Win10 1803 [build link]  


ReplyQuote
Juan Pablo Escobari
(@juan_pablo_escobari)
New Member
Joined: 3 months ago
 

@plattenschieler, Thanks for posting this solution.

I have a very similar setup and messing around with my Razer Synapse configurations somehow managed to limit my frame rate in Call of Duty to around 60-75 FPS.

I'm not exactly sure what I did, but I was getting so much better performance before, and now I'm crossing fingers that this is the solution.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote