Setup & Software Discussions
Windows NUC8i7hvk with eGPU. sSonnet Breakaway Box with AMD Razer Vega 64. Const...
 

Windows NUC8i7hvk with eGPU. sSonnet Breakaway Box with AMD Razer Vega 64. Constant Black screen.  

  RSS

George Tufeanu
(@george-tufeanu)
New Member
Joined: 3 months ago
 

Hello. Thanks for accepting me in this great group and  topic site. I have a question. Short said : Windows computer NUC8i7hvk. Connection HDMI, Samsung Q65Fnat 2018 TV. CONNECTED TO NUC, Sonnet Breakaway box eGPU with AMD Razor Strix Gaming,Vega 64.
PROBLEM. Screen goes black when I connect  eGPU and I am forced  to reinstall  Windows constantly. I installed all drivers from Intel ( the intern Grph. Card is much sluggish and les potential for gaming but at least it doesn’t get the screen black.) I install the drivers from AMD and that Adrenaline which for some time saw the eGPU but at a point it closed the intern graphic card and tried to use the eGPU and fro that point every single time the screen goes black if connected to eGPU. I feel it’s a conflict between Intel, AMD and probably Windows 10 drivers.
QUESTION: Does or did anybody experienced such a think of a black screen with eGPU in Windows 10 ?
Please help !

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

Which version of Windows 10 are you running? I’d recommend using DDU first to remove all graphics drivers then install latest Radeon drivers with the eGPU connected. Your black screen issue might be due to incompatibility between the set of drivers for RX Vega 64 eGPU vs. set of drivers for RX Vega M dGPU.

Best ultrabooks for eGPU use

eGPU enclosure buying guide


ReplyQuote
George Tufeanu
(@george-tufeanu)
New Member
Joined: 3 months ago
 

Thank you very much for the help answer. I will definitely try to install DDU and see what’s happening. I am just tired of reinstalling the windows again because of the black screen issue. Windows 10 Pro, Version 1903, OS build 18362.175
Thank you very much for your kind help. 
George T.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote