Yoga 730 15 + Razer Core X: Thunderbolt Driver Issues
 
Notifications
Clear all

Yoga 730 15 + Razer Core X: Thunderbolt Driver Issues  

  RSS

Wa1fu
(@wa1fu)
Active Member
Joined: 5 months ago
 

I got an eGpu a few months ago and have been using it with a Lenovo Yoga 730 15-IKb and found that only thunderbolt control center seemed to fix my connection issues, so after much headache and hassle I managed to install the software and everything was working fine.

Two days ago, I suddenly got the "Thunderbolt device functionality may be limited" issue, and I know it wasn't my eGPU or card as it was working previously, so i figured it was a driver issue. I tried a clean reinstall of thunderbolt drivers, but found that no matter what I did, I couldn't get thunderbolt control center installed on my laptop again.

I tried installing

  • legacy drivers(17.x)
  • suggested thunderbolt drivers from lenovo
  • 1.4.1 dhc drivers

None of them worked, so I tried factory resetting my laptop. When trying to install either the legacy or reccommended lenovo drivers, even after multiple reboots thunderbolt drivers refused to even show up in device manager (even with show hidden devices and tested with my eGpu connected or disconnected), so i did another factory reset (to ensure I didn't have leftover driver files) and tried to install the dhc compliant drivers from intel. When installing them manually through installing the .inf files, I found that TbtHostControllerToastComponent gave, "The system cannot find the file specified." 

After discovering none of the recomended solutions online worked, I proceeded to try a combination of all three of these with various wait times inbetween and testing with having my eGPU connected or disconnected, with a factory reset each time. On a few miraculous attempts, the thunderbolt driver showed up in the device manager, but the thunderbolt control center did not install itself and attempting to install from the microsoft store gave yet again another error. However because the drivers finally showed up in device manager, I tried updating them through browsing system files, yet after they updated the drivers, I still could not install thunderbolt control center from the microsoft store.

The core x fans spin whenever I connect the eGPU to my laptop, but the GPU fans dont turn on, and GPU never shows up in display adaptors in device manager. Core X however shows up in USB devices.

I have been attempting to install thunderbolt drivers nonstop for the past two days, and am at my wits end. If I cant find a solution I'll have ended up purchasing a very expensive paperweight. If anybody could provide a walkthrough for installing thunderbolt drivers or another solution that may have worked it would be greatly appreciated 🙁

EDIT: After a factory reset and clean install I seem to have the thunderbolt control center app, but it refuses to open. When checking app settings, it is 0 bytes(?) which leads me to believe it hasn't been installed properly through the drivers.

This topic was modified 5 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote