FCPX Coremelt plugin failure, thinks the lid is closed any ideas?
 
Notifications
Clear all

FCPX Coremelt plugin failure, thinks the lid is closed any ideas?  

  RSS

dfphoto
(@dfphoto)
Eminent Member
Joined: 1 year ago
 

Hi group, I have 2014 mbp using a gigabyte RX580 setup, thanks to mac_editor for making purge-wrangler, and purge-nvidia they seem to work pretty well, but in my testing today I have a couple of issues. I ran the script to allow selecting the egpu in get info on osx 10.13.6 (I forgot who wrote that script), but on restart I do not see this option. Wondering if everyone is moving to 10.14.

Next is the big issue, in FCPX 10.45 the app thinks the clam is closed and crashes when using Compressor, I have not tried a complete test yet but wondering if anyone has any ideas. Thanks Dave

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@dfphoto I presume you mean you used set-eGPU. Once the eGPU preference is set, it is permanent until you unset the preference. Anyway, I suggest upgrading to Mojave for a more refined eGPU experience (especially with apps for which you need set eGPU preference). Not sure about FCP/Compressor and cannot debug, but it is possible that purge-nvda might be causing problems. Sadly with NVIDIA dGPU-based macs that can’t be helped (unless external monitor is not needed). 

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
dfphoto
(@dfphoto)
Eminent Member
Joined: 1 year ago
 

Hi thanks for the reply, I forgot I had downloaded FCPX 10.4.6 and after a restart, I am not yet seeing this error message. I also donated some money to you. Thank you for being generous.

I will check the forum but I'm always afraid to upgrade osx due to plugins and all that stuff never working. However, most people are running 10.14? since I'm on an older mbp I'm wondering if that will affect my Nvidia card (built in).... I'll reply in a couple days once I check the bug and see if 10.4.6 fixed it....

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
dfphoto
(@dfphoto)
Eminent Member
Joined: 1 year ago
 

Sorry updating my original post, after updating fcp to 10.4.6 and compressor to 4.4.4 running osx 10.13.6 with the last security update and nvidia web driver and cuda driver. I have my external gigabyte 580 gaming box via the TB3/2 adapter working. Being on an older TB2 machine I was only hoping for 30% in gains which I see in Capture One Pro and some gains in Photoshop CC. I see some gains in FCPX and the only issue I had was the Coremelt plugins telling me there is a problem and my clam shell is closed. (it isn't) I had to run purge-nvda #5 to remove the nvidia driver, restart the compressor/sharing in fcpx would work as normal. The interesting thing I see now is the IRIS Pro is running about 3 bars the geforce gt 750m is running 2 bars and virtually zero on the RX580 but this compressor only... Find it interesting... but something seems off. Maybe I need to run the purge-wrangler again but if anyone knows this I'd appreciate it.

This post was modified 1 year ago

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote