mini-eGPU with AKiTiO Thunder3 & Thunder2 & Node Lite (the best Implementations)  

Page 7 / 8 Prev Next
 

Adgar
(@adgar)
Active Member
Joined:1 year  ago
Posts: 6
August 28, 2017 8:17 am  

 

hi guys, i'm thinking of buying a rx 480 8gb reference used, i have a doubt about the power stability. I have a DELL DA-2 with Akitio thuner2, . is any of you working with such a configuration?


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
August 28, 2017 9:13 am  

Thats an amazing mod @papoboy

How did you get it drilled out?

 

@Adgar the 480 is too long to fit in the Thunder2. You should hunt out an OEM HP RX 480 mini card or a 570 Sapphire Pulse.

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
Adgar
(@adgar)
Active Member
Joined:1 year  ago
Posts: 6
August 28, 2017 9:44 am  

 

I know thank you, i thought i take a rx 480 to have full compatibility with High Sierra, i have a Thunder2 and i will use only the inside. I have only a doubt about Power consumption with DEell DA-2.


ReplyQuote
papoboy
(@papoboy)
New Member
Joined:12 months  ago
Posts: 2
September 5, 2017 8:56 am  

@Eightarmedpet  Thanks. I drilled the holes using my desktop CNC mill.


ReplyQuote
vitas_TS
(@vitas_ts)
Active Member
Joined:12 months  ago
Posts: 14
September 15, 2017 1:32 pm  

How can I plug this into my gtx 1060?

Please help, thanks!!

WechatIMG67


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
September 15, 2017 1:37 pm  

You need a different PSU, not the one with the  3.5 or whatever plug... all in first page of this thread.

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
drwnsm
(@drwnsm)
New Member
Joined:1 year  ago
Posts: 4
September 16, 2017 8:32 am  

Hey guys, I really need your help, because I've run out of ideas.

I got a 13' MBP 2017 without touch-bar, trying to connect an Akitio Node Light mini eGPU containing an EVGA GTX 1050TI (also tried the same card by Zotac), powered by an external Leicke AC Adapter 12V 10A 120W. I'm running 10.12.6. I've tried the automate-eGPU.sh and Rastafabi's eGPU Enabler. Both led to the same error. The Card gets recognized correctly by the script, but Mac OS only displays the card as "Nvidia Chip Model". I've already tried to completely set up a clean install of Mac OS, reinstall drivers and scripts several times and use different boot+hotplug/plugin possibilities. Is there anything I've missed? 

Thanks for your help!

René

Edit: Firmware update fixed it.


ReplyQuote
thiagon
(@thiagon)
Active Member
Joined:1 year  ago
Posts: 14
September 20, 2017 12:45 pm  
Posted by: deplomb

@lifecom

here is the housing as 3d dxf,
please doublecheck all dimensions with the original case before constructing!

I have bought the Akitio Thunder2 but only the card itself (without the case) , I am considering requesting a company to build one for me, I've requested a quotation with this drawing but had insuficcient "views" for them to prepare the case.. would you be so kind to share the complete drawing with the different layers? 

Thank you very much in advance. 

Regards from Brazil


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
September 20, 2017 12:50 pm  

If you only care about macOS I'd maybe swap the 1050ti for a 460/560/570. Could be worth trying in Windows?

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
theBLUPRNT
(@thebluprnt)
New Member
Joined:11 months  ago
Posts: 3
September 21, 2017 10:46 pm  

Great post very helpful! I have a few questions as a newbie:

  • What is the difference between the thunderbolt 3 or 2 version vs. the node lite? Is it just that the lite needs an external psu?
  • Also can you not just buy the thunder3 version and use an adapter to work with an older thunderbolt port e.i. MacBook 2013? If so what's the point of having both models.
  • Lastly, I have a mini-itx model graphics card: Gigabite GeForce gtx 1060 3gb mini. ( https://www.gigabyte.com/Graphics-Card/GV-N1060IXOC-3GD#kf) Will this fit in these models?

Again great post I have more questions but I'll probably create a thread of my own. 

 

Thanks !


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
September 25, 2017 7:20 am  

I just replaced the fan in my Thunder3, the listed Noctura one didn't fit at all, 5mm too thick and the card was already touching the stock fan so I hunted out one the same size but better quality.

 

https://www.amazon.co.uk/gp/product/B00261743M/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
tristank
(@tristank)
Active Member
Joined:11 months  ago
Posts: 11
October 5, 2017 1:45 pm  

I'm slightly confused- which of this adapters is the right one if I want to use it with a closed thunder3 enclosure and Zotac GeForce GTX 1060 Mini 6GB connected to a Dell DA-2?

?

Posted by: Eightarmedpet

I just replaced the fan in my Thunder3, the listed Noctura one didn't fit at all, 5mm too thick and the card was already touching the stock fan so I hunted out one the same size but better quality.

 

https://www.amazon.co.uk/gp/product/B00261743M/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc

Thanks for the tip! I just ordered one. Much cheaper than the nf-a6x25flx.


ReplyQuote
TrIX
 TrIX
(@trix)
New Member
Joined:11 months  ago
Posts: 2
October 5, 2017 5:35 pm  
Posted by: papoboy

Here's my mod of the Akitio Thunder3. I have a Zotac GTX1060 in it.

Great design. Can you pls share your dxf file?


ReplyQuote
Alberth-OC
(@alberth-oc)
New Member
Joined:1 year  ago
Posts: 3
October 6, 2017 1:17 am  

Hello everyone, I'm coming here because I need help for members who handle eGPU via Thunderbolt 3. A friend of mine owns an Intel NUC NUC6i7KYK. It acquired the Akitio Thunder3 for being cheaper at the moment and a MSI RX 560 GPU; We installed Windows 10 on it because the eGPU only works with this OS according to the manufacturer, we installed all the drivers with the Driver Booster, but then the problems begin, when it starts the NUC with the eGPU connected the video card gets the fan trying spin, but looking like it can not. Another detail is also that when it enters the Device Manager it appears these three devices apparently without driver, translating they are:

"Signal processing and access control"
"Base system device"
"SMS / MMS"

The problem in this story is that the NUC does not come with a CD / DVD drive, so the CD that comes in the eGPU box and that may have the driver of these devices can not be used and it has no PC or Laptop on the site of Akitio we did not find the drivers of AKitio Thunder 3. The question is, is eGPU not working because of lack of eGPU driver? Could someone with Akitio Thunder 3 pass the drivers to us? Lack of power I already discarded because the RX 560 consumes little energy, just like the 1050Ti. I'm also talking to him to download the "Thunderbolt 3 Controller Firmware Update Tool" and the "Thunderbolt Bus Driver for Intel" on the Intel site to see if there is any lack of update of Thunderbolt 3. Remember that neither in the Device Manager Video Card appears to try to install its drivers. Thank you!


ReplyQuote
ondert
(@ondert)
Trusted Member
Joined:1 year  ago
Posts: 58
October 6, 2017 11:36 pm  

Which mini case is the best for OEM RX580/480  with 15" Macbook Pro touchbar attached on MacOS?


ReplyQuote
milap
(@milap)
New Member
Joined:9 months  ago
Posts: 1
December 5, 2017 11:43 pm  

Hello everyone,

Do You know what would happen when I will connect USB-C display (like ASUS portable display MB169C+) to secondary port in Thunder3?

I am asking about performance impact...

It will be like with standard display connected to eGPU card standard output? - no bandwidth usage for sending video signal back to laptop LCD
Or like with laptop LCD - some "reverse" bandwidth usage
Or maybe even worst since signal needs to be first send to eGPU then back to the laptop and again to the eGPU box?


ReplyQuote
amoeba
(@amoeba)
Eminent Member
Joined:9 months  ago
Posts: 26
January 24, 2018 11:56 am  
Posted by: raphax

Note: ZOTAC 1050TI work with default akitio thunder3 power supply! 😀

Without modding? As I understand it, the default circuitboard only provided 25W to the PCIe? If you want more, you need to mod the circuitboard?


ReplyQuote
esatamacmodular
(@esatamacmodular)
Eminent Member
Joined:2 years  ago
Posts: 29
February 3, 2018 6:18 am  

I just picked up a node lite and it sounds like a firmware update and power supply upgrade will allow for a 1060 or 1080 as one of the members has posted. However these both are implemented in windows 10. Is there any support or drivers/ web drivers that might make nvidia 10XX series work in os x or windows 7 with the node lite? Maybe I should make a thread, but this is where all the cool kids are hanging out.


ReplyQuote
(@aiy_jey)
New Member
Joined:5 months  ago
Posts: 2
March 26, 2018 11:20 am  

Hi, 
I went for the Akitio node Lite + GeForce GTX 1050 Ti build with an additional 120W power supply as suggested but it seems its not enough. I get an error in the Windows device manager with the error code 43. It seems the recommended power supply for it is 300W. Has anyone got it to work with 120W? What are my options here? 

Thanks for your help ! 🙂


ReplyQuote
(@aiy_jey)
New Member
Joined:5 months  ago
Posts: 2
March 27, 2018 10:20 am  

Alright I got it to work! There's a firmware update to do for the Akitio Node Lite :  https://www.akitio.com/firmware/node-lite-firmware


ReplyQuote
esatamacmodular
(@esatamacmodular)
Eminent Member
Joined:2 years  ago
Posts: 29
March 28, 2018 3:33 pm  
Posted by: AiyJey

Alright I got it to work! There's a firmware update to do for the Akitio Node Lite :  https://www.akitio.com/firmware/node-lite-firmware

Sweet. Can you describe your specific setup and what works? Maybe add it to the successful builds page?


ReplyQuote
Edward.Che
(@edward-che)
Active Member
Joined:1 year  ago
Posts: 9
April 11, 2018 1:31 am  

Hi @enjoy, very nice instructions. I learned a lot. Now i'm having a problem. I have a Akitio Thunderbolt 2 box and a GTX 1070 with a 2013 macbook pro. I tried to follow exactly the steps, but the eGPU is still not detected by my computer. No black screen, no compatible issues. Just not detected. I searched online, and some people said it's because the eGPU is not correctly powered. But when connected with my macbook, the fan is actually running and the light of PCIe box is on (see attached picture). I am really poor into computer knowledge. I tried to give you a clear image of my set-up. Could you give me any suggestions of what I might do wrong with it? Thanks a lot!

MBP 15 (Late 2013)+eGFX Breakaway Box+TB3 to TB2 adaptor+GTX 1070+DELL P2415Q


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 2, 2018 2:41 pm  

Hey Guys,
I`m kinda stuck here so hopefully anyone can help.
my Setup:
HP Spectre x360 i5 8250U 8GB RAM 256GB SSD
Akitio Thunder 3 with  Noctua Fan from ebay
Cal Digit 2m TB3 Cable new
Leicke 90W PSU new
Zotac 1050TI 4GB new
When i plug in the TB3 Cable the blue LED is lighting up.
Thunderbolt Software shows me one connected device: inXtron Akitio Thunder3 PCIe Box
status: connected
but the Noctua Fan is not spinning. The 1050ti fab doesn`t move and the card does not show up in the
device manager.
Thunderbolt Software is version 16.3.61.275
NVM Version 20
any suggestions? i`m out of ideas.


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
May 2, 2018 2:51 pm  

Sounds daft, but are you sure everything is connected right? Thats about the extent of my tech knowledge....

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 2, 2018 2:59 pm  

Well, at least the cables are in place....
The Akitio Case is recognized. But the Graphics card isn`t working.
Unfortunately I don`t have any other devices to test it.


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 2, 2018 3:02 pm  

OS is Win10 Home, could that cause a problem?
Should i upgrade to Pro?


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
May 2, 2018 3:15 pm  

You dont have a PC to pop the 1050 in? Have you built PC's before? I have failed to seat a GPU properly many times before....

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 2, 2018 3:46 pm  

I meant I don`t have any other TB3 Device or PCIe Card to test the Akitio.
The 1050 is fine. I put it in my PC and it worked.
Maybe 90 W isn`t enough Power or the PCIe Port doesn`t deliver enough.
But as I said, I have no other devices to test it.


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
May 2, 2018 3:49 pm  

It shouldn't be power issues as I ran a 1050 with the stock PSU which is less... where are you based? Got a pal with a PC you can test GPU's with?

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 2, 2018 3:54 pm  

I`m more concerned that the Akitio might be broken. Or it`s a software issue.
Like I posted earlier, everything is new except the  Thunder 3.
I even had to buy a new TB3 Cable because the stock cable didn`t work.
I can return everything but the 200€ for the Akitio Box are gone if its a brick.
But tomorrow I´ll give it to a friend with a MBP. Maybe he can get it to work.


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812
May 2, 2018 3:59 pm  

If you bought it on eBay you can request a refund if it doesn't work. The light being on suggests it does work though. The stock cable should work though, so thats also odd.

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 2, 2018 7:00 pm  

Yes it's odd. But I have no idea what else it could be.


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 3, 2018 8:27 am  

Is it normal that only the LED is on in the beginning? When will the fans start spinning? when i install the drivers?


ReplyQuote
Username
(@username)
Estimable Member
Joined:1 year  ago
Posts: 177
May 3, 2018 1:40 pm  
Posted by: klausmeine

Is it normal that only the LED is on in the beginning? When will the fans start spinning? when i install the drivers?

My Thunder3 and KFA2 1070 performance that way.
The drivers is needed to initiate the 1070. Until those are properly loaded, the fans barely turns once in a while as the card itself have temp controlled fans.
And no initiated card means no heat that need to be vented by the fans.

As soon as it boots with proper drivers, I get the Wooosh sound from the fans that confirms it is working!

2012 Mac Mini + GTX1070@10Gbps-TB1 (AKiTiO Thunder3 via TB3->TB2 adapter) + macOS


ReplyQuote
klausmeine
(@klausmeine)
Eminent Member
Joined:4 months  ago
Posts: 24
May 3, 2018 1:50 pm  

Well, so, the light is on. Internal Fan doesn`t spin. 1050 Fan doesn`t spin.
That`s normal as long as the card isn`t initialized, right?
But what other options do I have? Could there be any software, maybe preinstalled by HP, that keeps it from recognizing the card?


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Prominent Member
Joined:2 years  ago
Posts: 812

ReplyQuote
Page 7 / 8 Prev Next