AORUS Gaming Box: What GPUs do work, and which ones do not?
 
Notifications
Clear all

AORUS Gaming Box: What GPUs do work, and which ones do not?  

 of  14
  RSS

jisongkun
(@jisongkun)
Active Member
Joined: 2 years ago
 

@arzen, sorry for the late reply, here is the result with one external display, internal display deactivated and no H2D optimized firmware.

 

no, I'm not Korean but I did spend a solid few years in the states and UK. 😛

 

External Screen No Dummy Plug F1.0 Firmware

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

Arzen liked
ReplyQuote
Arzen
(@arzen)
Trusted Member
Joined: 3 years ago
 

@jisongkun, holy cow. That is almost double my 580's score!

Seems worth the upgrade! Here is a screenshot of my 580 Gaming Box running the same benchmark:

Screen Shot 2020 09 18 at 21.38.04

I recently modified my 16" MBP by adding thermal pads to the VRMs to stop the throttling on the CPU/GPU. I also disabled Turbo Boost with the Turbo Boost Switcher app.

Here is the score from my 5500 w/ 4GB dGPU on the same settings for reference:

Screen Shot 2020 09 18 at 21.55.07

 

TLDR; 580 ITX, 5700 ITX, Sapphire Nitro 5700 XT (thanks @raebyagthefirst):

Screen Shot 2020 09 18 at 21.38.04
Screen Shot 2020 09 19 at 10.08.10
10469 Screen Shot 2020 09 18 at 16 43 36

 Update: Here are my results from a Mantiz Saturn Pro II + PowerColor Red Devil 5700 XT on MacOS 10.15.7 (1600x900 and 1920x1080p):

Screen Shot 2020 09 30 at 20.22.29
Screen Shot 2020 09 30 at 20.28.04

 

This post was modified 3 weeks ago

MacBook Pro 16" - 2.3 i9, 16GB, 1TB, 5500m (I added thermal pads to the VRMs); Mantiz Saturn Pro w/ PowerColor Red Devil 5700 XT (previously, a Gigabyte RX 580 Gaming Box) + LG OLED C9


ReplyQuote
jisongkun
(@jisongkun)
Active Member
Joined: 2 years ago
 

@arzen, nice charts! but I have to say relying on eGPU playing games under mac os may not be a good choice, sadly I realized this truth after I paid too much money xd.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Arzen
(@arzen)
Trusted Member
Joined: 3 years ago
 

@jisongkun, I am loving mine. I can play WoW on maxed settings at 4K resolution. 😉

What other games do you play on MacOS?

 

MacBook Pro 16" - 2.3 i9, 16GB, 1TB, 5500m (I added thermal pads to the VRMs); Mantiz Saturn Pro w/ PowerColor Red Devil 5700 XT (previously, a Gigabyte RX 580 Gaming Box) + LG OLED C9


ReplyQuote
jisongkun
(@jisongkun)
Active Member
Joined: 2 years ago
 

@arzen, I was hoping I could boot to Bootcamp windows for steam games, but it often results in error code 43 or something, even after I used EFI boot file. not mentioning micro stuttering during other compatible online games. I did try the thermal pad mod, turbo boost disabled, and separated thunderbolt dock for peripherals, it still didn't give me a good experience. so I built a small 4L gaming pc at the end. 🙄

 

I guess for my needs on Mac OS, a new 16inch MacBook pro with a build-in Navi graphics card would be totally enough. 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Leno6789
(@leno6789)
New Member
Joined: 2 weeks ago
 

Hi.

I have an Aorus 1070 gaming box that I purchased some time ago without the GPU. I put a Radeon R9 Nano in and it has been working pretty well (apart from the odd fans at max speed after the laptop is shit down. Usually stuff. 
The Gaming box is connected via thunderbolt 3.0 to my 2019 Huawei Matebook X pro with a built in MX250.

I have recently bought a 1440p monitor to run games at 1440p but the R9 isn’t up to it (avg 40-50fps). So I bought a powercolor RX5600XT ITX from Scan.co.Uk brand new, hoped it would just be plug and play like the R9 Nano was but it just doesn’t run at all. The gaming box PSU fan is running but it doesn’t seem like the 5600xt is getting any power and no led’s lighting up on the PCB. Aorus engine will not run either.

 
I can confirm I am using the dedicated TB3 port which I’ve had no dramas using before. 
I have installed all latest windows updates, Aorus engine is fully updated and I’ve installed the latest firmware. I have tried to install the Radeon software but the 5600xt isn’t even recognised. 

I am wondering wether there is a TB3 software problem as the gaming box isn’t even recognised in the TB3 control panel sometimes. 

I have tried uninstalling Aorus engine and associated software and TB3 software centre and re-installed them to no avail. I have even tried to update the TB3 software but after uninstalling TB3 software and going into device manager with the gaming box attached, I don’t get any errors in the “other devices”. 

I wanted to go with a ITX 1070 but I though as I have a dedicated on board MX250, the conflicting would be more hassle than they are worth. 

 I am trying to reset my PC at the moment to see if that helps. Failing that I have no idea what to do. 

 

Any help would be very much appreciated. 

Thanks. 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
howoarang
(@howoarang)
Active Member
Joined: 3 weeks ago
 

Hi, it seems I have same problem as you have. I bought used Aorus Gaming Box without GPU card and also bought Powercolor RX 5600 XT ITX card, and it is not recoignized. Aorus gaming box is recoignized under Mac OS Catalina or Windows 10 without RX 5600 XT card only. 

I need some help, too.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Leno6789
(@leno6789)
New Member
Joined: 2 weeks ago
 
Posted by: @howoarang

Hi, it seems I have same problem as you have. I bought used Aorus Gaming Box without GPU card and also bought Powercolor RX 5600 XT ITX card, and it is not recoignized. Aorus gaming box is recoignized under Mac OS Catalina or Windows 10 without RX 5600 XT card only. 

I need some help, too.

It’s infuriating mate. 

So last night I unplugged and removed the 5600xt, restarted windows 10 and it was recognised in the TB3 control centre and Aorus engine started up. The LED lights also lit up on the gaming box.

I guess the newer AMD cards just aren’t supported yet 🙁

I’m going to return the 5600xt and look at other GPUs or other EGPU enclosures as there seems to have been a LOT of problems over the past few years with the gaming box. Especially if you have a dedicated GPU in your laptop (like is have). 

Hope you get yours sorted soon. 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
howoarang
(@howoarang)
Active Member
Joined: 3 weeks ago
 

Now I am reading some post about power modification on Aorus gaming box, so I think, it can help. If I will be succesful, I post some instructions.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Leno6789
(@leno6789)
New Member
Joined: 2 weeks ago
 
Posted by: @howoarang

Now I am reading some post about power modification on Aorus gaming box, so I think, it can help. If I will be succesful, I post some instructions.

That would be great mate 👍🏻

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  14