Clevo p751 with HP G2 dock : video output missing
 
Notifications
Clear all

Clevo p751 with HP G2 dock : video output missing  

  RSS

Luca Barbetta
(@luca_barbetta)
New Member
Joined: 3 months ago
 

Hi all,
they say you know a lot about thunderbolt, i'm here bothering you because no one had a clue on this problem.
With the company pc (HP Zbook studio G2) they gave me a HP 230W (lol) Thunderbolt G2 Dock.
I Have a Clevo P751TM1-G and i'm trying to make it work with the dock, perfectly functioning with the Zbook.
With the Clevo, USB and Ethernet works fine while the two monitors (HP 27'' and HP 22'', both 1080p) are fully recognized and the pc acts like its driving them, but they're reporting no signal is available and remaining black.
For "acts like its driving them" i mean they figure on screen settings, NVIDIA control panel, the pointer goes there while extended and so on.
They are connected to the dock via displayport to HDMI adapter and an HDMI cable, however a direct DP cable presents the same issue.
Without the dock, using an HP USB-C to DisplayPort adapter connected to the thunderbolt and the DP cable, the main monitor is working fine; so the signal goes out from the thunderbolt and is blocked by the dock for some reason.

So far i've done:
BIOS Thunderbolt security policy on "unique ID"
BIOS DDI control set to "DP to TBT"
Monitor DP hotplug detection set to "always active"
Installed HP G2 dock drivers SP101240 and SP99420

Thanks in advance

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

What if you try connecting only one display? Try either DisplayPorts? Try USB-C to DisplayPort adapter from USB-C port and from Thunderbolt port?

When connecting two displays, Try connecting the first display to one of DisplayPort1,DisplayPort2,USB-C and connect the second display to the Thunderbolt port. This can only work if the Clevo's Thunderbolt port supports two DisplayPort connections. If it does not, then both displays need to be connected to DisplayPort1,DisplayPort2,USB-C/VGA (because those ports are part of a DisplayPort 1.4 MST hub).

Maybe the Clevo doesn't like the DisplayPort 1.4 MST hub of the dock? It might need a firmware update - (it was one of the first docks to use this DisplayPort 1.4 MST hub). You can get standalone DisplayPort 1.4 MST hubs.

https://www.cablematters.com/pc-1220-126-usb-c-triple-4k-displayport-mst-hub-with-dual-displayport-and-hdmi-for-windows.aspx
https://www.club-3d.com/en/detail/2485/multi_stream_transport_(mst)_hub_displayport_1.4_triple_monitor/
https://www.startech.com/ca/AV/display-and-video-adapters/Displayport-Adapters/displayport14-mst-hub~MST14DP123DP

You don't have 4K displays, so a DisplayPort 1.2 MST hub should be sufficient (and less expensive). Also, If the Clevo doesn't have Titan Ridge Thunderbolt 3 controller (or it does not support DisplayPort 1.4 output) then a DisplayPort 1.4 MST hub will be overkill (but you could use it for a future setup).

 

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote