Enclosure & Hardware Discussions
Devilbox USB stopped working
 

Devilbox USB stopped working  

  RSS

yoshiwaan
(@yoshiwaan)
Active Member
Joined: 3 years ago
 

Hi folks,

After almost 2 years of use my Devilbox USB ports stopped working yesterday. I suspect a hardware failure, but with the particular cocktail of softwares and back alley firmware needed to run this thing properly you never know...

Devices plugged into the Devilbox USB ports don't seem to get any power, devices plugged into a USB hub which plugs into the Devilbox USB port say Set Address Failed or Port Reset Failed in device manager (but at least there is some signal going along there). Those same devices plugged straight into my laptop (XPS 9550 running Win 10) work fine.

I've tried:-
- Updating Thunderbolt 3 software
- Completely uninstalling and re-installing TB3 software (with restarts between each step)
- Removing the TB3 software approvals for the device then reconnecting
- Dusting with compressed air

It worked yesterday with a couple of disconnects which a reboot fixed, now it doesn't work at all.

I'm not sure how exactly to debug, hardware has never been my strong suite. Has anyone else had this or is there a Powercolor rep. on here that can help out?

Cheers

- Dell XPS 9550
- Windows 10
- Devilbox
- GTX 1080


ReplyQuote
Topic Tags