eGPU being finicky, i am are need help pls
 
Notifications
Clear all

eGPU being finicky, i am are need help pls  

  RSS

L1FT
 L1FT
(@l1ft)
New Member
Joined: 11 months ago
 

I've had a few problems with this in the past, where my eGPU straight-up refuses to be detected by my computer, and I've always figured out a way to solve it. The problem is, this happens somewhat often (every 1-2 months) and I'm getting tired of needing to spend around four hours every time to make it work. It's an GIGABYTE RX580 Gaming Box. My house had a small blackout today, not even lasting half a second (felt like someone just tapped the "cut off this poor house's power" button) and of course, my bitch of an eGPU decides to stop functioning. Everything I've tried before doesn't seem to work anymore, and this is quite annoying considering that my eGPU also connects my laptop to the rest of my setup. 

Some technical info:

Computer model: Lenovo T480

eGPU: GIGABYTE RX580 Gaming Box

This is just a small record of what I've tried so far:

Restart computer

-> Doesn't work

Uninstalled TB3 HSA component and TB3 Controller
Reinstalled the above
Restart computer

-> Doesn't work

Desperately pleaded my computer to function
Restart computer

-> Doesn't work

 

Any help would be appreciated!

On a side note, I can hear the "current noise" from my eGPU (whatever that high-pitched noise is), so I don't think the blackout fried it. Also, plugging it into the power slot of my computer makes my computer tell me that it has limited functionality on the port, but it still doesn't respond to the TB3 port.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
L1FT
 L1FT
(@l1ft)
New Member
Joined: 11 months ago
 

WOOOOO alright so my computer detected the eGPU except another issue has popped up.

The Thunderbolt Control Center thing doesn't want to connect to the eGPU. From what I know, after the user selects an option the program usually just closes, except this kind of just sits in a corner and throws a middle finger at me. By that, I mean the attachment on this post. If I just close and open the program again, it returns to "Do not connect".

image

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote