FCP X with Vega 64 in Razer Core V2, MBP 2014 over TB2.
 
Notifications
Clear all

FCP X with Vega 64 in Razer Core V2, MBP 2014 over TB2.  

  RSS

ISJ
 ISJ
(@isj)
New Member
Joined: 1 month ago
 

Context: I have a 2014 MBP 15" (Thunderbolt 2) and needed to improve performance of FCPX workflow whilst I wait for the redesigned iMac to be released (been waiting over a year now and my MBP only has the integrated Intel graphics)

Hardware: Sapphire Radeon Vega 64 in Razer Core V2, connected by TB2 to MBP and external display connected to eGPU directly via display port cable.

Software: Catalina with FCPX 10.4.8

History: my MBP has never skipped a beat in 6 years but now I've gotten into video editing and needed to beef up the performance. Once you add Cinema grade and stabilisation and noise reduction over clips the rendering starts to get painfully slow on such an old machine. I'm not too bothered about export times as this is a hobby, I'm not a YouTuber or using it professionally. Couldn't wait for the redesigned iMac, which has been delayed again at WWDC... So I did some research and came across eGPUs as the solution to my problem and saw many YouTube videos of people successfully ramping up the performance of their TB2 MBPs with eGPUs. I bought the Blackmagic eGPU from apple initially and used the barge-wrangler script to install it. Had the initial blank screen issue but ran the other script to solve that - but the monitor was running painfully slow despite being directly connected to the eGPU, frame rate was low and my MBP constantly crashing, especially every time it tried to sleep. None of the solutions worked, whether it be changing the primary display, changing the connections etc, I tried everything.

So I bought a Razer Core V2 and Vega 64 on eBay after doing further research, problem partly solved. The monitor now runs very smoothly, and scrubbing the timeline is perfect. However some problems still exist:

- My MBP still crashes every time it sleeps. It never crashed in 6 years before I messed with it...

- FCPX still doesn't seem to be using the eGPU fully to render video. For example the timeline I am using is a heavily edited 30sec timeline of clips with some noise reduction, cinema grade and stabilisation and also some mFlare 2 effects in there. This timeline was taking 2min 5sec to render prior to the eGPU. With the Blackmagic it never got under 5min and it seems to render even slower with the Vega 64 despite the fact that Catalina seems to like the Vega 64 much better than the RX580 in the Blackmagic, and doesn't make my computer completely unusable. The rendering times were the sole reason for getting an eGPU so that I can speed up my workflow and this seems to be the only thing that FCPX won't use the eGPU for... I've changed the preference in FCPX to prefer the external for rendering/sharing but it won't do it. It does use the Vega whilst rendering but the Vega never gets above 30% in activity monitor and it is taking 3 time longer than the integrated intel graphics for the same timeline... it makes no sense to me! My research suggests that 10.4.6 would solve this issue but I don't have a copy of that and don't know where to get it... 

I have 3 questions I hope someone can answer:

1. Is there a solution to my MBP crashing every time it sleeps? 

2. Does anyone have a link to a copy of FCPX 10.4.6 they can send me?

3. Will apple fix this issue in FCPX? Is it a bug or deliberate somehow?

 

Sorry for the long post and TIA.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote