Enclosure & Hardware Discussions
Gigabyte AORUS RTX 2070 Gaming Box into Razer Blade Stealth Early 2019 - No Thun...
 

Gigabyte AORUS RTX 2070 Gaming Box into Razer Blade Stealth Early 2019 - No Thunderbolt Device Detected at All  

  RSS

antihumorous
(@antihumorous)
New Member
Joined: 3 months ago
 

I was using a GTX 1080 box, but the power supply was faulty so I sent it back. They sent me an RTX 2070 in return, but this box doesn't respond at all when plugged in. No new devices in Device Manager (even a Base System Device), no nothing.

 

The PSU fan on the box spins up and the laptop charges, but there isn't any activity in the Thunderbolt Control App. I've tried reinstalling the Thunderbolt software and drivers, reinstalling GPU drivers, rolling back and upgrading Windows. I've tried every combination of reboots and reinstalls and power cycles and plugging and unplugging.

 

Furthermore, I know this thing accepts Aorus boxes because it worked with the 1080 box for a long time. I've tested the port with a TB3 hub and it worked, and I took the eGPU to Best Buy and plugged it into a Mac. Both halves work perfectly, they just don't talk to each other.

 

Even if I can't get any particular help with this, I wanted to put this here as a warning to others. This has been a nightmare. Gigabyte told me "hey, sell the box and buy a Razer Core" which is very Gigabyte of them. Razer escalated me to Super Double Secret Level 2 Support, who told me "I dunno, tried everything, good luck."

 

Beware.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

The Gaming Boxes tend to have power up issues when hot-plug to a Thunderbolt host. Have you tried a power reset? Basically leave the Thunderbolt 3 cable connected to your Blade Stealth but disconnect the power cable. Let it sit there for 15 minutes then reconnect the power cable. You can also try to boot the Blade Stealth up with the Gaming Box connected.

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote