[GUIDE] Update Thunderbolt 3 eGPU enclosure firmware in Boot Camp
 
Notifications
Clear all

[Sticky] [GUIDE] Update Thunderbolt 3 eGPU enclosure firmware in Boot Camp  

 of  11
  RSS

steve500
(@steve500)
Eminent Member
Joined: 2 years ago
 
Posted by: mikegleasonjr
Posted by: DarkEchoes

Been fighting with my Gaming Box 1070 for the last week trying to update it to the H2D firmware. Finally broke down and contacted Gigabyte to see what help they could offer, and after some back and forth they are willing to RMA it and update it themselves.

Hey, my Gigabyte Gaming Box (RX580) died. The Thunderbold controller is recognized and the LEDs are on, but the card fan does not work and the video adapter is not appearing. How did you start the RMA procedure? Thanks!

First post here, hi! 

Chiming in to help you out. If you haven't already RMA'd your unit, these Gigabyte 1070 mini rev1 cards have been prone to failure, well known in the mining community. I received an "untested" Aorus 1070 egpu from ebay today, it did not work. Powered up, RGB's lit up, but the card fan never did spin. Computer sees the thunderbolt controller but no GPU at all. 

These cards blow a fuse, the white fuse with a "10" on in on the back-side near the PCIE connector was blown. I bridged it with a dab of solder. 

Works great now.

This post was modified 2 years ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
mikegleasonjr
(@mikegleasonjr)
Eminent Member
Joined: 2 years ago
 

Chiming in to help you out.

Thanks!

Unfortunately, I tested the same fuse with a multimeter and the resistance is 0 across it (which tells me it's not blown) 🙁

I am hesitating to return the card since I bought it in Canada and now I live in Morocco. The shipping will be the price of a new card (200 USD on newegg these days) and I have to provide a return address in Canada. Really a shame.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

steve500 liked
ReplyQuote
5656hcx
(@5656hcx)
Active Member
Joined: 2 years ago
 

@itsage Have you tried to install the latest BIOS and F1.1 PSU fan firmware? The procedure for them is different from this thread (flash H2D firmware) and the updater can fail to detect gaming box and graphic card.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
steve500
(@steve500)
Eminent Member
Joined: 2 years ago
 

I was 100% unable to update the firmware of my Aorus gaming box on my 2018 Macbook pro

The 2018 uses Titan Ridge revision of thunderbolt controllers which do NOT support downgrading the driver version to the version Gigabyte asks us to downgrade to for supporting the firmware update utility.

I already discussed this with Gigabyte that Titan Ridge revision computers CANNOT update the firmware and their utility needs to be updated. They were hard to work with. In the end, they said they will forward my complaints to developers. 

I ended up updating my Aorus box using a 2016 MBP that was fully able to downgrade the thunderbolt controller driver to the version Gigabyte requests, firmware update utility works perfectly there. 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
jgrove
(@jgrove)
Active Member
Joined: 2 years ago
 

The fan update, stops the PSU fans running for both Windows and MAC but fails to shut the unit off, therefore you can still hear to hum of the PSU, the only way to power it off is to remove the TB3 cable from the host.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
jangoloti
(@jangoloti)
Trusted Member
Joined: 2 years ago
 

Dear all

Has somebody realised that the firmware version 17.1.64.250 (we should be at 17.3 by now) added support for Apple* Boot Camp in Secure Connect mode (SL1)?

It is written in the release notes included with the FWupdatetool of my Galax/KFA2 eGPU.
 
Can that help? How do we setup that mode?

JA

Mac Mini 2012 and 2018 i7, Mac book Pro 2016 15" with TB, eGPU Galax/KFA2


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

Thank you for sharing the release notes. I've noticed the latest versions of Intel Thunderbolt Software work well with Thunderbolt 3 Macs in Boot Camp. Apple set the firmware of these Macs to No Security (SL0). Here's the one from the 2018 Mac mini.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
jangoloti
(@jangoloti)
Trusted Member
Joined: 2 years ago
 
Posted by: itsage

Thank you for sharing the release notes. I've noticed the latest versions of Intel Thunderbolt Software work well with Thunderbolt 3 Macs in Boot Camp. Apple set the firmware of these Macs to No Security (SL0). Here's the one from the 2018 Mac mini.

You are welcome, that is my two cents.
They do not with my MBP and KFA2 EGPU, maybe because I have an old firmware version. As you see in my questions to @OliverB I cannot get it to work in Bootcamp for the firmware update. I think I have to get a PC with TB3 tomorrow in the office.
Should that work?

Mac Mini 2012 and 2018 i7, Mac book Pro 2016 15" with TB, eGPU Galax/KFA2


ReplyQuote
buffaloseven
(@buffaloseven)
Active Member
Joined: 2 years ago
 

I was able to successfully update the firmware for the RX 580 Gaming Box on my 2018 Macbook Pro with little to no issue. Ultimately, I just installed the latest version of the Intel Thunderbolt Software (linked in the OP), and then I downloaded an updated version of the Intel Thunderbolt Firmware Update Tool. I then followed Gigabyte's instructions included in the firmware download and everything worked -- no errors, no hotplugging needed, just load, select, go, and restart.

2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 580 @ 32Gbps-TB3 (Gigabyte Gaming Box) + macOS 10.14 & Win10 [build link]  

itsage liked
ReplyQuote
FlyingTexan
(@flyingtexan)
Eminent Member
Joined: 2 years ago
 

Ok I'm having issues trying to install the gigabyte software "Error while getting the PD Software version".  It tells me to uninstall the TB driver so I do then the program doesn't even load so I go back an run the intel firmware for TB, get it going, get back into the gigabyte program, same error.

I'm on the 2017 MacBook Pro with the Auros Gaming Box GTX 1070 plugged into the left side and I'm getting pretty frustrated.  What do I need to do. Any driver installs, etc, just lock up the whole computer.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  11