Macbook Pro 16'' not recognizing GIGABYTE RX580 Gaming Box (supported by apple)
 
Notifications
Clear all

Macbook Pro 16'' not recognizing GIGABYTE RX580 Gaming Box (supported by apple)  

  RSS

dorza
(@dorza)
Eminent Member
Joined: 2 years ago
 

Hey!

My MBP 16'' with 32GB ram & 2 gpu's inside it, is not recognizing the RX580 Gaming Box for some reason.

It is charging, but that's it - USB/DISPLAYS not working.

The gaming box is perfectly working with my 2014 15'' retina on Windows bootcamp, but not on MacOS.

**It's important to note that my 16'' MBP is running the latest MacOS Catalina... :/

 

Any advice/fix would be greatly appreciated.

MBP Retina 15’’ mid 2014 + GIGABYTE RX580
MBP 16'' 2019 + GIGABYTE RX580 (trying to make it work...)


ReplyQuote
dorza
(@dorza)
Eminent Member
Joined: 2 years ago
 

** Update:

In System Report -> under 'USB' this is what I see:

(Still nothing in GPU History or anything besides charging...)

System Report USB   Gaming Box

MBP Retina 15’’ mid 2014 + GIGABYTE RX580
MBP 16'' 2019 + GIGABYTE RX580 (trying to make it work...)


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago

ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

It's connecting the USB billboard device. That happens when it can't connect as Thunderbolt. Maybe a problem with the connector or cable.

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@dorza, Perform a power reset - unplug the power cable from the outlet and let the Gaming Box stay off for at least 10 minutes before reconnecting it to power.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
dorza
(@dorza)
Eminent Member
Joined: 2 years ago
 

@joevt, I use original cables, still no eGPU recognition - only charging.

 

Posted by: @itsage

@dorza, Perform a power reset - unplug the power cable from the outlet and let the Gaming Box stay off for at least 10 minutes before reconnecting it to power.

 

Hey, I've done it several times with no success... maybe the problem is Catalina?

thx

 

@eightarmedpet, thx for the links but unfortunately my macbook can't seem to recognize the Gaming Box even once so I think it's a bigger issue than connect/disconnect... probably an OS bug (?)

 

MBP Retina 15’’ mid 2014 + GIGABYTE RX580
MBP 16'' 2019 + GIGABYTE RX580 (trying to make it work...)


ReplyQuote
dorza
(@dorza)
Eminent Member
Joined: 2 years ago
 

*Update: still not recognising the eGPU... do you think updating MacOS is something I should do/avoid?

 

thx.

MBP Retina 15’’ mid 2014 + GIGABYTE RX580
MBP 16'' 2019 + GIGABYTE RX580 (trying to make it work...)


ReplyQuote