Notifications
Clear all

Mantis Venus - USB ports unusable  

 of  7
  RSS

alberto2000
(@alberto2000)
Active Member
Joined: 5 months ago
 

Has there been any update on this? I just got a brand new Mantiz Venus today and everything seems to work fine under MacOS, external SSD (powered through USB) seems to work, all good. But in BootCamp Windows 10 it doesn't even show up. Do I need to install any addtional drivers in Windows?

Macbook Pro 13" 2016 (no touch bar), i7 2.4 GHz, 16 GB RAM, Mantiz Venus, AMD RX 580


ikir liked
ReplyQuote
danamkaplan
(@danamkaplan)
New Member
Joined: 4 months ago
 

Yes, please. I am very frustrated. I put in a good amount of research to get a docking solution with ethernet, mouse, kb, and xbox controller connector and all components are practically unusable when plugged in. I cannot find a download, support, documentation or firmware on the Mantiz site @mymantiz_john

 

I found one link for a firmware installer, on reddit's r/egpu, but unfortunately, my current version of Windows 10 (March 2020) cannot detect egpu software to run it?

Mantiz Venus
Nvidia GTX 750 ti
Dell XPS 2in1 7390 (Core i7-1065G7 "Ice Lake")


ikir liked
ReplyQuote
alberto2000
(@alberto2000)
Active Member
Joined: 5 months ago
 

@danamkaplan, have you followed a build setup guide with a similar system? I got mine now fully working but it took quite a bit of work. Trickiest part was to get around the "Error 12" problem...

 

 

Macbook Pro 13" 2016 (no touch bar), i7 2.4 GHz, 16 GB RAM, Mantiz Venus, AMD RX 580


ReplyQuote
danamkaplan
(@danamkaplan)
New Member
Joined: 4 months ago
 

@alberto2000, Mine was bought on ebay so I'm not sure the firmware. I didn't follow a build guide. But my setup is:

  • Mantiz Venus (How can I tell v1 or v2)
  • Nvidia GTX 750 ti (The only card I had lying around, still surprisingly decent at 1080p low settings for modern games)
  • Dell XPS 2in1 7390 (Core i7-1065G7 "Ice Lake" and "Iris Plus Integrated GPU")
  • Logitech M510 mouse (2.4 GHz wireless reciever), Wired Mechanical KB, Ethernet, X360 Controller receiver - all in the rear ports of the Mantiz Venus.

All worked seemlessly plug and play (in both Windows 10 and Ubuntu 19.10), but the peripherials plugged in experience lag, mouse and ethernet cut in and out.

I really want to try out the firmware that would give bandwidth to the addition I/O but the mantiz site is no help and older threads like this one are hard to parse.

 

Mantiz Venus
Nvidia GTX 750 ti
Dell XPS 2in1 7390 (Core i7-1065G7 "Ice Lake")


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 4 years ago
 

Mantiz is not responding anymore... it seems they are gone.


MacBook Pro 2020 Touch Bar i7 quad-core 2.3Ghz - 16GB RAM - 1TB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15 [build link]  


ReplyQuote
 of  7