US$349 Mantiz Venus TB3 enclosure/dock
 
Notifications
Clear all

US$349 Mantiz Venus TB3 enclosure/dock  

 of  112
  RSS

Demetri
(@demetri)
Active Member
Joined: 3 years ago
 

Sorry if this has already been asked and answered, but I've just installed an SSD into my Mantiz and there is Win10 installed on it (installed using this tutorial form Mantiz's own blog -  https://mymantiz.com/blogs/news/how-to-install-window-10-on-an-external-ssd-for-mbp-mantiz-venus-sata-ssd)

I can boot into Windows when this SSD is in a USB 3.0 enclosure perfectly fine, but here I don't get an option to do this, as after I hold the option key on start only Macintosh HD shows up. 

The SSD is recognized in MacOS and mounts seconds after I login, but I can't boot from it. 

What am I doing wrong?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

vertice liked
ReplyQuote
vertice
(@vertice)
Active Member
Joined: 3 years ago
 

Just got my Mantiz Venus today from Amazon, construction quality is great and it has been plug and play with my 2017 Razer Blade.

2 Questions:

1) Even after updating the firmware, any peripherals I have connected to the Mantiz constantly connect and disconnect. Anything that can be done about this?

2) The case fan is really quite loud in either configuration. Can I leave it disconnected? All I have in there is my GPU (GTX 1070 with aftermarket style cooler with 2 fans).

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

 

Posted by: Demetri

Sorry if this has already been asked and answered, but I’ve just installed an SSD into my Mantiz and there is Win10 installed on it (installed using this tutorial form Mantiz’s own blog –  https://mymantiz.com/blogs/news/how-to-install-window-10-on-an-external-ssd-for-mbp-mantiz-venus-sata-ssd)

I can boot into Windows when this SSD is in a USB 3.0 enclosure perfectly fine, but here I don’t get an option to do this, as after I hold the option key on start only Macintosh HD shows up. 

The SSD is recognized in MacOS and mounts seconds after I login, but I can’t boot from it. 

What am I doing wrong?

thanks to @Rushvora; please check the post; late-2016-15-macbook-pro-rp455-gtx-1080ti32gbps-tb3-mantiz-venus-windows-10-external-ssd

Posted by: vertice

Just got my Mantiz Venus today from Amazon, construction quality is great and it has been plug and play with my 2017 Razer Blade.

2 Questions:

1) Even after updating the firmware, any peripherals I have connected to the Mantiz constantly connect and disconnect. Anything that can be done about this?

2) The case fan is really quite loud in either configuration. Can I leave it disconnected? All I have in there is my GPU (GTX 1070 with aftermarket style cooler with 2 fans).

1. what peripherals? in which port? 

2. please make sure the case fan is in the first ( count from the left ) fan connector. it is not loud. 

Mantiz: ● ●


ReplyQuote
PepeCZ
(@hr1bek)
Trusted Member
Joined: 3 years ago
 
Posted by: OtaXou

Note for french buyers : I just payed 104€ of customs clearence fees from DHL. Which put the total for my Venus at 337.65€ (converted by PayPal from 389$USD) + 104€ = 441.65€.

You may want to wait for Amazon :') I didn't expect the customs fees to be so high

Or you can buy my Mantiz Venus (old +- 2monzhs) for only +-310euro.

(EU, standart shipping is in this price for free, if someone prefer faster shipping for example via dpd,dhl,ppl,etc so must pay little more for shipping)

I want sell my silver Venus and buy dark grey 🙂 If someone want so write me.

LAPTOP = HP Spectre x360 13 Dark Ash Silver (i7-8565U, 16GB DDR4, 512GB SSD)
EGPU = Mantiz Venus MZ-02 Space Grey + PSU Corsair SF600 600W 80 Plus Gold
GPU = PowerColor AMD Radeon RX Vega 64 8GB HBM2
DISPLAY = Samsung C27FG73 | ROUTER = NETGEAR Nighthawk X4S R7800
KEYBOARD = Logitech G810 Orion Spectrum | MOUSE = Logitech G305 Recoil Black
CHAIR = DXRacer Racing OH/RV001/N
PHONE = OnePlus 6T MidnightBlack (8GB LPDDR4X, 256GB UFS2.1)


ReplyQuote
franketto
(@franketto)
Trusted Member
Joined: 3 years ago
 

I just discovered the Lenovo Yoga 720 can have TB3 @4x!

The 15'' normally has 2x because it has the GTX 1050 (8x connection) plus the Intel integrated 630. So, if you disable the GTX 1050 from BIOS, you still have the iGPU and if you connect the TB3 it becomes a 4x! Not bad.

But in my tests (on professional programs like Resolve) you will get more fps using a GTX970 on TB3 2x + GTX 1050 than the GTX970 alone @4x.

Tomorrow I will post some data, comparing also the Lenovo with the other desktop pc Asrock  I have, even that with TB3 2x, vs the same Asrock with 16x pci-e, same card 970.

Next week I will test Zotac 1080Ti Mini on the Mantiz on these systems.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@franketto, this would be wonderful if it's possible. I tested the 15" Yoga 720 with iGPU only and unfortunately the Thunderbolt 3 connection attached to x2 PCIe lanes. You can see PCI Express x2 Bus #6 under PCI Express Root Port #9.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2019 13" MacBook Pro [8th,4C,U] + RX 5600 XT @ 32Gbps-TB3 (VisionTek mini eGFX) + macOS 11 & Win10 2004 [build link]  


ReplyQuote
franketto
(@franketto)
Trusted Member
Joined: 3 years ago
 

I'm sorry itsage... I was in a hurry and I got better fps than when I used the Mantiz with the GTX 1050 not disabled, so... I thought I got 4x!

Instead no, it's still 2x.

But isn't this strange? With the 1050 active but not used by the prog, the TB3 970 2x is slower! What's going on?

Next I will post the data.

 

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
franketto
(@franketto)
Trusted Member
Joined: 3 years ago
 

Here it is, Resolve 14 Studio tests:

 

CPU + RAM   Lenovo Yoga
720 15’’
i7-7700HQ
16G
W10Home
Lenovo Yoga
720 15’’
i7-7700HQ
16G
W10Home
Lenovo Yoga
720 15’’
i7-7700HQ
16G
W10Home
Asrock Z270
Fatal1ty minitx
I7-7700
32G
W10Pro
Asrock Z270
Fatal1ty minitx
I7-7700
32G
W10Pro
Lenovo Yoga
720 15’’
i7-7700HQ
16G
W10Home
GPU   GTX 970
With INTERNAL
Display!!
GTX 970
With EXTERNAL
Display!!
GTX 970
With EXTERNAL
Display!!
+
GTX 1050 DISABLED
GTX 970 GTX 970 GTX 970
With EXTERNAL
Display!!
+
GPU 1050
TB3   Mantiz TB3 2x Mantiz TB3 2x Mantiz TB3 2x Mantiz TB3 2x   Mantiz TB3 2x
               
09 blur   10 24 28 28 35 32
18 blur   8 15 16 16 19 24
30 blur   7 9 10 10 12 14
66 blur   3 4 4-5 4-5 5 6
TNR 01   11 24 36 39 50 32
TNR 02   9 16-17 22 22 29 20
TNR 04   6 10 11-12 12 15 10-12
TNR 06   5 7 7-8 7-8 10 6-8

 

The tests that stress GPU are the 09-66 blur. The TNR is a mixed one, where CPU has its role.
As you can see using Internal display is awful. You must always use an HDMI connected to eGPU...
With 1050 on, but not used by the prog, you get 24fps that becomes 28 if you disable 1050. And TNR goes from 24->36!
This is what I'm marvelled... why?? Does this mean the TB3 2x is more throttled by the 1050 active, even if not used??!

So, disabling 1050 makes Lenovo TB3 2x the same power if put on a desktop pc (28=28, 36, slightly less than 39, but the other are identical).

If you use instead the combo 970 + 1050 you surpass even the desktop pc with pci-e 16x!! (apart the first 09blur of 35 vs 32, due to quite pure bandwidth use with light power CUDA cores)

Overall, TB3 @2x is something only -16/20% on blur GPU test, whilst regards the pci-e 3.0 @16x bandwidth is -88% !!

BTW:
I put some colors on the table, but it does not display correct (in edit mode they are there, but when posted, they disappear...)

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 
Posted by: franketto

I'm sorry itsage... I was in a hurry and I got better fps than when I used the Mantiz with the GTX 1050 not disabled, so... I thought I got 4x!

Instead no, it's still 2x.

But isn't this strange? With the 1050 active but not used by the prog, the TB3 970 2x is slower! What's going on?

Next I will post the data.

 

 

 

My guess is when the 1050 dGPU was active, the benchmarks were running off the dGPU and not eGPU. It was showing the wrong information which led to the confusion. When you disabled the dGPU, the benchmarks were able to use the eGPU.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2019 13" MacBook Pro [8th,4C,U] + RX 5600 XT @ 32Gbps-TB3 (VisionTek mini eGFX) + macOS 11 & Win10 2004 [build link]  


ReplyQuote
franketto
(@franketto)
Trusted Member
Joined: 3 years ago
 

No, Resolve shows which gfx card is using and I deselected the 1050  on purpose to see only the 970. In fact I tried also the 970 + 1050 and the results are much faster as expected. I also tried the 1050 alone and it has slightly slower results than the 970 alone.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  112