US$349 Mantiz Venus TB3 enclosure/dock
 
Notifications
Clear all

US$349 Mantiz Venus TB3 enclosure/dock  

 of  31
  RSS

Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 
Posted by: rawweb

Been using my Venus flawlessly since it delivered earlier this year (original group buy from this forum), then experienced some strange power behavior and decided to check my RX 580 GPU in my 2012 Mac Pro last night. Big mistake. Looks like I managed to bust off some resistors while trying to angle the GPU out of the enclosure :(. Really kicking myself. PSA: Be careful!

John at Mantiz is beyond helpful and was very responsive via twitter. So far, phenomenal customer service. I'm shipping my board to them for inspection/repair. 

just received your board today, will check how we can do with that in our business hour.

Thank you.

 

Mantiz: ● ●


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

I've tested thousands times that put the Game data in SSD will not cause any performance issue ( In Game or Pro Apps ) But it did load longer time, about few seconds  ( when you just started the game ) than the game data in Internal M.2 SSD. 

 

Mantiz: ● ●


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 
Posted by: dennisxx
Posted by: Mymantiz_John
Posted by: OtaXo

So just received the Mantiz Venus, great product btw excellent build quality.

The thing is... that I have the exact same problems as with my Razer Core, those I wanted to escape by buying the Venus :/ Well not as exact as before :

The problem lies with the USB ports. With my Razer Core, both my keyboard (Razer DeathStalker Chroma) and mouse (Razer DeathAdder Chroma) were laggy and completely unusable (both are 5V).

With the Mantiz Venus, I only have problems with my mouse, that's freezing every minutes or so. My Venus FW is updated to the last version, as well as my Thunderbolt drivers (and any drivers for that matters), and I already tried completely erasing the mouse drivers and reinstalling them from scratch. My mouse works flawlessly connected to any ports on my Razer Blade Stealth, this issue really is with the Venus, and on any ports for that matters front and back.

I'm tempted to do a fresh Windows install but I already did that to try and correct the problem back with the Core and this didn't solve anything. I hope not to have to do the same here but if nobody have a clue I guess I'll try it out this weekend. 

what's your laptop ? let me guide you how, Add my facebook, or twitter to have instant message to communicate. Thank you. 

I'm having absolutely similar issue: mouse and keyboard is lagging frequently when gaming(The Witcher 3 Wild Hunt) and mouse/kb receiver is connected to mantiz's usb ports (it stops working for a second or two it happens approx. each minute but I'm not sure if period is fixed-size or not). Both kb and mouse work flawlessly when receiver is connected to laptop. It is important to note that receiver is connected to usb cable and is placed absolutely same place and distance to mouse is the same in both cases: when cable is connected to mantiz and when to laptop.

And both work flawlessly when graphics card is not under load. From my understanding this issue most probably appears when TB3 bandwidth is all occupied by graphics and there is complettely no space for other consumer like USB ports. This most probably can be fixed by reserving some small bandwidth for each usb port - this should fix an issue.

context: latest Manitz Venus drivers, logitech anywhere mx wireless mouse + logitech k750 wireless keyboard on single nano receiver, windows 10 pro 64bit, dell 7480 laptop, mantiz venus + GF 1080 .

Also, I'm obserwing one more issue:

when my laptops wakes up first time (with mantiz powered and connected to laptop) it does not recognize my second display and then I put my laptop to sleep again and then wake it up again - that fixes this issue. This issue is absolutely persistent - it happens every time to me. I have to do this sequence ( wake-sleep-wake ) every time which is pretty much annoying and I believe can be fixed with drivers update which I hope will happen soon.

Also, I've noticed that time to time when you connect laptop to mantiz and/or wake laptop from sleep (while laptop is connected to mantiz) it does not power on usb ports i.e. my cell phone is not starting charge. Sleep-wake sequence seems to resolve this issue - but still - that is annoying and looks pretty much like a bug.

context: latest Manitz Venus drivers, logitech anywhere mx wireless mouse + logitech k750 wireless keyboard on single nano receiver, windows 10 pro 64bit, dell 7480 laptop, mantiz venus + GF 1080 .

regarding the system -sleep-wake-sleep-wake issue:

  I suggest you go to Dell Support site to update the latest Thunderbolt Driver and related Intel Chip driver ( Those are different version than Windows update sometimes ) Use Dell's.

We found the similar issue in XPS & Razer Blade stealth, after updated the issue should be solved.

 

Mantiz: ● ●


ReplyQuote
shazeal
(@shazeal)
New Member
Joined: 2 years ago
 

Got my Venus eGPU a couple of weeks ago,  and it is working great with my 15" 2017 rMBP, OSX 10.13.2.

 

Plugged in to the eGPU...

Sapphire RX 480 Nitro+ GPU

2TB Seagate Firecuda HDD

Logitech G810 Spectrum Keyboard

LAN Cable

 

I did have a couple of minor issues.

Stock fan is loud, not obnoxious, but enough that even when the GPU is idle it becomes annoying.

Replaced Fan with Noctua NF-A8 PWM 80mm 4-Pin PWM Fan and the issue is gone, the fan only really makes any noise when GPU is in use now. I had to buy some M4 cut to length cabinet screws to attach it in the case.

The other issue I cannot fix is the Logitech Gaming software for Mac does not seem to like my G810 keyboard being plugged in via the eGPU enclosure and refuses to detect the keyboard, this is most likely a software issue though since the keyboard works fine otherwise.

Performance is on par with the Hackintosh this card used to be in. And having a full docking solution with a single cable is amazing.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


itsage liked
ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 3 years ago
 
Posted by: shazeal

Got my Venus eGPU a couple of weeks ago,  and it is working great with my 15" 2017 rMBP, OSX 10.13.2.

 

Plugged in to the eGPU...

Sapphire RX 480 Nitro+ GPU

2TB Seagate Firecuda HDD

Logitech G810 Spectrum Keyboard

LAN Cable

 

I did have a couple of minor issues.

Stock fan is loud, not obnoxious, but enough that even when the GPU is idle it becomes annoying.

Replaced Fan with Noctua NF-A8 PWM 80mm 4-Pin PWM Fan and the issue is gone, the fan only really makes any noise when GPU is in use now. I had to buy some M4 cut to length cabinet screws to attach it in the case.

The other issue I cannot fix is the Logitech Gaming software for Mac does not seem to like my G810 keyboard being plugged in via the eGPU enclosure and refuses to detect the keyboard, this is most likely a software issue though since the keyboard works fine otherwise.

Performance is on par with the Hackintosh this card used to be in. And having a full docking solution with a single cable is amazing.

Can you explain more about the fan replacement? I've always wanted a tutorial for that.

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
agravatos53
(@agravatos53)
New Member
Joined: 2 years ago
 

 A question for Mymantiz_John : Can I use the Venus eGPU without a graphics card plugged in, as a normal Thunderbolt dock? Will the power supply turn off  or sleep if the macbook goes to sleep?

 I have a 15″ 2017 rMBP running High Sierra 10.13.2

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 
Posted by: agravatos53

 A question for Mymantiz_John : Can I use the Venus eGPU without a graphics card plugged in, as a normal Thunderbolt dock? Will the power supply turn off  or sleep if the macbook goes to sleep?

 I have a 15″ 2017 rMBP running High Sierra 10.13.2

without a graphic card , Mantiz Venus will be a USB docking station and when MBP sleep , Venus slept too.

 

Mantiz: ● ●


ReplyQuote
max
 max
(@max)
Active Member
Joined: 2 years ago
 

On your website it states "All international sales are final. No returns/exchanges." What does this mean? No warranty? 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
raybanner
(@raybanner)
Eminent Member
Joined: 3 years ago
 

Hi John,

can I use the Mantiz Venus 02 with a RX580 alongside my MBP 15" with 750m dgpu on High Sierra?

What is your experience with the custom costs when shipping to Germany?

 

Thank you!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

1. Yes.

2. mail us to have more information about the import duty & Tax. [email protected]

Mantiz: ● ●


ReplyQuote
robwil
(@robwil)
Active Member
Joined: 2 years ago
 

I just received my Mantiz Venus and have a possibly silly question. On the side panel vent, there is some clear plastic that is covering about half of the vent. Is this something we should leave in tact, or remove?

Mantiz Venus + Macbook TB3 : https://egpu.io/bootcamp-setup-guide-tb3-macbook-pro/


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

Just leave it, it makes much strong fresh air blowing into the the enclosure.

Mantiz: ● ●


robwil liked
ReplyQuote
Flint Ironstag
(@flint-ironstag)
Estimable Member
Joined: 3 years ago
 

This is definitely one of those instances where a picture is worth 1000 words.

My initial inclination (much earlier in the day) was to say "hey, that sounds like it's obstructing airflow through the ventilation holes - remove it"...  Then I figured I'd best ask for a pic, or read the manual first.

Now I definitely would love to see a pic of this situation.

Thanks!

MP 6,1 | 4c | d700
MP 6,1 | 6c | d500


ReplyQuote
XenonOne5000
(@xenonone5000)
Active Member
Joined: 2 years ago

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@xenonone5000 The 550W PSU in the Mantiz Venus should be able to handle RX Vega 56 cards.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
XenonOne5000
(@xenonone5000)
Active Member
Joined: 2 years ago
 

Thank you!! Going to pick one and give it a try. I was going for the sapphire (Everybody thinks those are the best choice), but apparently they have a 3-8 pin connector and not sure how I could make it happen in the Mantiz. I am a long time mac user, but this is truly a new science to explore for me. So since that could not work, this would be my next choice. Really grateful for the help. 

https://www.newegg.com/Product/Product.aspx?Item=N82E16814932030&cm_re=vega_56-_-14-932-030-_-Product

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

@XenonOne5000 @itsage
Yes I confirm having used a Vega 56 for few months inside a Venus


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
XenonOne5000
(@xenonone5000)
Active Member
Joined: 2 years ago
 

Awesome! Thank you so much!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
XenonOne5000
(@xenonone5000)
Active Member
Joined: 2 years ago
 

I want to really buy the sapphire Vega 56 nitro, and just faced a interesting dilemma. Its generally thought all those cards have a 3 - 8pins power supply connection, and off course I was afraid that would be a no go for the Mantiz. But looking at the regular nitro on newegg I realized that the regular nitro version (not the special edition with the blue decoration) does use a regular connection with two 8- pins. as its show in image below. So since the spec on the Sapphire website confirm that, I am assuming its a newegg website mistake. Does anyone had the same issue? Should just go ahead and get this one for the Mantiz?

Thanks as always! 

https://www.newegg.com/Product/Product.aspx?Item=N82E16814202310&cm_re=vega_56-_-14-202-310-_-Product

Screen Shot 2018 02 28 at 8.36.33 AM

http://sapphirenitro.sapphiretech.com/en/Vega56.html#specifications

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

That card should work. All the RX Vega 56 eGPU implementations so far have been the reference card with two 8-pin connectors.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
Zorn_
(@zorn_)
Eminent Member
Joined: 2 years ago
 

For what it's worth I've been using the Mantiz Venus with a Powercolor Vega 64 reference. I did go into Wattman and set P6 as the maximum state, so not sure how much difference that has made, but the card has been rock solid under both macOS and Win10.

2019 Razer Blade Stealth (GTX 1650, 2TB SSD)
Razer Core X Chroma (Upgraded with SF600 PSU)
ASUS ROG Strix 2080 Ti


hadin liked
ReplyQuote
hadin
(@hadin)
New Member
Joined: 2 years ago
 

Hi,

I have two questions:

1. Can I use the Mantiz Venus with my 13" Macbook Pro TouchBar 2016?

2. Does anyone have a hint about getting this in germany? It's about 400 Dollars in the US without any shipping, but the are quite some fees to pay when importing electronics. Is there something like a amazon in europe where I am able to buy the egpu?

Regards
Hadin

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

1. Yes.
2. contact us : [email protected] to get more information about the duty & Shipping.

Mantiz: ● ●


ReplyQuote
Kbaegis
(@kbaegis)
New Member
Joined: 2 years ago
 

So I bought my Mantiz to work with a 1080TI/Late 2016 MBP 15". My MacBook has never registered any PCI device as having existed inside the device. Am I doing something wrong or am I dealing with a product defect?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@kbaegis The attached Thunderbolt screen cap indicates the Mantiz Venus can communicate to your MacBook Pro just fine. Nvidia eGPU is not natively supported in macOS High Sierra. You need to use a workaround to enable it. Follow the setup guide here.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 
Posted by: Kbaegis

So I bought my Mantiz to work with a 1080TI/Late 2016 MBP 15". My MacBook has never registered any PCI device as having existed inside the device. Am I doing something wrong or am I dealing with a product defect?

Please contact us here

Mantiz: ● ●


ReplyQuote
FricoRico
(@fricorico)
Eminent Member
Joined: 3 years ago
 

I use the Mantiz Venus board with my Macbook Pro 2015 (TB2, M370X). I noticed that the expansion board causes boot freezing (black screen). Much like issues that can be resolved using PERST# workaround. Does anyone know why attaching the expansion board locks my Macbook.

I can hotplug the expansion board and use it without any problems.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Wunair
(@wunair)
Eminent Member
Joined: 3 years ago
 
Posted by: lancetchang

 

2. I connected the mouse and keyboard on the USB port at the back of the enclosure. When GPU heat it up, it seems that the keyboard connection is not stable. I am not sure whether is due to the temperature issue or something else?

 

Is there a solution/explanation to this? I seem to experience this problem as well. When GPU is on (slight) load, the connection seem to drop for a split second.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
FricoRico
(@fricorico)
Eminent Member
Joined: 3 years ago
 

Is anyone using this enclosure with Thunderbolt 2 equipped Macbooks? I wonder if anyone else is having any black startup screen issues?

For me the Macbook firmware is locking the startup when this enclosure is attached. Can't seem to get past that and it would be great to be able to reboot with the eGPU still attached.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 
Posted by: FricoRico

Is anyone using this enclosure with Thunderbolt 2 equipped Macbooks? I wonder if anyone else is having any black startup screen issues?

For me the Macbook firmware is locking the startup when this enclosure is attached. Can't seem to get past that and it would be great to be able to reboot with the eGPU still attached.

Yep, I had similar issue with the Devilbox & Mid 2015 15" (M370X). The culprit was either complexity of multiple ports that the firmware couldn't initialize in EFI or the dGPU. I don't remember exactly.

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread


FricoRico liked
ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 
Posted by: FricoRico

Is anyone using this enclosure with Thunderbolt 2 equipped Macbooks? I wonder if anyone else is having any black startup screen issues?

For me the Macbook firmware is locking the startup when this enclosure is attached. Can't seem to get past that and it would be great to be able to reboot with the eGPU still attached.

I believe @goalque's workaround - part of automate-eGPU.sh's automatic mode would be perfect for you - on every boot, setting the tbt-options NVRAM option to <00> (it was something like this if I recall correctly) would do it (make a daemon or something). Of course, @goalque knows best regarding this. Booting into windows would probably reset it.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro


FricoRico and goalque liked
ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 
Posted by: mac_editor
Posted by: FricoRico

Is anyone using this enclosure with Thunderbolt 2 equipped Macbooks? I wonder if anyone else is having any black startup screen issues?

For me the Macbook firmware is locking the startup when this enclosure is attached. Can't seem to get past that and it would be great to be able to reboot with the eGPU still attached.

I believe @goalque's workaround - part of automate-eGPU.sh's automatic mode would be perfect for you - on every boot, setting the tbt-options NVRAM option to <00> (it was something like this if I recall correctly) would do it (make a daemon or something). Of course, @goalque knows best regarding this. Booting into windows would probably reset it.

Yes, this setting keeps all TB devices invisible in EFI environment until the kernel takes control. It may work.

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread


ReplyQuote
ts1
 ts1
(@ts1)
Active Member
Joined: 2 years ago
 

Are there steps I have to take to enable the ethernet functionality? I'm on macos 10.13.4 and in my network preferences everything just shows as "not connected", although a dongle for ethernet-thunderbolt 3 does work. I've tried this link to install a driver but the download link is dead for me:  https://mymantiz.com/blogs/news/mantiz-venus-ethernet-driver
Although I would think that this firmware is already pre-installed as I bought this mantis very recently and that blog post is from july last year...

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@ts1 Try this link. The Mac drivers package is at the top.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
FricoRico
(@fricorico)
Eminent Member
Joined: 3 years ago
 
Posted by: mac_editor
Posted by: FricoRico

Is anyone using this enclosure with Thunderbolt 2 equipped Macbooks? I wonder if anyone else is having any black startup screen issues?

For me the Macbook firmware is locking the startup when this enclosure is attached. Can't seem to get past that and it would be great to be able to reboot with the eGPU still attached.

I believe @goalque's workaround - part of automate-eGPU.sh's automatic mode would be perfect for you - on every boot, setting the tbt-options NVRAM option to <00> (it was something like this if I recall correctly) would do it (make a daemon or something). Of course, @goalque knows best regarding this. Booting into windows would probably reset it.

Right! I forgot that this script is still very relevant.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ts1
 ts1
(@ts1)
Active Member
Joined: 2 years ago
 
Posted by: itsage

@ts1 Try this link. The Mac drivers package is at the top.

worked perfectly, thank you!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
 of  31